Einleitung

Vielen Dank, dass Sie die Software Hard Disk Sentinel verwenden. Hard Disk Sentinel wurde entwickelt, um mögliche Probleme im Zusammenhang mit dem Speichersystem zu überwachen, zu analysieren, zu melden, aufzudecken und zu beheben. Erkennen und überwachen Sie Festplatten, SSDs, SSHDs (Hybrid-Festplatten), USB-Sticks, Speicherkarten, SATADOM-Geräte und sogar Bandlaufwerke. Das Hauptziel besteht darin, Informationen sowohl zum Zustand als auch zu Temperatur und statistischen Leistungseinbußen zu erkennen sowie mögliche Festplattenfehler vorherzusagen - und Zeit für die Vorbereitung des geplanten Austauschs von Speichergeräten zu gewinnen. Durch die Verwendung dieser Software können wir Datenkorruption oder schwerwiegenden Datenverlust vermeiden.

Bitte lesen Sie diese Dokumentation sorgfältig durch. In den folgenden Kapiteln werden alle Funktionen und Merkmale von Hard Disk Sentinel beschrieben.

Geräteunterstützung

Hard Disk Sentinel unterstützt nicht nur Festplatten, sondern auch zahlreiche andere Geräte einschließlich SSDs und Flash-Medien im Allgemeinen und bietet zudem Methoden zur Überwachung von NAS-Geräten (Network Attached Storage). Ziel war es, einen umfassenden Lösungsansatz mit einer Standardumgebung bereitzustellen (anstatt separate Tools für verschiedene Geräte zu erstellen), damit Benutzer Probleme mit allen Arten von Speichergeräten diagnostizieren, überwachen, melden und reparieren können. Die Verwendung verschiedener Tools für Festplatten, SSDs und viele andere Geräte erfordert unter Umständen mehr Ressourcen und kann verwirrend sein. Aus diesem Grund ist es besser, über eine Gesamtlösung und eine Standardmethode zu verfügen, um die Festplattenlaufwerke im Auge zu behalten, auf denen wertvolle Daten gespeichert sind.

Hard Disk Sentinel unterstützt über 10.000 verschiedene Gerätemodelle, Festplatten, SSDs, Hybridgeräte, RAID-Controller, interne/externe Gehäuses und so weiter.


Festplatten, S.M.A.R.T.">

Festplatten in Computern verfügen über eine oder mehrere physische Platten . Der Schreib-/Lesekopf, der über dieser Platter fliegt, führt alle Lese-, Schreib- und Löschvorgänge aus.

Mit zunehmender Festplattenkapazität werden Daten in immer kleineren Bereichen auf der Plattenoberfläche gespeichert. Jede kleine (sogar mikroskopische) Beschädigung oder Verschmutzung der Oberfläche würde die Wahrscheinlichkeit des Zugriffs auf wichtige Daten erheblich verringern. Das Innere des Festplattenlaufwerks ist geschützt, um Schmutz außerhalb des Festplattengehäuses zu halten.

Der Zugriff auf Datensektoren ist nicht immer problemlos möglich. Es ist möglich, dass einige Bereiche der Festplattenoberfläche aufgrund kleiner Beschädigungen, Kratzer oder Verschmutzungen (selbst durch einen mechanischen Schlag/eine Beschädigung, die zu kleinen Partikeln im Festplattenlaufwerk führt), nicht lesbar oder beschreibbar sind. In diesem Fall markiert die Festplatte diesen Bereich als fehlerhaft und verwendet diese Sektoren nie wieder für Lese- oder Schreibvorgänge. Wenn in diesem Bereich zuvor Daten vorhanden waren, versucht die Festplatte zunächst, die Daten zu lesen und in einen speziellen Ersatzbereich zu kopieren. Diese Prozedur wird als Neuzuweisung (Reallocation) bezeichnet. Nach Abschluss der Neuzuweisung wird der gesamte Zugriff auf den alten Bereich in den freien Bereich umgeleitet. Auf den ursprünglichen (problematischen) Bereich der Festplatte kann auch nach einer vollständigen Neuformatierung nicht zugegriffen werden.

Das hört sich gut an - denn das Problem wird automatisch behoben, jedoch wird der Benutzer nichts vom ständig abnehmenden Festplattenstatus bemerken, bis er einer unbrauchbare Festplatte und einem teilweisen oder vollständigen Datenverlust gegenüber steht.

Es gibt weitere mögliche Probleme, die den Zustand der Festplatte verschlechtern können. Hohe Temperaturen, falsche Stromzufuhr oder mechanischer Schlag, Vibrationen können die Festplatte ernsthaft beschädigen. Viele dieser Probleme können mithilfe von Hard Disk Sentinel erkannt und der durch die Probleme verursachte Datenverlust vermieden werden.

S.M.A.R.T.

S.M.A.R.T. (Self-Monitoring Analysis and Reporting Technology) wurde von IBM eingeführt. Es wurde erstellt, um den Festplattenstatus mithilfe verschiedener Methoden und Geräte zu überwachen. Eine einzelne ATA-Festplatte kann bis zu 30 solcher Messwerte (Attribute) aufweisen. Einige von ihnen wirken sich direkt oder indirekt auf den Zustand der Festplatte aus, andere enthalten statistische Informationen wie Einschaltzeit, Anzahl Starts und Stopps, Temperatur usw.

Heutzutage verfügen alle modernen IDE-/"Serial ATA"-/SCSI-/SAS-/USB-Festplatten (und auch SSDs) über S.M.A.R.T. . Es ist nicht wirklich ein Standard - daher kann die Bedeutung der Attribute von Hersteller zu Hersteller unterschiedlich sein. Aus diesem Grund ist eine herstellerunabhängige Methode zur Analyse des Festplattenzustands erforderlich, um den tatsächlichen Status einer Festplatte zu ermitteln. Hard Disk Sentinel wurde so entworfen, schauen Sie bitte in den Abscnnitt Methoden zur Zustandsberechnung.

Viele Attribute werden von allen Herstellern auf dieselbe (oder nahezu gleiche) Weise verwendet. So ist es beispielsweise möglich, die Temperatur und die Einschaltzeit vieler Festplatten zu erfassen. Diese (und viele andere) Werte werden von Hard Disk Sentinel überwacht und gemeldet.

Gemäß der S.M.A.R.T.-Spezifikationen sollte die Festplatte, wenn die Anzahl der Fehler hoch genug ist, den Fehlerschwellenwert zu erreichen, mindestens 24 Stunden lang arbeiten, um die Datensicherung durchzuführen. In vielen Fällen reicht diese Zeit jedoch nicht aus. Daher ist es wichtig, Probleme zu erkennen und sich vorzubereiten, bevor es zu spät ist. Hard Disk Sentinel zeigt einen Zustand von 0 (Null) % an und schlägt einen sofortigen Austausch des Festplattenlaufwerks vor, wenn der Schwellenwert für die Fehlerstufe erreicht ist. Das Problem ist, dass viele Laufwerke lange vorher vollständig ausfallen (oder "nur" Datenbeschädigung/Datenverlust auftritt). Aus diesem Grund ist es wichtig, den Status zu überwachen und nicht bis zu dem Punkt abzuwarten, an welchem neben dem Computer-BIOS beim Einschalten womöglich auch Windows Festplattenprobleme meldet. Normalerweise ist es zu diesem Zeitpunkt für eine vollständige Sicherung zu spät.

Anmerkung: Einige Festplattencontroller oder -treiber verhindern unter Umständen das Lesen und Anzeigen von S.M.A.R.T.-Werten. In diesen Fällen kann der aktuelle Zustand, die Temperatur oder ein anderer Status für die betroffenen Festplatten nicht ermittelt werden. Geschieht dies,l kann die Seite Support -> Driver Zone auf der Website hilfreich sein: Sie bietet Treiber-/Firmware-Updates für viele Geräte und Festplattencontroller, mit denen Festplattenstatusinformationen erkannt werden können. Die Verwendung des Menüpunkts Bericht -> Testbericht an Entwickler senden in Hard Disk Sentinel kann hilfreich sein, da auf diese Weise die Möglichkeiten überprüft werden können und eine Beratung ermöglicht wird. Sie können sich auch an den Hersteller des Controllers wenden, um einen aktualisierten Treiber oder eine aktualisierte Firmware zu erhalten, insbesondere wenn Sie ein externes Festplattengehäuse, einen RAID-Controller oder ähnliches verwenden. Hard Disk Sentinel bietet zudem höchstmögliche Kompatibilität mit diesen Geräten (unterstützt Dutzende von RAID-Controllern aller großen Hersteller), aber manchmal ist es vielleicht nicht möglich, den S.M.A.R.T.-Status zu bestimmen, wenn solche Geräte verwendet werden.

SSD-Zustand, Temperatur

SSDs (und im Allgemeinen Flash-basierter Speicher in Speicherkarten und USB-Sticks) funktionieren anders als Festplatten: Die Speicherzellen in diesen Geräten unterliegen bei jedem Schreibvorgang einem Verschleiß, und jede Zelle toleriert nur eine begrenzte Anzahl von Überschreibungsdurchläufen.

Die Funktion "Verschleißregulierung" der SSD versucht, diesen Effekt zu verbergen/minimieren, aber im Allgemeinen nimmt der Zustand der SSD (auch wenn sie überhaupt keine Probleme hat) langsam aber sicher ab. Die meisten SSD-Geräte melden den Gesamtzustand der Speicherzellen anhand verschiedener Attribute: Wenn keine (anderen) Probleme gefunden wurden, liest Hard Disk Sentinel diese Attribute, um den vollständigen Zustand des Solid-State-Geräts zu bestimmen.

Dies ist völlig unabhängig von Software, Windows, Neustart, Partitionierung, Formatierung und so weiter: Wenn die Menge der geschriebenen Daten zunimmt, nimmt der Zustand langsam und sicher ab.

Einige SSDs verfügen vielleicht auch über Temperatursensoren (um den Temperaturwert bereitzustellen). Dies gilt jedoch wahrscheinlich nicht für alle Modelle. Während der Zustand angezeigt werden kann, fehlt der Software eventuell die Temperatur, wenn die SSD das Auslesen dieses Wertes nicht unterstützt. Ist in Hard Disk Sentinel die S.M.A.R.T.-Seite mit den erkannten Statusinformationen ausgewählt, könnte in diesem Fall kein "Temperatur"-Attribut aufgeführt sein.


Installation

Windows 10,8,8.1,7,Vista, 2016,2012,2008,XP,2003,2000,NT4: Vor der Installation von Hard Disk Sentinel sind keine Vorbereitungen erforderlich, es kann sofort nach dem ersten Start des Betriebssystems installiert werden . Es ist nicht erforderlich, Komponenten von Drittanbietern zu installieren (Visual Basic, VC ++, .NET, JAVA oder ähnliches sind überhaupt nicht erforderlich). Das Installationsprogramm der Software installiert alles, es werden keine weiteren Komponenten heruntergeladen.

"Windows 98/98SE/ME"-Nutzer: Das Betriebssystem verfügt nicht über standardmäßig geladene S.M.A.R.T.-Treiber. Vor der Installation müssen Sie die Datei Smartvsd.vxd aus dem Ordner Windows\System in den OrdnerWindows\System\IoSubsys kopieren und Ihren Computer neu starten. Bitte installieren Sie Hard Disk Sentinel erst nach diesem Vorgehen (Problem ursprünglich unter http://support.microsoft.com/kb/265854 beschrieben, dort jedoch nicht mehr verfügbar).

Nach dem Download kann Hard Disk Sentinel auf jeder physischen, nicht entfernbaren Festplatte installiert werden. Standardmäßig wird es im Ordner "Programme" (auf x64-Systemen "Programme (x86)") installiert. Es wird nicht empfohlen und nicht unterstützt, auf einem Wechseldatenträger (z. B. USB-Stick) zu installieren, da Hard Disk Sentinel die aktuellen Messwerte regelmäßig in seiner Datenbank (in seinem Installationsordner) speichert. Mittels dieser Datenbank ist es möglich, die zuvor gemessenen Werte abzurufen und grafisch darzustellen.

Während der Installation wird das Anwendungssymbol auf dem Desktop und in der Schnellstartleiste erstellt. Hard Disk Sentinel wird nach der Installation automatisch gestartet - sofern der Benutzer dies nicht deaktiviert.

Während der Installation wird das Anwendungssymbol auf demnach dem Neustart Hard Disk Sentinel automatisch zusammen mit dem System bei Anmeldung durch den Benutzer aufgerufen. Dies kann unter der Option Konfiguration -> Einstellungen -> Mit Windows laden deaktiviert werden (dann muss es manuell gestartet werden) oder es wird für den Start konfiguriert, jedoch durch Deaktivieren der Option Konfiguration -> Einstellungen -> Hauptfenster beim Start anzeigen ohne Anzeige des Hauptinformationsfensters (nur in der registrierten Version). Es wird empfohlen, Hard Disk Sentinel immer im Hintergrund laufen zu lassen, um eine ständige Überwachung, sofortiges Warnen durch die konfigurierten Warnungen, die Meldung von (auch geringfügigen) Problemen oder vorübergehenden Überhitzungszuständen zu ermöglichen - die sonst womöglich unbemerkt bleiben.

Portable Version

Die Version Hard Disk Sentinel Professional Portable (als separater Download von der Download-Seite verfügbar) kann auf einen Wechseldatenträger (normalerweise ein USB-Stick) extrahiert und unter Windows-Systemen von dort gestartet werden, um Festplattenlaufwerke ohne Installation zu diagnostizieren, zu überwachen, zu testen und zu reparieren. Die portable Version speichert alle Status, Statistiken, Einstellungen und Lizenzen auf diesem Wechseldatenträger (USB-Stick).

In Bezug auf die Lizenzierung lautet die portable Version auch Hard Disk Sentinel Professional. Mit einer einzigen Lizenz von Hard Disk Sentinel Professional können Sie also auswählen, ob Sie die installierte ODER die portable Version verwenden möchten. Für die Verwendung beider sind zwei separate Lizenzen erforderlich (oder eine Lizenz für die Hard Disk Sentinel Professional Family). Die Anzahl der von der Portable-Version zu diagnostizierenden Festplatten und Systeme ist nicht begrenzt (solange die Portable-Version nur auf jeweils einem System verwendet wird).

Anmerkung: Es kann immer nur eine Version (installiert oder tragbar) aktiv sein. Wenn auf dem Computer auch die installierte Version läuft, muss diese zuerst über Datei -> Beenden geschlossen werden, bevor die Portable gestartet wird. Der Eintrag Hilfe -> Info kann verwendet werden, um die aktuelle Version zu überprüfen. Wenn diese Version verwendet wird, wird das Wort "PORTABLE" angezeigt.

Vorgaben

Nach dem Start wird das Hauptfenster angezeigt, in welchem die Liste der erkannten Laufwerke, deren Status im linken Bereich und rechts detaillierte Informationen zum ausgewählten Festplattenlaufwerk oder zur ausgewählten SSD angezeigt werden. Über dieses Fenster kann auf alle Funktionen und Features von Hard Disk Sentinel zugegriffen werden.

Standardmäßig gibt die Anwendung keine Alarme/Warnungen aus, jedoch werden die neu gefundenen Probleme ins Festplattenprotokoll eingetragen.


Komponenten der Anwendung

Die Hauptkomponenten von Hard Disk Sentinel werden in den folgenden Abschnitten beschrieben:

  • Statusfenster

  • Trayicon

  • Laufwerkssymbol

  • Schnellmenü

  • Hauptfenster

  • Konfiguration

  • Konfigurieren und Ausführen von Sicherungsaufgaben (nur in der PROFESSIONAL-Version verfügbar)


Statusfenster

Durch Klick auf die Schaltfläche "Statusfenster anzeigen" (3. Schaltfläche in der Symbolleiste des Hauptfensters) können Sie die Anzeige eines kleinen Statusfensters umschalten. Es enthält die Modelle sowie die Temperatur- und Zustandswerte der installierten Festplatten. Standardmäßig wird dieses Statusfenster über allen anderen Fenstern immer im Vordergrund angezeigt. Auf diese Weise ist es möglich, den aktuellen Status der Festplatten zu überwachen.

  • Wird der Mauszeiger über das Statusfenster bewegt, wird in der oberen rechten Ecke des Statusfensters ein kleines Symbol (X) angezeigt. Das Statusfenster wird ausgeblendet, wenn der Benutzer (mit der linken Maustaste) auf dieses Symbol klickt.

  • Mit einem Klick der linken Maustaste auf das Statusfenster wird die Liste der logischen Laufwerke unten im Statusfenster angezeigt, um einen schnellen Überblick über den auf den einzelnen Festplatten verfügbaren freien Speicherplatz zu erhalten. Klickt der Benutzer auf ein logisches Laufwerk, wird dieses automatisch im Windows Explorer geöffnet. Ein erneuter Linksklick auf das Statusfenster verbirgt das Informationsfenster für logische Laufwerke wieder.

    Statusfenster mit Informationen zum logischen Laufwerk

  • Sie können das Statusfenster an eine beliebige Bildschirmposition verschieben, indem Sie die linke Maustaste gedrückt halten und die Maus bewegen. Standardmäßig kann das Statusfenster nicht außerhalb des Bildschirms verschoben werden (es ist auf die Bildschirmränder ausgerichtet), dies kann aber deaktiviert werden. Auf diese Weise kann das Statusfenster (teilweise oder vollständig) außerhalb des Bildschirms verschoben werden.

  • Nach einem (linken) Doppelklick werden die Details der Festplatte unter dem Mauszeiger im Hauptfenster der Anwendung angezeigt.

  • Mit der rechten Maustaste wird das Schnellmenü angezeigt (Es kann auch durch einen Rechtsklick auf dasTrayicon angezeigt werden. Dies ist nützlich, wenn das Statusfenster ausgeblendet ist.).

Anmerkung: Das im Statusfenster angezeigte Layout und die Informationen können konfiguriert werden. Die Anwendung speichert die Änderungen und die Position des Statusfensters automatisch und beim nächsten Mal wird das Fenster wie zuvor konfiguriert angezeigt (oder überhaupt nicht angezeigt - wenn das Statusfenster zuvor ausgeblendet wurde).


Trayicon

    Trayicon zeigt Informationen an

In der unteren rechten Ecke links neben der Uhr oder gruppiert in einem Popup-Menü (wie im Bild oben zu sehen; hoffentlich sieht der Zustand meiner SSD nie so aus), wenn zu viele Anwendungen mit Taskleisten-Symbolen aktiv sind, kann Hard Disk Sentinel den Status von Festplatten mithilfe von Trayicons anzeigen. Nach einer Neuinstallation wird für jede Festplatte ein Symbol mit Temperaturinformationen gezeigt (sollte die Temperatur auf der Festplatte erfasst werden können). Die Anwendung zeigt hohe und höhere Temperaturen in verschiedenen Farben an: Unterhalb 40 Grad Celsius ist der Hintergrund des Symbols grün, zwischen 40 und 50 ist das Temperatursymbol gelb und über 50 ist es rot. Natürlich können diese Schwellenwerte und Farben basierend auf den Einstellungen des Benutzers konfiguriert werden.

Wenn zwei oder mehr Datenträger Trayicons haben, ist nicht immer klar, welches Symbol zu welchem Datenträger gehört. Die Symbole werden in der Reihenfolge der Festplatten (von links nach rechts) angezeigt. In einigen Fällen können diese Symbole jedoch aufgrund des Betriebssystems oder einer anderen Anwendung mithilfe von Trayicons neu angeordnet werden. Wenn der Mauszeiger über ein Trayicon von Hard Disk Sentinel bewegt wird, werden Nummer, Modell, Temperatur und Zustand sowie andere Informationen (alles, was im Statusfenster der Festplatte zu sehen ist) als Hinweis dargestellt.

Wenn der Benutzer (mit der linken Taste) auf ein Symbol in der Taskleiste doppelklickt, erscheint das Hauptfenster mit detaillierten Informationen zu allen installierten Festplatten.

Ein Rechtsklick auf das Trayicon wird das Schnellmenü mit den am häufigsten verwendeten Funktionen anzeigen.


Laufwerksymbol

Laufwerksymbole

Auf den Symbolen der logischen Laufwerke zeigt Hard Disk Sentinel ständig den Status dieser Datenträger (Integritätsstatus, der gut, akzeptabel und schlecht sein kann) und die Menge des verwendeten Speicherplatzes an. Auf diese Weise kann in jeder Anwendung (z. B. Windows Explorer) der aktuelle Status leicht abgelesen werden.

Festplattenzustand und verwendeter Speicherplatz werden auf den Festplattensymbolen angezeigt

Diese Option ist besonders nützlich, wenn zwei oder mehr Festplatten installiert sind oder wenn das Statusfenster nicht angezeigt werden kann. Der genutzte Platz wird in 16 verschiedenen Schritten angezeigt. Wenn der belegte Speicherplatz auf dem logischen Laufwerk vergrößert wird, wird das Band gelb und dann rot.

Anmerkung: Die Anzeige des verwendeten Speicherplatzes hängt von der Einstellung des Schwellenwertes für den freien Speicherplatz ab. Es ist möglich, die Schwellenwerte für den freien Speicherplatz für jedes logische Laufwerk unterschiedlich zu konfigurieren. Wenn ein höherer Schwellenwert konfiguriert ist, erreicht das Band früher gelbe oder rote Bereiche.

In der unteren rechten Ecke der Symbole wird ein Symbol angezeigt, das dem Festplattenzustand entspricht. Standardmäßig kann dieses Symbol ein grünes Häkchen sein, wenn der Gesundheitszustand besser als 50 % ist. Zwischen 25 % und 50 % wird ein gelbes Ausrufezeichen und unter 25 % ein rotes X auf den Symbolen der logischen Datenträger angezeigt. Natürlich können diese Schwellenwerte konfiguriert werden.

Anmerkung: Das Integritätssymbol wird nur auf Laufwerken angezeigt, auf denen der aktuelle Integritätsstatus ermittelt werden kann. Auf logischen Datenträgern, die anderen Laufwerken zugeordnet sind (z. B. USB-Sticks ohne Statusinformationen) und auf Remote-Laufwerken können nur Informationen zum verwendeten Speicherplatz angezeigt werden (Diese Option ist standardmäßig deaktiviert und kann im Konfigurationsfenster Festplattensteuerung aktiviert werden.). Die Integritätsinformationen werden unter Windows 98/98SE/ME nicht angezeigt.

Um den aktuellen Status der Laufwerke anzuzeigen, muss deren Status (Zustand verwendeter Speicherplatz) regelmäßig überprüft werden. Langsamere Geräte oder Laufwerke (z. B. Kartenleser oder Netzlaufwerke) benötigen sogar mehr Zeit für die Erkennung. Dies kann die Reaktionszeit der Anwendung verlängern oder das System verlangsamen. In diesen Fällen sollte diese Option auf den betroffenen Laufwerken teilweise oder vollständig deaktiviert sein. Dies kann im Konfigurationsfenster Laufwerkssteuerung konfiguriert werden.

Hard Disk Sentinel sollte aktiv sein (ausgeführt werden), um das Integritätssymbol und den verwendeten Speicherplatz auf den Symbolen des logischen Laufwerks anzuzeigen. Wenn es nicht ausgeführt wird, können diese zusätzlichen Informationen nicht angezeigt werden.


Schnellmenü

Dieses Menü wird angezeigt, wenn der Benutzer mit der rechten Maustaste im Statusfenster oder auf das Trayicon klickt. Über dieses Menü können Sie:

  • Das Statusfenster ein- oder ausblenden (die dazugehörige Option ist verfügbar).

  • Die Konfigurationsseite öffnen und die Einstellungen festlegen.

  • Die Temperatur-Statistik einer Festplatte anzeigen.

  • Im Hauptfenster detaillierte Informationen zu einer Festplatte anzeigen (das zuvor ausgewählte Informationsfeld erscheint).

  • Diese Hilfe anzeigen.

  • Das Info-Fenster der Anwendung anzeigen, das die aktuell installierte Version, den Namen des registrierten Benutzers, einen Schnelllink zur Webseite der Anwendung sowie den Namen und die E-Mail-Adresse der Person enthält, die die Übersetzung des Interface durchgeführt hat.

  • Die akustischen Warnungen in der aktuellen Sitzung aktivieren oder deaktivieren. Wenn die akustischen Warnungen auf der Seite Warnungen aktiviert wurden und ein Problem festgestellt wird (z. B. Überhitzung, geringer Speicherplatz usw.), gibt die Anwendung eine akustische Warnung aus (Optional kann diese Warnung wiederholt werden, solange der Benutzer nicht bestätigt, dass er das Problem kennt, indem er auf diese Option klickt oder dieselbe Option im Hauptfenster verwendet.). Mit dieser Option können die akustischen Warnungen für die aktuelle Sitzung deaktiviert werden. Nach dem Neustart der Anwendung werden die akustischen Warnungen automatisch wieder aktiviert. Verwenden Sie diese Option besser so, als die akustischen Warnungen auf der Seite Warnungen zu deaktivieren.

  • Hard Disk Sentinel schließen. Dadurch wird die Ausführung der Anwendung beendet und der Status der Festplatten wird später nicht mehr überwacht. Hinweis: Beim nächsten Start werden die Änderungen des Zustands seit dem letzten Lauf überprüft und im Protokoll der Festplatte festgehalten. Auf diese Weise kann Hard Disk Sentinel, wenn er nicht ständig, aber regelmäßig ausgeführt werden kann, verwendet werden, um den Status der Laufwerke und die Änderungen (Verschlechterung des Zustands) zu überprüfen.


Hauptfenster

Über das Hauptfenster von Hard Disk Sentinel können Sie über das Hauptmenü oder die Schnellschaltflächen auf alle Features und Funktionen zugreifen.

Hauptfenster mit Festplatten-Informationen

Der obere linke Bereich enthält die Liste der erkannten physischen Laufwerke mit einer kurzen Information über den Status (Zustand und Temperatur). Die Liste enthält Festplatten, SSDs, Hybridlaufwerke usw., einschließlich USB-Sticks und Speicherkartenleser. Gewöhnlich folgt die Reihenfolge der Laufwerke der Liste der Laufwerke, die in der Windows-Datenträgerverwaltung angezeigt werden, um die Identifizierung zu erleichtern (außer bei einer von Hard Disk Sentinel gefundenen RAID-Konfiguration und angezeigten RAID-Mitgliedern - während die Windows-Datenträgerverwaltung nur das RAID-Volume anzeigt), also werden Geräte (auch leere Kartenleser) hier standardmäßig angezeigt. Nach einem Rechtsklick ist es möglich, die Liste anzupassen: Geben Sie an, ob kleinere/größere Schaltflächen angezeigt werden sollen (mit unterschiedlicher Menge an Informationen) und deaktivieren Sie, wenn möglich Geräte, um sie aus dieser Liste auszublenden.

Der untere linke Bereich zeigt die Liste der logischen Laufwerke und ihre gesamte/freie Kapazität. Neben physischen können auch andere Laufwerke enthalten sein (z. B. Remote-/Netzlaufwerke). Durch einen Rechtsklick (wie bei den physischen Datenträgern) kann die Liste angepasst werden.

Der horizontale Splitter zwischen der oberen und unteren Liste kann verwendet werden, um die Größe der verschiedenen Bedienfelder zu ändern. Wenn eine physische oder logische Festplatte mit der linken Maustaste ausgewählt wird, werden die Details der Festplatte oder des Laufwerks im rechten, größeren Informationsfeld angezeigt.

In den Auswahlfeldern wird die Liste der Laufwerke regelmäßig aktualisiert. Auf diese Weise spiegeln die Quickinfos der Laufwerke (Temperatur, Zustand oder freier Speicherplatz) den tatsächlichen, neuesten Status wider.

Der Splitter zwischen dem Selektor und den Informationstafeln kann verwendet werden, um die Größe dieser beiden Bereiche zu ändern. Hinweis: Die Anwendung speichert Position und Größe dieses Fensters sowie die Position der Splitter automatisch. Auf diese Weise wird das Fenster beim nächsten Mal so angezeigt, wie es zuvor verwendet wurde.

Im Informationsfenster werden die Details des aktuell ausgewählten physischen oder logischen Laufwerks angezeigt.

Das Hauptmenü bietet folgende Optionen:

  • Datei: In diesem Menü können Sie eine automatische Aktualisierung auf die neueste Version (falls verfügbar) durchführen, den Status der Offline-Festplatten öffnen, Windows-Volume-/RAID-Status überprüfen (z. B. für den Status eines logischen Laufwerks oder eines Software-RAIDs), die Liste des Ereignisprotokolls für das Einbinden/Entfernen von Laufwerken prüfen sowohl bei aktivem wie auch inaktivem Hard Disk Sentinel sowie die NAS-Festplattenüberwachung konfigurieren oder Hard Disk Sentinel vollständig schließen (stoppen).

  • Laufwerk: Es ist möglich, die Festplattenfunktionen anzupassen: Passen Sie die Empfindlichkeit der Akustikmanagement-Konfiguration, die Erweiterte Energieverwaltung oder die Freifall-Kontrolle an. Funktionen (falls vom Laufwerk nicht unterstützt) sind ausgegraut (nicht auswählbar). Über den Menüpunkt "Laufwerk" können auch Laufwerktest gestartet werden, einschließlich der "integrierten" Hardware-Selbsttests und dem Test des wahlfreien Zugriffs (Random Seek) sowie Oberflächentests. Hard Disk Sentinel Professional bietet eine breite Palette von Tests, darunter einfaches Lesen, Überschreiben (Nullfüllung, Füllen mit zufälligen Daten oder einem bestimmten Muster), Neuinitialisierung der Festplattenoberfläche, Aktualisieren der Festplatte und Festplattenreparaturtests mit hochgradig anpassbaren Optionen. Zudem ist es möglich, Laufwerktest mit wenigen Klicks auf mehreren Laufwerken zu starten. Durch die Online-Garantieprüfung kann der aktuelle Garantiestatus auf der Webseite des Herstellers anhand des aktuellen Festplattenmodells und der Seriennummer überprüft werden, die auf der Informationsseite in Hard Disk Sentinel angezeigt werden.

  • Ansicht: Es kann ausgewählt werden, welches Informationsfeld für die ausgewählte Festplatte dargestellt werden soll.

  • Bericht: Mit diesen Optionen kann ein vollständiger Text- oder HTML-Bericht erstellt werden. Es ist möglich, den Bericht einfach zu speichern (und sofort zu öffnen) oder ihn sofort per E-Mail an eine beliebige Adresse zu senden. Standardmäßig ist die konfigurierte Empfängeradresse eingefügt und zum Übertragen der Berichts-E-Mail die werden konfigurierten E-Mail-Optionen verwendet. Es ist möglich, einen Authentischen Laufwerkseeport zu speichern, bei dem es sich um einen zertifizierten Bericht (HTML-Format) handelt, um den Status eines oder mehrerer Laufwerke zu bestätigen. Entwickelt, um gebrauchte Festplatten zu verkaufen und zu kaufen, da es möglich ist, die Authentizität des Berichts zu speichern (und dann zu überprüfen), um den vollständigen Status zu bestätigen (einschließlich möglicher Fehler und Lebensdauerstatistiken: Einschaltzeit, Start/Stopp-Anzahl, Anzahl der geschriebenen Daten des Laufwerks beim Verkauf.

  • Konfiguration: In diesem Fenster können die Features und Funktionen der Anwendung konfiguriert werden. Die Optionen sind in verschiedene Kategorien unterteilt.

  • Hilfe: Die aktuelle, vollständige Hilfe oder das Info-Fenster kann aufgerufen werden. Es ist auch möglich, wegen eines Registrierungsschlüssels (eine 15-stellige Nummer, den Lizenzcode) Kontakt aufzunehmen und eine sichere Bestellung einzuleiten - und diesen empfangenen Registrierungsschlüssel einzugeben.

Wird der Mauszeiger über die Schnellschaltflächen im Hauptmenü bewegt, wird die Funktion der Schaltflächen in einem Hinweisfenster angezeigt. Mit den Schaltflächen können folgende Aufgaben ausgeführt werden:

  • Aktualisieren Erkennt den vollständigen Status aller Festplattenlaufwerke unabhängig von der konfigurierten Erkennungshäufigkeit erneut genau wie beim Neustart der Software.

  • Warnungen erneut aktivieren Löscht die Liste der behandelten Warnungen, damit diese erneut gesendet, die akustischen Warnungen erneut abgespielt werden usw.

  • Statusfenster ein-/ausblenden Ausblenden oder Anzeigen des Statusfensters

  • Schallpegel ändern Konfiguriert den akustischen Pegel der Festplatte (falls unterstützt). Ein höherer Schallpegel bedeutet mehr Rauschen und eine schnellere Suchleistung, ein niedrigerer Schallpegel bedeutet weniger Rauschen, jedoch eine langsamere Suchleistung.

  • Seuchtest Testet die Suchleistung des Laufwerks, Geräuschpegel und Temperaturniveau. Der Test kann effektiv dazu verwendet werden, um die Festplatte durch Erhöhen ihrer Temperatur zu "belasten".

  • Oberflächentests Startet verschiedene Arten von Festplattentests, um den Status zu bestätigen oder Probleme zu erkennen und zu beheben.

  • Laufwerktest Führt Festplatten-interne Selbsttests durch, um kritische Komponenten zu überprüfen und versteckte Probleme aufzudecken.

  • Garantieprüfung Überprüft die Garantie der aktuell ausgewählten Festplatte auf der Website des Herstellers.

  • Bericht erstellen und speichern Speichert einen Vollständigen Bericht. Der Berichtstyp (Text oder HTML) kann ausgewählt werden.

  • Bericht per E-Mail senden Sendet einen vollständigen Bericht per E-Mail. Der Berichtstyp (Text oder HTML) kann ausgewählt werden.

  • Testbericht an Entwickler senden Sendet einen Testbericht an den Entwickler, um die Weiterentwicklung zu unterstützen. Nützlich, um Probleme oder Erkennungsprobleme zu überprüfen, Kompatibilitätsprobleme - falls vorhanden - zu melden und um Hilfe zu bitten, um die aktuelle Situation zu verbessern.

  • Konfiguration Das Öffnet das Konfigurationsfenster.

  • Aktivieren/Deaktivieren akustischer Warnungen Deaktiviert oder aktiviert akustische Warnungen für die aktuelle Sitzung. Wenn die Option "Sound-Warnung wiederholen" aktiviert ist, können mit dieser Schaltfläche die Sound-Warnungen bestätigt und weitere Sound-Warnungen deaktiviert werden.

  • Hilfe Öffnet die aktuelle Hilfe.

  • Über Zeigt das Fenster mit Informationen zur Anwendung an.


Informationen zum physischen Laufwerk

Für ein physisches Laufwerk stehen viele verschiedene Informationsseiten zur Verfügung. Sie können die Ansicht zwischen den Seiten mithilfe der Registerkarten oder durch Auswahl der Seite im Menüpunkt Ansicht ändern.

  • Übersicht

  • Temperatur

  • S.M.A.R.T.

  • Informationen

  • Protokoll

  • Laufwerk Leistungsfähigkeit

  • Warnungen


Übersicht

Die aktuellen Leistungs- und Integritätswerte der ausgewählten Festplatte werden angezeigt.

Unterhalb der Werte wird eine Textausgabe des aktuellen Status angezeigt. Hard Disk Sentinel analysiert die S.M.A.R.T.-Attribute, die von der Festplatte bereitgestellt werden, durch die Auswertung dieser Werte, es wird eine Textbewertung erstellt und angezeigt, die die Anzahl der Probleme enthalten kann, die während der Lebensdauer der Festplatte auftraten. Dies umfasst, ohne darauf beschränkt zu sein, die Anzahl fehlerhafter Sektoren, schwacher (ausstehender) Sektoren, Anlaufprobleme, (Kommunikations-) Datenübertragungsfehler usw., abhängig vom Gerätetyp (Festplatte oder SSD), der Verbindung (IDE/SATA/SCSI/SAS/USB/NVMe M.2 und so weiter). Die Hintergrundfarbe des Textausgabesbereichs (Grün, Gelb, Rot) zeigt den Zustand der Festplatte an. Der Textbereich kann Tipps zur Behebung der Probleme enthalten (und eine Sicherung durchführen, wenn der Zustand dies nahelegt). Es wird daher empfohlen, die Details zu lesen.

In der Mitte werden einige statistische Informationen wie die Einschaltzeit und die geschätzten Werte für die verbleibende Lebensdauer angezeigt. Der Prozess zum Messen und Berechnen dieser Werte ist im Anhang beschrieben. Außerdem können dort gegebenenfalls die Gesamtanzahl der Starts/Stopps und/oder die Gesamtmenge der geschriebenen Daten angezeigt werden, und falls verfügbar stellt das Gerät solche Informationen bereit.

Einige spezielle Geräte, wie z. B. industrielle (Mikro-) SD-Karten, erfordern besondere Aufmerksamkeit und müssen zuerst für die Überwachung konfiguriert werden. Dieses Verfahren ist für gespeicherte Informationen völlig sicher und hat keinerlei Auswirkungen auf den Betrieb und die Kapazität des Geräts. Es teilt Hard Disk Sentinel lediglich mit, wie die Statusinformationen erkannt und angezeigt werden sollen. Dies kann aktiviert werden, indem Sie unterhalb der Textausgabe auf Gerätespezifische Erkennung steuern klicken.

Am unteren Rand des Bedienfelds wird der grafische Verlauf der zuvor gemessenen Festplattenzustandswerte angezeigt. Hard Disk Sentinel speichert den täglich gemessenen schlechtesten (niedrigsten) Gesundheitszustand und zeigt diese Werte im Diagramm an. Wenn die Anwendung für einen längeren Zeitraum verwendet wird, kann die Bildlaufleiste unter dem Diagramm verwendet werden, um zu einem früheren Datum zu scrollen. Mithilfe des kleinen Laufwerksymbols kann das Diagramm als Bild (BMP oder JPG) gespeichert werden.

Benutzerdefinierte Gesundheitsschwellen

Ein Doppelklick auf die Leiste Gesundheit % öffnet das Fenster Benutzerdefinierte Integritätsschwellenwerte, in dem benutzerdefinierte gelbe (Warnung) und rote (Alarm) Ebenen für das jeweilige Gerät angegeben werden können, die verwendet werden, um festzustellen, ob das Gerät eine Warnung auslösen sollte (anstelle der globalen Schwellenwerte, die auf der Seite Konfiguration: Schwellenwerte/Trayicon festgelegt sind. Diese Werte sind beispielsweise nützlich, um verschiedene benutzerdefinierte Integritätsschwellenwerte für SSDs anzugeben (wobei die Abnahme des Gesundheitszustands in % normal ist) und die Standard-Gesundheitsschwellenwerte für Festplatten beizubehalten).


Temperaturstatistik

Auf dieser Seite können Sie die aktuellen täglichen Durchschnitts-, Mindest- und Höchsttemperaturwerte überprüfen und den Verlauf der aufgezeichneten Werte überprüfen. Diese können helfen, (zum Beispiel) einen eventuell ausgefallenen Lüfter und die daraus resultierenden höheren Temperaturen zu erkennen.

Basierend auf den Temperaturwerten wird eine Textbewertung angezeigt (wie die Bewertung basierend auf dem Laufwerkszustand). Bei hohen Temperaturen kann die Anwendung Tipps geben, um Probleme zu vermeiden.

In einigen Fällen liefert der Temperatursensor auf der Festplatte etwa nicht die richtigen Werte. Es wird empfohlen, die Genauigkeit des Temperatursensors zu überprüfen und die Temperaturkalibrierung durchzuführen (dieser Hinweis wird angezeigt, bis für die Festplatte kein Temperaturversatz (gleichbleibend 0) mehr festgelegt ist). Dies kann für ältere Festplatten wichtiger sein. In der Regel erfordern neuere Festplatten keine Temperaturkalibrierung.

Am Ende dieser Seite werden die neuesten Werte (gemessen in der aktuellen Sitzung) angezeigt. Es ist auch möglich, die an den vorhergehenden Tagen gemessenen Durchschnitts-, Mindest- und Höchsttemperaturen zu untersuchen. Wenn Hard Disk Sentinel über einen längeren Zeitraum verwendet wurde, kann die Bildlaufleiste unter dem Diagramm verwendet werden, um zu einem früheren Datum zu scrollen. Mithilfe des kleinen Laufwerkssymbols kann das Diagramm als Bild (BMP oder JPG) gespeichert werden.

Benutzerdefinierte Temperaturschwellenwerte

In der oberen rechten Ecke neben der Leiste "Aktuelle Temperatur" befindet sich eine Option: "Eigene Temperaturschwellenwerte setzen". Mit dieser Option können benutzerdefinierte gelbe (Warnung) und rote (Alarm) Pegel für das jeweilige Gerät angegeben werden, die verwendet werden, um zu bestimmen, ob das Gerät einen Alarm auslösen soll (anstelle der globalen Schwellenwerte auf der Seite Konfiguration: Schwellenwerte/Trayicon festgelegt sind). Diese Werte sind (zum Beispiel) nützlich, um höhere benutzerdefinierte Schwellenwerte für NVMe-SSDs (die normalerweise bei höheren Temperaturen funktionieren) anzugeben, während die Standardschwellenwerte für Festplatten beibehalten werden und ein "Überhitzungsalarm" für eine SSD verhindert wird.

Sie können auf diesen Dialog "Eigene Temperaturschwellenwerte" zugreifen, indem Sie oben auf der Seite "Temperatur" auf den aktuellen Temperaturbalken (der die aktuelle Temperatur anzeigt) doppelklicken.


S.M.A.R.T.

Auf der S.M.A.R.T.-Seite (Self-Monitoring Analysis and Reporting Technology) wird die Liste von S.M.A.R.T.-Attributen für das ausgewählte Laufwerk angezeigt. Abhängig von Laufwerkstyp, Verbindung, werden unterschiedliche Attribute und verschiedenen Abschnitte/Werte angezeigt. Diese werden von der Festplatte (oder SSD) bereitgestellt, um den aktuellen Status wiederzugeben. Die Liste der vom Hersteller definierten Attribute - da nicht alle Festplatten alle Attribute enthalten - ist fixiert und es ist nicht möglich, Attribute hinzuzufügen oder zu entfernen, nachdem die Festplatte das Werk verlassen hat. Der Satz von Attributen kann auf verschiedenen Festplatten desselben Herstellers variieren, aber Festplatten gleichen Typs haben normalerweise dieselben Attributlisten (es kann Ausnahmen geben, da Firmware-Updates Attribute hinzufügen/ändern können).

S.M.A.R.T. Attributdetails, Flags und Trends für das ausgewählte Attribut

Von links nach rechts beginnt die Liste mit der Kennung (Nummer). Sie kann zwischen 0 und 255 liegen. Wenn sich das Attribut direkt auf den Status der Festplatte auswirkt und eine kritische Stufe erreicht, zeigt Hard Disk Sentinel, ein grünes Häkchen (Attribut OK) oder ein rotes X (Attribut ist nicht korrekt) vor der Nummer an.

Dann wird der Name des Attributs angezeigt - sofern er nicht unbekannt ist. Die meisten Attribute werden weitgehend von allen (oder fast allen) Herstellern verwendet, jedoch sind Wert und Bedeutung einiger Attribute sind unbekannt, da der Hersteller solche Informationen nicht veröffentlicht.

Die Spalte Schwellenwert enthält den Schwellenwert für das Attribut. Wenn die Spalte Wert eine Zahl enthält, die kleiner als der Schwellenwert ist, ist das Attribut nicht korrekt. Ist das Attribut kritisch, wird in diesem Fall das rote X am Anfang dieser Zeile angezeigt. In der Spalte Schlechtester wird der schlechteste jemals gemessene Wert angezeigt.

In der Spalte Status wird der aktuelle Status des Attributs angezeigt. Es kann sein:

  • OK: Der Wert ist gleich oder größer als der Schwellenwert. Es gibt kein Problem.

  • OK (immer bestanden): Der Schwellenwert ist Null, daher ist es nicht möglich, einen kleineren Wert zu haben. Wird normalerweise für die Attribute angezeigt, die nur statistische Informationen anzeigen.

  • Fehler: Ein kritisches Attribut hat den Schwellenwert überschritten (Wert ist kleiner als der Schwellenwert).

  • Nutzungslimit überschritten: Ein nicht kritisches Attribut hat den Schwellenwert überschritten (Wert ist kleiner als der Schwellenwert).

In der Spalte Daten werden die rohen Messwerte angezeigt. Diese Werte werden von der Festplatte nicht ausgewertet. Im Gegensatz dazu enthält die Spalte Wert eine ausgewertete Nummer, die vom Hersteller und der Festplatte abhängt. Diese Werte werden im hexadezimalen Format angezeigt. Es ist möglich, Dezimalwerte aus dem Menü auszuwählen, das nach einem Rechtsklick auf die S.M.A.R.T.-Tabelle angezeigt wird.

Bei der Prüfung des Festplattenzustands und der Berechnung des Integritätswerts wird empfohlen, die Rohwerte zu überprüfen, da auf diese Weise ein objektiver, herstellerunabhängiger Status der Festplatten erzielt werden kann.

In der Spalte Offset kann ein Versatzwert (positiv oder negativ) angegeben werden. Hard Disk Sentinel addiert (subtrahiert) diese Zahl für das Attribut, wenn es ausgewertet wird. Dies kann beispielsweise während der Temperaturkalibrierung verwendet werden. Es gibt viele Optionen, um den Versatzwert festzulegen:

  • Durch Verwendung der Symbole - und +: Die Anzahl wird um eins verringert oder erhöht.

  • Durch Klick auf die Nummer zwischen den Symbolen: Die Nummer kann direkt in einem kleinen Feld angegeben werden.

  • Wenn das richtige Attribut ausgewählt ist, können Sie mit den Tasten + und - und der EINGABETASTE den Versatzwert angeben.

Anmerkung: Es wird empfohlen, den Versatz direkt durch Klicken auf die Zahl oder durch Drücken der EINGABETASTE festzulegen.

Das Kontrollkästchen in der Spalte Aktivieren kann zum An-/Ausschalten des Attributs verwendet werden. Ist ein Attribut deaktiviert, zählt es nicht für die Werte Zustand und Leistungsfähigkeit. Änderungen (Verschlechterungen) deaktivierter Attribute werden nicht im Festplattenprotokoll gespeichert. Aus diesem Grund wird das Deaktivieren von Attributen NICHT empfohlen.

Achtung: Bei Verwendung der Optionen Offset und Aktivieren wird der Festplattenstatus möglicherweise falsch oder ungenau angezeigt. Nur fortgeschrittene Benutzer sollten eine dieser Optionen ändern.

Anmerkung: Änderungen der Optionen Offset und Aktivieren werden nur in der registrierten Version gespeichert. Wird die nicht registrierte Version verwendet, werden die Änderungen an diesen Optionen beim Neustart der Anwendung automatisch verworfen.

Eine Textausgabe (mit der Bedeutung und Wichtigkeit des Attributs) wird als Hinweis angezeigt, wenn die Maus über ein Attribut bewegt wird. Nach einem Rechtsklick auf die Tabelle wird ein Popup-Menü angezeigt mit der Option, diese Beschreibung für jedes Attribut sichtbar zu halten. Die vollständige Liste der bekannten S.M.A.R.T.-Attribute wird im Anhang beschrieben.

Mit der rechten Maustaste können die in der Tabelle angezeigten Informationen in die Zwischenablage kopiert werden. Später können diese Informationen in eine Textdatei, eine E-Mail oder ein Dokument eingefügt werden.

Attributdiagramm

Unter der Tabelle wird der grafische Verlauf des aktuell ausgewählten S.M.A.R.T.-Attributs dargestellt. In diesem Diagramm kann untersucht werden, wie sich das Attribut geändert hat. Die beiden Endpunkte des Diagramms geben den ersten Messwert (Installationstag) und den letzten (aktuellen) Wert des Attributs wieder. Alle anderen Tage zwischen diesen beiden Daten werden automatisch ausgewählt.

Neben dem Diagramm werden die Statusflags des Attributs angezeigt. Alle Attribute können ein oder mehrere Statusflags aufweisen. Sie geben den Hauptzweck des Attributs an. Dies können sein:

  • Kritisch: Der Wert kann den Integritätsstatus der Festplatte entscheidend beeinflussen (z. B. Anzahl der Sektoren, die in den Ersatzbereich verschoben wurden).

  • Statistisch: Der Wert beeinflusst den Status weder direkt noch indirekt (z. B. Anzahl der Einschaltzyklen).

  • Leistung: Der Wert kann Leistung oder Geschwindigkeit beeinflussen (z. B. Betriebszeit, Suchzeit).

  • Fehlerrate: Normalerweise korrigierbare Attribute, bei denen der Wert den Zustand der Festplatte nicht direkt beeinflusst (z. B. Suchfehlerrate).

  • Anzahl Ereignisse: Der Zählerwert erhöht sich, wenn einige Ereignisse oder Probleme auftreten (z. B. wenn ein neuer fehlerhafter Sektor gefunden wird).

  • Selbsterhaltend: Der Wert des Attributs wird kontinuierlich überwacht.

Attributdiagramm Ansichten

Es können zwei verschiedene Arten von Zahlen angezeigt werden. Standardmäßig ist das Feld Anzeigedaten ausgewählt, sodass die rohen, herstellerunabhängigen Zahlen angezeigt werden. Der Standardmodus kann auf der Konfigurationsseite Erweiterte Optionen ausgewählt werden. Die Unterschiede zwischen den Methoden werden hier beschrieben.

Datenfeld anzeigen

Diese Werte erhöhen sich im Falle eines Problems, da sie tatsächlich die Anzahl der Probleme (z. B. Anzahl der fehlerhaften Sektoren) oder Ereignisse enthalten. Die Grafik ist bei stagnierendem Trend ideal.

Viele Attribute (z. B. Betriebszeit, Anzahl der Einschaltzyklen usw.) nehmen ständig zu. Dadurch nimmt der Trend des Diagramms für diese Attribute ebenfalls zu, dies ist jedoch völlig normal. Für einige (insbesondere statistische) Attribute kann die Anzahl sehr hoch sein und dann fallen, dies ist auch normal. Das Diagramm ist wichtig für die kritischen Attribute (z. B. neu zugewiesene, schlechte Sektoranzahl), bei denen die Analyse der vorherigen Werte problematische Tage oder Zeiträume in der Lebensdauer der Festplatte aufdecken kann.

Anzeigen herstellerspezifischer Werte

Durch die Untersuchung der Anzahl der Nummern in der Spalte "Wert" ist es möglich, den Trend der herstellerabhängigen Werte zu überprüfen. Diese Werte verringern sich im Falle eines Problems, bis sie den Schwellenwert für das Attribut erreichen. Wenn das Attribut kritisch und der Schwellenwert erreicht ist, hat die Festplatte ein S.M.A.R.T.-Problem, an dieser Stelle sollte die Festplatte sofort ersetzt werden. Zu diesem Zeitpunkt sollten die Hersteller die Festplatte gemäß den Garantiebedingungen austauschen.

Attribut-Trend: geschätztes Erreichen des Schwellenwerts

Eine dunkelblaue Linie verbindet die tatsächlichen Messwerte. Am unteren Rand des Diagramms wird der Schwellenwert mit einer gelben Linie angezeigt.

Wenn der Trend abnimmt, verbindet eine violette Linie den zuletzt gemessenen Wert mit dem Schwellenwert. Diese Linie wird basierend auf den vorherigen Werten gezeichnet (blaue Linie). Es deutet eine geschätzte Verschlechterung der Festplatte in der Zukunft an: Wenn der Attributwert wie zuvor verringert wird, kann der Schwellenwert, der das Datum überschreitet (an welchem der Wert den Schwellenwert erreicht), leicht abgelesen werden.

Zum Beispiel (siehe Bild oben) kann abgelesen werden, dass die Festplatte am 28. Oktober 2006 zum ersten Mal untersucht wurde. Zu diesem Zeitpunkt betrug der Wert der neu zugewiesenen Sektoren 100. Am 9. November 2006 betrug dieser Wert nur 95 (aufgrund vieler neu zugeordneter Sektoren änderte sich der Wert von 100 auf 95). Wenn sich dieser Trend fortsetzt, erreicht dieses Attribut am 31. März 2007 seinen Schwellenwert 36 (dies wird auch auf der rechten Seite angezeigt, damit es leichter zu lesen ist). Das bedeutet, dass an diesem Datum (oder früher) die Festplatte aufgrund der zunehmenden Anzahl von Festplattenfehlern ersetzt werden muss.

Die Unterschiede zwischen den beiden Methoden sind hier beschrieben.

Anmerkung Bei SCSI-Festplatten enthält das S.M.A.R.T.-Bedienfeld die statistischen Informationen, die von der SCSI-Festplatte bereitgestellt werden (z. B. Gesamtzahl der gelesenen/geschriebenen Bytes, Anzahl der Lese-/Schreibfehler usw.). Das Diagramm unter der Liste kann verwendet werden, um den Trend eines solchen Attributs zu untersuchen.

Standardmäßig zeigt das Diagramm Werte, die zu verschiedenen Zeitpunkten gemessen wurden, als Hard Disk Sentinel aktiv war und den aktuellen Status aufzeichnen konnte. Die Daten werden automatisch ausgewählt und das Diagramm wird angepasst, um die Attributänderungen und Trends anzuzeigen.
Doppelklicken Sie auf das Diagramm, um alle möglichen Daten anzuzeigen. Um alle angezeigten Werte (im CSV-Format) mit den entsprechenden Messdaten zu exportieren, klicken Sie mit der rechten Maustaste auf das Diagramm und wählen Sie die Option Speichern.

Klicken Sie zwischen S.M.A.R.T.-Tabelle und Diagramm und ziehen Sie die Maus, um die Größe der Bedienfelder zu ändern.

Attribute auf verschiedenen Geräten

SCSI-, SAS-Festplatten und SSDs, NVMe-SSDs sowie andere spezielle Geräte (wie etwa industrielle Speicherkarten, Bandlaufwerke) liefern normalerweise völlig unterschiedliche Attribute und Formate. Es gibt keine Werte-/Schwellenwert-/schlechtesten Felder (die auf IDE- und seriellen ATA-Geräten vorhanden sind), sondern nur Attribute und deren Werte. Hard Disk Sentinel identifiziert den Status, die Fehlerzähler und statistische Informationen auch für diese Geräte.


Informationen

Auf der Informationsseite werden viele Details der Festplatte angezeigt. Dazu gehören unter anderem: Hersteller und Modelltyp, Revision (interne Version) und Seriennummer der Festplatte. Diese können verwendet werden, um die Festplatte zu überprüfen und zu identifizieren.

Die logischen Laufwerke und NTFS-Mountpunkte (falls konfiguriert), die der Festplatte zugeordnet sind, werden angezeigt. Dies kann hilfreich sein, wenn viele Festplatten installiert sind und sich viele logische Laufwerke im System befinden.

Mit der rechten Maustaste können die in der Tabelle angezeigten Informationen in die Zwischenablage kopiert werden. Später können diese Informationen in eine Textdatei, eine E-Mail oder ein Dokument eingefügt werden.

IDE-, "Serial ATA"-Fesplatte

IDE- und "Serial ATA"-Festplatten werden über die ATA-Schnittstelle gesteuert und identifiziert. Hard Disk Sentinel erkennt und zeigt die physikalischen Eigenschaften an (z. B. die Gesamtzahl der Sektoren, die Fehlerkorrekturbytes usw.). Die Puffergröße kann wichtig sein: Dies ist die Größe des internen Festplatten-Caches. Wenn die Leistung wichtig ist, wird empfohlen, Festplatten mit größeren Puffergrößen zu verwenden.

Die maximalen und aktuell ausgewählten Ultra-DMA-Modi werden angezeigt. Letztere bestimmen die aktuelle theoretisch maximale Datenübertragungsrate zwischen der Festplatte und dem Host. Natürlich ist ein größerer Wert besser.

Wenn der aktuelle Ultra-DMA-Modus ist (0), wenn das System den Ultra-DMA-Übertragungsmodus nicht verwendet und nur im PIO-Modus (Programmed I/O) arbeitet. Dies verringert die Leistung der Festplatte und des gesamten Systems drastisch, da der Prozessor warten muss, bis alle Lese-/Schreibvorgänge abgeschlossen sind. Es wird empfohlen, die Konfiguration zu überprüfen und dieses Problem zu beheben (z. B. durch Neuanordnen von Festplatten und optischen Geräten oder Verwenden neuer Kabel). "Ultra DMA 33"-Modus (2) bedeutet, dass ein altes IDE-Kabel mit nur 40 Drähten anstelle neuerer IDE-Kabel mit 80 Drähten verwendet wird. Es wird nicht empfohlen, runde oder zu lange Kabel zu verwenden.

Anmerkung: Bei einigen Controllern oder Systemen ist es möglich, dass das Laufwerk im PIO-Modus arbeitet, der Ultra-DMA-Modus jedoch zuvor ausgewählt wurde und dies in diesem Fenster angezeigt wird. Wenn Sie sich nicht sicher sind, aber eine langsame Leistung feststellen, überprüfen Sie die aktuelle Einstellung im Geräte-Manager, indem Sie die Eigenschaften des (IDE-) Controllers auswählen.

Bei SATA-Festplatten überprüft und meldet Hard Disk Sentinel auch das theoretische Maximum und die aktuell ausgehandelte Übertragungsgeschwindigkeit (sofern das dies Laufwerk unterstützt). Dies kann hilfreich sein, um zu überprüfen, ob die Leistung eines Festplattenlaufwerks (normalerweise einer SSD) durch den aktuellen Festplattencontroller eingeschränkt ist.

Hinweis: Hard Disk Sentinel prüft, ob die ATA-Informationstabelle vollständig und die Prüfsumme der Tabelle korrekt ist. Letzteres stellt sicher, dass die erkannten und angezeigten Informationen korrekt sind. Ist dies nicht der Fall, werden gar einige Werte von der Festplatte nicht korrekt gemeldet (z. B. der Leistungswert, der UDMA-Übertragungsmodus und die "Serial ATA"-Eigenschaften). In folgenden Fällen wird eine Warnung angezeigt:

Ungültige ATA-Kontrollbytes oder ATA-Prüfsummenwerte haben keinen Einfluss auf die Erkennung und Anzeige von Integritäts- und Temperaturwerten.

Akustik-Management

Akustik-Management von Laufwerken

Es ist möglich, die Akustik-Einstellungen anzuzeigen und zu ändern, wenn diese Funktion von der Festplatte unterstützt wird. Höhere Schallpegel ermöglichen einen schnelleren (aber lauteren) Betrieb. Wenn Sie eine niedrigere Stufe einstellen, wird die Festplatte langsamer und leiser (die Positionierung des Lese-/Schreibkopfs ist langsamer und leiser). Die Akustik-Einstellung hat keinen Einfluss auf die Antriebsdrehzahl. Wenn das Laufwerk Akustik-Management unterstützt, können Sie den Pegel ändern, indem Sie auf Anpassen klicken.

Die wichtigsten ATA-Features werden angezeigt, sodass die zusätzlichen Funktionen überprüft werden können (z. B. Sicherheitsmodus, Energieverwaltung usw.).

S.M.A.R.T.-Details

In diesem Abschnitt werden die Ergebnisse und Details der Hardware-Selbsttests der Festplatte angezeigt. Die unterstützten Selbsttests können hier ausgeführt werden, indem Sie auf hier klicken, um zu starten klicken. Die geschätzte Dauer der Selbsttests wird angezeigt (der Hersteller hat diese Schätzungen bereitgestellt), aber die Selbsttests können viel länger dauern, als angezeigt wird. Der kurze Selbsttest testet die Funktionalität der wichtigsten Festplattenkomponenten (Kopf, Servo, Elektronik). Die Optionen Erweiterter Selbsttest und Transport-Selbsttest (falls unterstützt) führen herstellerspezifische Testschritte aus. Der erweiterte Selbsttest überprüft die gesamte Oberfläche der Festplatte. Während dieses Vorgangs werden die Problembereiche (falls vorhanden) überprüft. Es wird daher empfohlen, diesen Test regelmäßig durchzuführen.

Während des Tests wird ein Fenster mit dem aktuellen Status der Festplatte angezeigt. Wurde der Test abgeschlossen, wird Erfolg oder Misserfolg (und das fehlerhafte Element, was Servo, Elektronik, Kopf usw. sein kann) angezeigt. Während des Selbsttests kann die Festplatte verwendet werden. Normalerweise ist die HDD-LED während der Tests dunkel, man hört vielleicht trotzdem, dass die Festplatte in Betrieb ist. Lese-/Schreibvorgänge während des Tests können den Test verlangsamen - und umgekehrt können aufgrund des Tests die Lese-/Schreibvorgänge langsamer sein. Es wird daher empfohlen, den Test in Leerlaufzeiten auszuführen.

Anmerkung: Die Selbsttests Erweitert und Transport (falls unterstützt) können nur in der registrierten Version verwendet werden.

SCSI-Festplatte

Bei einer SCSI-Festplatte werden die zur Identifizierung der Festplatte erforderlichen Informationen angezeigt. Die vom Hersteller bereitgestellte Zeichenfolge und der Status der Fehlervorhersagefunktion werden auch mit den erkannten ASC- und ASCQ-Rohwerten angezeigt.

Auf der Seite Informationen werden weitere gerätespezifische Details für SCSI-, SAS-Festplatten und SSDs angezeigt, einschließlich Features, Funktionen, optionalen Features usw.


Geräoschpegel

Es ist möglich, die Akustik-Einstellungen einer IDE/Serial-ATA-Festplatte anzuzeigen oder zu ändern, wenn diese Funktion von der Festplatte unterstützt wird. Höhere Schallpegel ermöglichen einen schnelleren (aber lauteren) Betrieb. Wenn Sie eine niedrigere Stufe einstellen, wird die Festplatte langsamer und leiser (die Positionierung des Lese-/Schreibkopfs ist langsamer und leiser). Die Akustik-Einstellung hat keinen Einfluss auf die Antriebsdrehzahl.

Wird dies von der Festplatte unterstützt, kann der Geräuschpegel in diesem Fenster geändert werden. Mit dem Schieberegler kann der Benutzer auswählen, was für ihn wichtig ist (leiser oder schneller Betrieb oder er kann ein Gleichgewicht zwischen den Endpunkten auswählen). Der empfohlene Schallpegel (vom Hersteller festgelegt) wird angezeigt. Das Einstellen eines akustischen Pegels wirkt sich nicht auf den Zustand der Festplatte aus.

Wenn zwei oder mehr Festplatten getestet und verglichen werden (z. B. in einem Benchmark), sollte für alle Festplatten der gleiche Schallpegel konfiguriert sein (z. B. am schnellsten oder am langsamsten), um genaue Ergebnisse zu erhalten.

Anmerkung: Die Konfiguration des akustischen Pegels hängt stark von den Fähigkeiten des Hosts (Controller, Motherboad) und der installierten Treiber ab. Unterstützt der Controller oder der Treiber diese Funktion nicht, wird eine Fehlermeldung angezeigt und der Schallpegel bleibt unverändert. In diesem Fall kann die Verwendung eines anderen Controllers oder das Ändern des Controllertreibers der Festplatte hilfreich sein. Einige Festplatten bieten nur zwei Werte an den beiden Enden des Schiebereglers (daher kann das Einstellen einer mittleren Ebene zum Ende wechseln), während andere Festplatten womöglich die Einstellung auf eine ausgeglichene Einstellung ermöglichen.

Erfahrungsgemäß sollten Festplatten die über die Einschaltzyklen konfigurierte Einstellung schützen (beibehalten). Daher sollte nach dem Ausschalten/Einschalten der konfigurierte Wert verwendet werden. Die meisten Festplatten setzen jedoch den Wert beim Aus- und Einschalten zurück. Hard Disk Sentinel verfügt über eine Option namens Einstellung bei Neustart automatisch anpassen. Wenn Sie die APM-Einstellung konfigurieren/anpassen, übernimmt Hard Disk Sentinel diese automatisch, wenn erforderlich (zum Beispiel beim nächsten Start, wenn das Gerät den eingestellten Wert vergessen zu haben scheint).

Die gleiche Konfiguration und Einstellungen (und der Hinweis zur Option Einstellung bei Neustart automatisch anpassen) gilt auch für andere Festplattenfunktionen, z. B. auch die Einstellungen Erweiterte Energieverwaltung und Freifall-Kontrolle.

Durch Anpassen der Einstellung Erweiterte Energieverwaltung können wir steuern, ob das Laufwerk die Stromversorgung erhalten (und in allen möglichen Situationen parken/herunterfahren) oder sich weiter drehen und das Parken auch in Leerlaufsituationen verhindern soll. Viele Laufwerke parken standardmäßig sehr häufig die Köpfe (was die Lebensdauer der Festplatte bei minimaler Energieeinsparung verkürzen kann). Daher wäre es etwa besser, den Wert ganz rechts (FEh - höchster Stromverbrauch) mit Hard Disk Sentinel zu konfigurieren, um das Parken/Herunterfahren zu verhindern und damit die Lebensdauer der Festplatte zu erhöhen (sofern vom Laufwerk unterstützt und anwendbar, z. B. Festplattenlaufwerke, die in Desktop-Systemen verwendet werden). Beachten Sie, dass diese Einstellung völlig unabhängig von der Windows-Energieverwaltungseinstellung (Time-out für das Herunterfahren der Festplatte) ist.

Durch Anpassen der Empfindlichkeit der Freifall-Kontrolle (sofern dies vom Festplattenlaufwerk unterstützt wird) können wir einstellen, wie schnell das Laufwerk die Köpfe von der Oberfläche zum Parkplatz bewegen soll, wenn es eine Beschleunigung erkennt (normalerweise Herunterfallen oder Stoß), um einen Festplattenfehler zu vermeiden. Einige Notebook-Festplatten unterstützen diese Funktion und ermöglichen das Anpassen der Empfindlichkeit. Normalerweise bieten sie auch ein Attribut "Anzahl der Freifall-Ereignisse" in der S.M.A.R.T.-Attributliste, um zu zählen, wie oft das Laufwerk solche Ereignisse hinter sich hat.


Protokoll

Für jede im System installierte Festplatte führt Hard Disk Sentinel ein Protokoll. Die Verschlechterungen des Datenfeldes der wichtigsten S.M.A.R.T.-Attribute werden in diesem Protokoll gespeichert. Diese Attribute sind:

  • 5: Reallocated Sectors Count.

  • 10: Spin Retry Count.

  • 196: Reallocation Event Count.

  • 197: Current Pending Sector Count.

  • 198: Off-Line Uncorrectable Sector Count.

  • 199: Ultra ATA CRC Error Count (Datenübertragungsfehler).

Wenn eine Festplatte längere Zeit nicht auf die Abfrage von Hard Disk Sentinel reagiert, wird sie ebenfalls protokolliert (wenn diese Funktion auf der Seite Erweiterte Optionen aktiviert ist).

Alle Einträge haben das genaue Datum und die Uhrzeit, die Attributkennung sowie die vorherigen und neuen Rohwerte des Attributs. Es ist möglich, dass sich zwei oder mehr Attribute seit der vorherigen Erkennung geändert haben (insbesondere wenn Hard Disk Sentinel nur gelegentlich gestartet wird) und zwei oder mehr Protokolleinträge gleichzeitig erstellt werden.

Es ist möglich, die Anwendung so zu konfigurieren, dass Warnungen gesendet/ausgegeben werden, wenn dem Protokoll ein neuer Eintrag hinzugefügt wird. Auf diese Weise kann der Benutzer benachrichtigt werden, wenn von Hard Disk Sentinel ein neues Problem erkannt wird (wodurch sich der Festplattenzustand ändern kann). Diese Funktion ist nur in der registrierten Version verfügbar.

Es ist möglich, einige Attribute in der S.M.A.R.T.-Seite der Festplatte zu deaktivieren, indem man die Option in der Spalte "Aktivieren" verwendet. Die Änderungen der deaktivierten Attribute werden nicht im Protokoll gespeichert (sie generieren keine Warnungen) und wirken sich nicht auf den Wert des Festplattenzustands aus.

Hinweis: In der aktuellen Version des Protokolls werden nur die letzten 50 Probleme gespeichert. Danach werden die ältesten Probleme verworfen.

Hinweis: Die obigen Informationen spiegeln das ursprüngliche Design von Hard Disk Sentinel wider. Abhängig von der tatsächlichen Festplatte, Geräteverbindung/-modell, können auch verschiedene Attribute und deren Änderung/Verschlechterung auf der Protokollseite gemeldet werden, da verschiedene Geräte (Festplatten und SSDs) möglicherweise weitere (oder völlig unterschiedliche) Attribute aufweisen, die für die Überwachung der Änderungen wichtig sind.


Leistungsüberwachung in Echtzeit

Auf dieser Seite wird die Menge der übertragenen (gelesenen und geschriebenen) Daten sowohl in der aktuellen Sitzung als auch seit der Installation angezeigt. Auf diese Weise werden auch die täglichen durchschnittlichen Schreib- und Lesemengenwerte angezeigt.

Ein Doppelklick auf das angezeigte Installationsdatum ermöglicht das Konfigurieren des Datums für die aktuelle Festplatte, sodass die täglichen Lese-/Schreibstatistiken ab dem jeweiligen Installationsdatum berechnet werden können.

Hard Disk Sentinel überwacht kontinuierlich die aktuellen Schreib- und Lesegeschwindigkeiten und überprüft, inwieweit die aktuelle Nutzung die Festplatte belastet. Dies wird in Prozent (%) angezeigt, genau so wie der Benutzer die CPU-Auslastung im Task-Manager überprüfen kann.

Wenn Hard Disk Sentinel einen Schreibvorgang erkennt, werden eine orangefarbene "LED" und die aktuelle Schreibgeschwindigkeit angezeigt. Im Falle einer Leseoperation werden die Lesegeschwindigkeit und eine hellblaue "LED" dargestellt. Natürlich sind diese Farben unabhängig vom Status der Festplatte.

Basierend auf der aktuellen Übertragungsrate und der aktuellen Festplattennutzung schätzt die Anwendung eine mögliche (theoretische) maximale Übertragungsrate, die für kurze Zeit als Spitzenübertragungsrate erreicht werden kann. Dieser Wert wird nach folgender Formel berechnet: (geschätzte maximale Übertragungsrate) = (aktuelle Übertragungsrate) / (aktuelle Festplattenauslastung in %). Wenn die Festplatte beispielsweise Daten mit 20 MB/s überträgt und die aktuelle Festplattenauslastung 50 % beträgt, ergibt die geschätzte maximale Übertragungsrate 40 MB/s. Um die Genauigkeit zu erhöhen, werden die durch geringe Festplattennutzung berechneten Werte automatisch ignoriert. Dies ist ein theoretischer Maximalwert. Einige Geräte, Caches oder andere Anwendungen können diesen Wert beeinflussen.

Die Grafiken unten zeigen den tatsächlichen Wert der Plattenaktivität/Übertragungsrate mit der hellblauen Linie und einen Durchschnittswert mit der roten Linie (Durchschnitt der zuletzt gemessenen tatsächlichen Werte).

Wenn Sie zum Beispiel einen Kopiervorgang starten, sehen Sie möglicherweise, dass die Cyan-Linie sofort springt (was darauf hindeutet, dass der Vorgang aktiv ist) und die rote Linie langsamer folgt. Dieser Durchschnitt ist bei einer hohen Anzahl von Festplattenvorgängen gleichzeitig nützlich (z. B. wenn unterschiedliche Software ständig auf die Festplatte zugreift), da dieser Durchschnitt eventuell die Festplattenaktivität/Übertragungsrate besser widerspiegelt - anstelle der sich ständig ändernden tatsächlichen Werte.

Die aktuelle Datenträgerübertragungsrate und die Diagramme zur Datenträgerverwendung können in vielen Fällen hilfreich sein. Zum Beispiel:

  • Bei Verwendung von zwei oder mehr Festplatten kann geprüft werden, welche Festplatten aktiv sind und mit welcher Geschwindigkeit sie arbeiten. Zum Beispiel wenn das System auf der ersten Festplatte installiert ist und auf die anderen Festplatten eine Anwendung zugreift, die großen Datenverkehr generiert, kann die Festplattennutzung der Anwendung problemlos überprüft werden. Während eines konstanten Ladevorgangs kann zudem die aktuelle Nutzung der Systemfestplatte untersucht werden, wobei zu viel virtueller Speicher belegt wird.

  • Während einer Kopie zwischen zwei verschiedenen Festplatten: Übertragungsrate und Geschwindigkeit der beiden Festplatten können verglichen werden, und dies kann anzeigen, welches Laufwerk langsamer als das andere ist.

  • Während des Brennens von Daten in einen optischen Speicher: Um die tatsächliche Datenübertragungsrate (Brenngeschwindigkeit) zu ermitteln und um zu überprüfen, wie groß dabei die Festplattennutzung ist. Eine geringere Festplattennutzung bedeutet, dass eine höhere Brenngeschwindigkeit ausgewählt werden kann.

  • Auf einem Server (Datei- oder Datenbankserver mit hoher Auslastung) können Nutzung und Übertragungsrate der Festplatte(n) überprüft werden. Auf diese Weise kann der Administrator entscheiden, ob beim Hinzufügen neuer Clients eine neue (schnellere) Festplatte erforderlich ist.

  • Wenn während eines Vorgangs mit konstanter Geschwindigkeit (z. B. Brennen auf DVD) die Festplattennutzung ständig steigt und fällt (das Diagramm enthält viele Spitzen), sind die Daten auf der Festplatte vermutlich arg fragmentiert, und eine Defragmentierung wird empfohlen (Auch eine zu hohe Auslastung des virtuellen Speichers kann dieses Problem verursachen.).

Hinweis: Die Echtzeit-Leistungsüberwachung hängt vom aktuellen Betriebssystem ab. Sie ist unter Windows 95/98/ME nicht verfügbar. Auf einigen externen Laufwerken (z. B. USB-Stick oder Speicherkarte) wird diese Funktion nicht unterstützt.

Hinweis: Die Echtzeit-Leistungsüberwachung hängt von der Funktion der Windows-Leistungsindikatorobjekte ab und ist unabhängig vom tatsächlichen Integritätsstatus der Festplatte. Ist diese Funktion in Windows deaktiviert oder sind die Leistungsindikatoren beschädigt oder fehlen sie, steht die Echtzeit-Leistungsüberwachung nicht zur Verfügung. Weitere Informationen finden Sie unter Es werden keine Leistungsinformationen angezeigt. Was ist falsch? auf der Seite "Häufig gestellte Fragen".


Warnungen

Die von der Festplatte generierten Warnungen werden auf dieser Seite aufgelistet.

Die Liste enthält sowohl den Ereignistyp (Überhitzung, schwacher Zustand, vorhergesagter Fehler usw.) als auch das Ereignisdatum.

In dieser Liste werden nur Ereignisse protokolliert und angezeigt, denen mindestens eine Warnung zugeordnet ist (akustische Warnung, E-Mail usw.).


Logisches Laufwerk

Im Informationsfenster werden die Details des ausgewählten logischen Laufwerks angezeigt, einschließlich der zugehörigen physischen Festplatte(n) (im Falle eines gebänderten (stripped) oder gespiegelten Volumes kann das logische Laufwerk mehreren physischen Festplatten zugeordnet sein), Name, Seriennummer. In diesem Fenster werden auch die Informationen zu gesamtem und freiem Speicher angezeigt.

Hard Disk Sentinel zeigt auch den Partitionsstil (MBR oder GPT), den Datenträgertyp und die Partitionsausrichtung an (um bei Leistungsproblemen zu helfen, wenn ein Laufwerk mit 4 KByte Sektorgröße (4K-Laufwerke) verwendet wird. Hard Disk Sentinel zeigt die Größe der Zuordnungseinheit (Cluster) an sowie die insgesamt verfügbaren freien Zuordnungseinheiten (Dies ist der kleinste Abschnitt, der von einer Datei verwendet wird, wenn ihre Größe kleiner als dieser Wert ist.).


Status der Offline-Laufwerke öffnen (nicht mehr verbunden)

Standardmäßig erkennt Hard Disk Sentinel alle Laufwerke, die aktuell mit dem derzeitigen System verbunden sind, und zeigt sie an. Hard Disk Sentinel speichert den Status, Änderungen, Protokolle und Statistiken zu diesen Laufwerken und kann so Details zum Verlauf dieser Laufwerke bereitstellen.

Wird ein Laufwerk entfernt, nicht mehr zugänglich, getrennt sind die zuvor gespeicherten Statusinformationen noch vorhanden. Wird die Funktion "Status der Offline-Laufwerke öffnen" verwendet, können wir den letzten bekannten Status erneut laden und mögliche Änderungen, Verschlechterungen, Protokolle und Statistiken genauso untersuchen, als würde das Laufwerk noch angeschlossen und aktiv überwacht.

In diesem Fenster können alle Laufwerke ausgewählt werden, die auf diese Weise gelesen werden sollen. Anschließend wird das Laufwerk im oberen linken Bereich (Liste der physischen Laufwerke) im Hauptfenster mit der Farbe Dunkelblau angezeigt. Dies zeigt an, dass es nicht aktiv überwacht wird, nicht mehr verbunden ist (offline), sondern dazu verwendet werden kann, seinen Zustand und seine Geschichte zu überprüfen.


(Network Attached Storage) NAS-Laufwerksüberwachung konfigurieren

Neben der Überwachung und Diagnose von Festplatten, die direkt mit der tatsächlichen Konfiguration verbunden sind, können auch über das Netzwerk verbundene Laufwerke überwacht werden: Überwachung von NAS-Geräten (Network Attached Storage). Standardmäßig bieten NAS-Geräte keine Möglichkeit, das aktuelle Festplattenmodell, die Temperatur, den Zustand und weitere Statusinformationen zu identifizieren. Durch Erweitern der Funktionalität des NAS-Geräts können jedoch regelmäßige Berichte, Status Quelle gehannt, auf dem NAS selbst erstellt werden, die von Hard Disk Sentinel gelesen, interpretiert und angezeigt werden können. Auf diese Weise können Laufwerke im NAS so überwacht werden, als wären sie direkt mit dem eigentlichen Computer verbunden. An das Netzwerk angeschlossene Speicherlaufwerke werden in der Liste der physischen Laufwerke im Hauptfenster hellorange angezeigt.

Weitere Informationen, Anweisungen und Schritte finden Sie auf der Webseite: How to: monitor Network Attached Storage (NAS) status - eine Schritt-für-Schritt-Anleitung mit Bildern, die den gesamten Vorgang veranschaulichen.Hinweis: Diese Funktion kann nur in der registrierten Professional-Version verwendet werden.


Konfiguration

In diesem Fenster können Sie die Optionen von Hard Disk Sentinel ändern. Die Optionen sind in verschiedene Kategorien unterteilt, die sich auf der linken Seite des Fensters befinden. Durch Klick auf eine Kategorie werden die entsprechenden Optionen auf der rechten Steuerungsseite angezeigt. Diese Kategorien sind:

  • Festplatten

  • Einstellungen

  • Statusfenster

  • Schwellenwerte/Trayicon

  • Warnungen

  • Nachrichten-Einstellungen

  • E-Mail-Konfiguration

  • Registrierung

  • Aktualisieren

  • Erweiterte Optionen

  • Laufwerksteuerung

  • Hotkeys

  • Operationen (nur mit installierter PROFESSIONAL-Version)

  • Integration

  • Testbericht senden


Konfiguration: Festplatten

Auf dieser Seite werden alle erkannten Festplatten angezeigt. Durch Aktivieren des Kontrollkästchens vor der Festplattennummer können Sie festlegen, welche Festplatten im Statusfenster angezeigt werden sollen. Durch Doppelklick auf eine Festplatte wird ein Trayicon für die Festplatte hinzugefügt/entfernt.

Es ist möglich, nur ein einziges Trayicon mit der höchsten Temperatur anzuzeigen. Auf diese Weise kann sich das Symbol ändern und verschiedene Festplatten widerspiegeln (da die Temperaturwerte variieren können). Ist diese Option aktiviert und auch die Anzeige des Zustandszeichens, wird das Symbol des niedrigsten gefundenen Integritätswerts angezeigt (auch wenn die Festplatte mit dem niedrigsten Integritätswert nicht mit der Festplatte mit der höchsten Temperatur identisch ist).

Hinweis: Wenn der Mauszeiger über die Trayicons bewegt wird, werden die zugehörigen Festplattendetails in einem kleinen Hinweisfenster angezeigt.

Wenn Sie mit der rechten Maustaste auf eine Festplatte klicken, wird das lokale Menü der Festplatte angezeigt (siehe Abbildung oben). In diesem Menü können Sie das Symbol der Festplatte in der Taskleiste ein- oder ausblenden oder auf die Details der Festplatte zugreifen (eine beliebige Informationsseite). Darüber hinaus kann das Fenster mit dem Akustik-Management über dieses Menü geöffnet werden (sofern diese Funktion von der Festplatte unterstützt wird).

Laufwerksaktivitätssymbole (Aktivitäts-LEDs)

Auf der Seite Laufwerk Leistungsfähigkeit werden die aktuelle Übertragungsgeschwindigkeit eines Laufwerks und die Festplattenaktivität in Prozent (%) angezeigt. Dies kann (wie die im Windows Task-Manager angezeigte CPU-Auslastung in %) anzeigen, wie viel Zeit (in %) das Laufwerk inaktiv ist oder für einen Lese-/Schreibvorgang verwendet wird. Dies kann darauf hindeuten, dass das Laufwerk "vollständig" aktiv ist oder eine schnellere Leistung erbringen kann. Dies ist unabhängig von der Festplattennutzung (verwendeter/freier Speicherplatz).

Es ist möglich, für jede Festplatte ein Trayiconl hinzuzufügen, wobei "LEDs" die oben genannte Festplattenaktivität anzeigen: Weitere LEDs zeigen an, dass das Laufwerk aktiver ist - während keine (oder nur 1-2 LEDs) andeuten, dass das Laufwerk fast inaktiv ist und mehr genutzt werden könnte. Diese Funktion kann besonders dann nützlich sein, wenn die LED für die tatsächliche Festplattenaktivität nicht sichtbar ist, überhaupt nicht funktioniert (z. B. bei zusätzlichen Festplatten-/RAID-Controller-Karten) und wir ein visuelles Feedback zur Festplattenaktivität wünschen, insbesondere um zu wissen, wann ein Laufwerk Lese- oder Schreibbefehle ausführt.

In Konfiguration: Festplattenlaufwerke aktivieren Sie das Aktivitätssymbols für jede Festplatte das Kontrollkästchen "Aktivitätssymbol" des entsprechenden Laufwerks (wenn Hard Disk Sentinel Echtzeit-Leistungsdaten vom System empfängt und daher das Wort "unterstützt" angezeigt). Alternativ können Sie ein einzelnes Symbol hinzufügen, um die gesamte Festplattenaktivität widerzuspiegeln, indem Sie die Option "Zeige gesamte Laufwerksaktivität auf einem einzelnen Trayicon" aktivieren.


Konfiguration: Einstellungen

Es ist möglich, einige globale Optionen von Hard Disk Sentinel zu steuern.

Statusfenster beim Start anzeigen: Das Statusfenster soll beim Starten der Anwendung automatisch angezeigt werden oder nicht. Durch Ausblenden oder Anzeigen des Statusfensters wird diese Option auch geändert (wenn das Fenster ausgeblendet und die Anwendung neu gestartet wurde, wird das Statusfenster nicht automatisch angezeigt).

Laden mit Windows : Soll Hard Disk Sentinel jedes Mal gestartet werden, wenn Windows gestartet wird und der Benutzer sich anmeldet. Es wird empfohlen, diese Funktion zu verwenden, da auf diese Weise der Status von Festplatten ständig analysiert wird. Mit der Option Verzögerung vor Start können Sie eine Verzögerung konfigurieren, bevor zum ersten Mal auf die Festplatten zugegriffen wird. Dies ist besonders nützlich, wenn das System beim Start eine große Anzahl anderer Anwendungen lädt, da die Option dem Systemstart mehr Zeit lässt, alles zu laden und zu initialisieren.

Hauptbildschirm beim Start anzeigen: Zeigt beim Start der Anwendung automatisch das Hauptfenster an. Hinweis: Diese Option kann nur in der registrierten Version deaktiviert werden. In der nicht registrierten Version wird das Hauptfenster bei jedem Start automatisch angezeigt.

Anwendung auch in der Taskleiste anzeigen: Wenn ein Fenster von Hard Disk Sentinel geöffnet ist (mit Ausnahme des Statusfensters), wird die Anwendung in der Taskleiste neben anderen laufenden Programmen angezeigt. Ist diese Option deaktiviert, werden nur die Trayicons neben der Uhr angezeigt, auch wenn ein oder mehrere Fenster der Anwendung geöffnet sind.

Es ist möglich, die Sprache zu konfigurieren, die in der Benutzeroberfläche und in allen Berichten, E-Mails und Nachrichten verwendet werden soll. Die Temperatureinheit (Celsius oder Fahrenheit) kann eingestellt werden, und es ist möglich, die übertragene Dateneinheit (MB, GB oder TB, Multiplikationen von 1024 ) auszuwählen, die auf der Leistungs-Informationsseite aller Festplatten verwendet werden soll. Darüber hinaus kann die Einheit für die physische Festplatte und die Partitionsgröße konfiguriert werden.


Konfiguration: Statusfenster

Das Layout des Statusfensters kann auf dieser Seite konfiguriert werden. Der Benutzer kann eine beliebige Farbe oder ein Bild auswählen, um es als Hintergrund für das Statusfenster zu verwenden. Die Auswahl kann über die entsprechende Schaltfläche "Auswählen" getroffen werden. Als Vorschau wird die ausgewählte Farbe oder das ausgewählte Bild in der oberen rechten Ecke angezeigt. Hinweis: Wenn Sie ein Bild als Hintergrund verwenden, wird dieses automatisch auf die richtige Größe des Statusfensters gestreckt.

Ist die Option An Bildschirmrändern andocken aktiviert, kann das Statusfenster nicht außerhalb des Bildschirms verschoben werden. Stattdessen wird das Fenster am Bildschirmrand ausgerichtet, wenn es in die Nähe eines Randes verschoben wird. Ist die Option deaktiviert, kann das Fenster (teilweise oder vollständig) außerhalb des Bildschirms verschoben werden.

Es ist möglich, die Transparenz des Statusfensters zu konfigurieren (sofern dies vom Betriebssystem unterstützt wird), und der Benutzer kann den bevorzugten Typ, die Größe und Farbe der Schrift auswählen. Es wird empfohlen, korrekte Einstellungen zu verwenden, die für den Benutzer leicht lesbar sind (in Bezug auf seine Vorlieben und das Licht, den Kontrast der Umgebung), die Größe des Fensters sollte den Benutzer jedoch nicht bei seiner Arbeit stören.

Man kann Mausklicks an das Fenster unterhalb des Statusfensters senden. Auf diese Weise akzeptiert das Statusfenster keine Klick- und Ziehvorgänge mit der Maus. Am besten kombinieren Sie diese Option mit der Transparenzoption. Sie können also auf ein Fenster unter dem Statusfenster klicken. Hinweis: Ist diese Option aktiviert, kann das Statusfenster nicht verschoben oder ausgewählt werden. Über das Trayicon können Sie auf die Funktionen der Anwendung zugreifen.

Alle Informationen im Statusfenster können direkt auf dem Desktop angezeigt werden. Die Daten werden "unterhalb" allen anderen Fenstern angezeigt und die Informationen können durch Klick auf das Symbol Desktop anzeigen überprüft werden. Mithilfe der X- und Y-Koordinaten kann der Speicherort der Informationen eingestellt werden. Hinweis: Die Informationen werden über den Verknüpfungen und Symbole des Desktops angezeigt. Es wird daher empfohlen, einen leeren Bereich für die Informationen anzugeben. Die Optionen "Aktiver Desktop" und "Webseite anzeigen" sollten deaktiviert sein, um diese Funktion zu verwenden. Hinweis: Diese Funktion kann den Prozessor intensiv in Anspruch nehmen, daher wird nicht empfohlen, sie auf langsameren Computern zu verwenden.

Bei Verwendung des vollständig transparenten Hintergrunds kann der Hintergrund des Statusfensters so transparent sein, dass das Fenster unter dem Statusfenster zwischen den Buchstaben und Symbolen sichtbar ist. Ist diese Option aktiviert, wird das Statusfenster möglicherweise nicht durch Klick auf das rote X ausgeblendet, jedoch können Hotkeys zum Ein-/Ausblenden des Fensters verwendet werden.

Die Option Immer im Vordergrund steuert, ob das Statusfenster über allen anderen Fenstern angezeigt wird. Nach dem Ändern dieser Option ist ein vollständiger Neustart der Software erforderlich.

Im Statusfenster wird für jede Festplatte eine Liste möglicher Elemente angezeigt. Hinweis: Die konfigurierten Elemente werden auch im Hinweisfenster gezeigt, wenn die Maus über ein Trayicon bewegt wird.

Unter Windows Vista/7 kann ein Seitenleisten-Gadget verwendet werden, um Festplatteninformationen (z. B. Temperatur und Zustand) anzuzeigen. Das visuelle Erscheinungsbild des Gadgets (Farbe, Schriftart, anzuzeigende Festplatten) kann über die Einstellungen des Statusfensters angepasst werden.


Konfiguration: Schwellenwerte/Trayicon

Einstellungen für Schwellenwerte und Trayicon

Auf dieser Seite können Sie das visuelle Erscheinungsbild der Trayicons abhängig von der Temperatur des Geräts festlegen. Jede Stufe hat entsprechende Farben: grün, gelb, rot - um das Verhältnis der Temperatur zu den Schwellenwerten anzuzeigen.

Diese globalen Schwellenwerte gelten für alle Geräte, es sei denn, für eines (oder mehrere) wurde auf der Seite Temperatur ein benutzerdefinierter Temperaturschwellenwert definiert. Dann werden die benutzerdefinierten Schwellenwerte für die jeweiligen Geräte verwendet, um das Symbol anzuzeigen und eine Warnung auszulösen (wenn der Schwellenwert erreicht ist).

Standardmäßig zeigt das Symbol den aktuellen Temperaturwert der Festplatte an (mit abwechselndem "Blinken" des Integritätssymbols: Warnungen wenn der Integritätswert unter dem konfigurierten Schwellenwert liegt).

Die Farben können in drei verschiedenen Schritten konfiguriert werden: Es ist möglich, die Vordergrund- und Hintergrundfarbe für niedrige Temperatur (grüner Pegel), hohe Temperatur (roter Pegel) und Temperatur zwischen den niedrigen und hohen Einstellungen (gelber Pegel) zu konfigurieren. Auf dieser Seite können die Schwellenwerte für niedrige und hohe Temperaturen konfiguriert werden.

Es ist auch möglich, ein Symbol bezüglich des Festplattenzustands auf dem Trayicon anzuzeigen. Es kann Grün (perfekt bei hohem Gesundheitswert), Rot (schlecht, bei niedrigem Zustand) oder Gelb (akzeptabel zwischen den beiden Schwellenwerten) sein. Es kann ausgewählt werden, wann das Zustandssymbol angezeigt werden soll - beispielsweise nur dann, wenn der Zustand zu niedrig ist (Standardeinstellung).

Wenn sowohl die Anzeige des Temperatur- als auch des Gesundheitssymbols aktiviert ist, werden diese beiden Bilder abwechselnd angezeigt (für eine Sekunde wird der Temperaturwert und für eine Sekunde das Symbol für den aktuellen Gesundheitswert angezeigt). Dieses "Blinken" kann die Aufmerksamkeit des Benutzers auf sich ziehen - dies kann jedoch störend wirken. Es wird empfohlen, die Standardeinstellung beizubehalten: das Trayicon nur bei Problemen blinken zu lassen.

Hinweis: Bei verschiedenen Geräten können möglicherweise auch benutzerdefinierte Integritätsschwellenwerte auf der Übersichtsseite konfiguriert sein. Diese funktionieren wie die benutzerdefinierten Temperaturschwellenwerte und überschreiben die Standardschwellenwerte für den Gesundheitszustand, wenn der Status und die Alarmbedingungen ermittelt werden müssen.


Konfiguration: Warnungen

Eine der wichtigsten Funktionen von Hard Disk Sentinel besteht darin, Warnungen zu erstellen oder Aufgaben auszuführen, wenn ein Problem gefunden wird. Auf diese Weise können die Probleme erkannt und vermieden werden, und mithilfe automatischer Aufgaben können die Dateien archiviert werden, um Datenverlust zu vermeiden. Mit jedem Problem können viele verschiedene Aufgaben verbunden werden.

Wird ein Fehler erwartet: Dieses Ereignis tritt auf einer Festplatte auf, wenn ein kritischer S.M.A.R.T.- Parameter einen vom Hersteller festgelegten Schwellenwert überschritten hat. In diesem Moment sollte die Festplatte sofort ersetzt werden. Hinweis: Zu diesem Zeitpunkt ist der Festplattenzustand bereits auf 0 % gesunken. Anmerkung: Diese Funktion ist nur in der registrierten Version verfügbar.

Wenn der Zustand der Festplatte niedrig ist: Dieses Ereignis tritt auf einer Festplatte dann auf, wenn der Integritätswert niedriger als der konfigurierte gelbe oder rote Wert ist. Hinweis: Diese Funktion ist nur in der registrierten Version vollständig verfügbar. In der nicht registrierten Version kann nur die Gelbstufe ausgewählt werden, um eine Warnung auszulösen.

Wenn die Temperatur hoch ist: Dieses Ereignis tritt auf einer Festplatte auf, wenn die Temperatur über den konfigurierten gelben oder roten Wert erhöht wird. Hinweis: Diese Funktion ist nur in der registrierten Version vollständig verfügbar. In der nicht registrierten Version kann nur die Gelbstufe ausgewählt werden, um eine Warnung auszulösen.

Wenn ein neuer Protokolleintrag hinzugefügt wird: Dieses Ereignis tritt dann auf einer Festplatte auf, wenn sich ein kritisches S.M.A.R.T.-Attribut verschlechtert und dieses Problem im Protokoll der Festplatte festgehalten wird. Hinweis: Diese Funktion ist nur in der registrierten Version verfügbar.

Wenn der freie Speicherplatz niedrig ist: Dieses Ereignis tritt auf einem logischen Laufwerk auf, wenn der freie Speicherplatz unter dem konfigurierten Schwellenwert liegt. Hinweis: Diese Funktion ist nur in der registrierten Version verfügbar. Es ist möglich, den Schwellenwert für freien Speicherplatz global zu konfigurieren (eine Einstellung für alle logischen Laufwerke), oder es können unterschiedliche Schwellenwerte für freien Speicherplatz für jedes logische Laufwerk festgelegt werden (unter Verwendung von % oder Megabyte (1024 x 1024 Bytes) als Einheit):

Schwellenwerte für freien Speicherplatz

Es ist möglich, den zu verwendenden akustischen Alarm auszuwählen. Dies kann jede vom System unterstützte Audiodatei sein (z. B. wav, mid, mp3, wma), und Hard Disk Sentinel verwendet sie als Warnung.

Wenn die Option Soundalarm wiederholen aktiviert ist, wiederholt die Anwendung den Soundalarm kontinuierlich, bis der Benutzer den Soundalarm durch Deaktivieren der Soundalarme bestätigt (über das Schnellmenü) oder aus dem Hauptfenster). Auf diese Weise werden die Gründe für die akustischen Warnungen angezeigt und der Benutzer kann sie untersuchen, bevor er weitere akustische Warnungen deaktivieren kann. Die Verwendung dieser Funktion wird auf Servern empfohlen, auf denen kein lokaler Benutzer vorhanden ist. Möglicherweise wird jedoch der akustische Alarm bemerkt, und der Remote-Alarm ist nicht möglich.

Die Option PC-Lautsprecher verwenden ermöglicht die Verwendung des internen PC-Lautsprechers ("Summer Speaker") anstelle der Soundkarte. Auf diese Weise müssen keine externen Lautsprecher an den Computer angeschlossen werden. Die Verwendung dieser Funktion wird auf Servern empfohlen (kombiniert mit der vorherigen Option). Hinweis: Ist diese Funktion aktiviert, wird der akustische Alarm "ein doppelter 1000-Hz-Piepton" anstatt einer Audiodatei auf dem PC-Lautsprecher abgespielt. Hinweis: Einige Computer (insbesondere Notebooks) womöglich nicht über einen PC-Lautsprecher verfügen. Bitte stellen Sie immer sicher, dass der akustische Alarm auf Ihrem System hörbar ist.

Mit der Schaltfläche Teste Sound-Warnung können Sie die konfigurierte Sound-Warnung prüfen (Sounddatei abspielen oder den PC-Speaker verwenden). Ist die Warnung nicht hörbar, müssen eventuell Kabel und Lautsprecher überprüft oder die Konfiguration geändert werden.

Es ist möglich, geplante Status-E-Mails zu senden, die die aktuelle Konfiguration und den Status aller Festplatten enthalten. Hard Disk Sentinel sendet die E-Mail später automatisch, wenn die E-Mail zum konfigurierten Zeitpunkt nicht gesendet werden kann, weil der Computer nicht funktioniert hat oder wenn ein Netzwerkproblem vorliegt. Hinweis: Diese Funktion ist nur in der registrierten Version verfügbar.

Wenn die Option Sende/Zeige Nachricht für ein Problem verwendet wird, wird die Nachricht gemäß den konfigurierten Nachrichteneinstellungen angezeigt und/oder zugestellt.

Ist die Option Panik-Backup aktiviert, werden die konfigurierten Aufgaben automatisch ausgeführt, wenn ein Problem gefunden wird. Es ist möglich, verschiedene Aufgaben bezogen auf die problematischen Festplatte zu definieren. Hinweis: Diese Funktion ist nur in der PROFESSIONAL-Version verfügbar.

Wenn die Option Herunterfahren aktiviert ist, wird der Computer automatisch ausgeschaltet (heruntergefahren), um weitere Probleme zu vermeiden. Natürlich wartet die Anwendung, bis alle anderen Aufgaben abgeschlossen sind, bevor der Computer heruntergefahren wird. Vor dem Herunterfahren gibt es einen Countdown von einer Minute. Während dieser Zeit kann das Herunterfahren abgebrochen werden.

Wichtig: In jeder Sitzung kann jedes Problem auf jeder Festplatte nur einmal eine Warnung auslösen. Mit anderen Worten, wenn eine Festplattentemperatur den Gelbpegel erreicht und eine Warnung für den Gelbpegel aktiviert ist, werden die Warnungen ausgeführt (z. B. wird eine akustische Warnung abgespielt oder eine E-Mail gesendet usw.). Wenn die Festplatte unter den Schwellenwert abkühlt und erwärmt sich dann wieder auf den gelben Wert, generiert diese Festplatte keine erneute Warnung. Auf diese Weise können zu viele Warnungen (z. B. zu viele E-Mails) vermieden werden, wenn sich die Festplatte in der Nähe der Schwellenwerte befindet. Wenn sich eine andere Festplatte auf Gelb erwärmt, wird natürlich eine neue Warnung generiert.

Die Liste der zuvor bearbeiteten Warnungen wird jeden Tag um Mitternacht gelöscht. Dies bedeutet, dass ein Computer (Server), der über einen längeren Zeitraum (etwa Wochen) ausgeführt wird, jeden Tag eine Warnung pro Festplatte für jedes Problem ausgibt.

Die Liste der zuvor bearbeiteten Warnungen kann jederzeit im Hauptfenster gelöscht werden sowie dadurch, dass auf die Software durch das Betätigen der Verknüpfung auf dem Desktop oder in der Schnellstartleiste zugegriffen wird. Diese Aktionen zwingen Hard Disk Sentinel, seine internen Daten neu zu initialisieren und die Warnungen erneut auszugeben.


Konfiguration: Nachrichten-Einstellungen

Wird ein Problem gefunden, kann Hard Disk Sentinel Warnungen senden oder anzeigen. Auf dieser Seite können Sie die Typen solcher Warnungen konfigurieren. Eine beliebige Kombination der Optionen ist möglich. Hinweis: Es sollte mindestens ein Alarmtyp ausgewählt werden.

E-Mail senden: Im Falle eines Problems sendet Hard Disk Sentinel eine E-Mail mit der Problembeschreibung. Die E-Mail wird wie auf der Seite E-Mail-Konfiguration konfiguriert geliefert und zugestellt. Es ist möglich, vor dem Senden die Standard-Internetverbindung zu wählen (dies kann erforderlich sein, wenn ein DFÜ- oder DSL-Modem verwendet wird), zudem es ist möglich, die Verbindung nach dem Senden der Nachricht zu schließen (auflegen). Hinweis: Ist die Option zum Schließen der Verbindung aktiviert, die Verbindung jedoch bereits vor dem Senden einer E-Mail hergestellt wurde (der Computer war bereits verbunden), wird die Verbindung NICHT geschlossen.

Der Benutzer kann den E-Mail-Typ auswählen. Dies kann ein vollständiger HTML-Bericht sein (einschließlich Bilder, aber immer noch kleiner 50 KB pro Festplatte), ein Volltextbericht (nur Klartext) oder ein Kurztextbericht. Letzterer ist sehr klein und schnell - nützlich, wenn die Nachricht per E-Mail -> SMS-Gateway zugestellt werden soll. Hinweis: Der ausgewählte Berichtstyp wird als tägliche Status-E-Mail gesendet. Außerdem wird der ausgewählte Berichtstyp (HTML oder Text) gespeichert oder gesendet, wenn der Benutzer im Hauptfenster auf den entsprechenden Button klickt.

Es ist möglich, die Elemente so zu konfigurieren, dass sie in den detaillierten Text oder HTML-Bericht aufgenommen werden (wenn die registrierte Version verwendet wird). Hinweis: Unabhängig von den konfigurierten Elementen enthält der XML-Bericht alle Abschnitte.

Nachricht an Remotecomputer senden: Die Warnung kann an jeden Computer im Netzwerk gesendet werden (genau wie bei der Verwendung des Befehls NET SEND). Um solche Nachrichten zu senden und zu empfangen, muss der Messenger-Service sowohl auf dem Absender- als auch auf dem Empfängercomputer ausgeführt werden. Mit der Schaltfläche Auswählen können Sie den Empfängercomputer aus dem lokalen Netzwerk auswählen. Dies kann in größeren Netzwerken langsam sein und es geht eventuell schneller, den Computernamen direkt anzugeben (ohne \\Präfix). Es ist möglich, eine Testnachricht an den Remote-Computer zu senden, um die Verbindung zu überprüfen.

Wichtig: Kann auf den Remote-PC nicht zugegriffen werden (er reagiert etwa nicht aufgrund eines Netzwerkfehlers oder eines Stromausfalls), sendet Hard Disk Sentinel die Nachrichten automatisch alle 5 Minuten bis zur erfolgreichen Zustellung erneut (während der aktuellen Sitzung). Wenn der Benutzer die Anwendung neu startet, wird dieser erneute Sende-Vorgang abgebrochen.

Hinweis: Der Messenger-Service unterstützt nur kleine Nachrichten (bis zu 254 Zeichen). Normalerweise kann der Empfänger (in den meisten Fällen der Administrator) anhand dieser Informationen nur die Problembeschreibung und den Absender-Computer lesen. In solchen Fällen sollte der Administrator den Absender-Computer auf Probleme untersuchen. Es wird empfohlen, zuallererst die Datei HDS_problem_log.txt im Ordner von Hard Disk Sentinel zu überprüfen, da sie Informationen zu früheren Warnungen enthält. Womöglich werden einige (nicht standardmäßige ASCII-) Zeichen in der zugestellten Nachricht falsch angezeigt.

Nachricht auf dem Bildschirm anzeigen: Mit dieser Option wird die Nachricht auf dem Bildschirm angezeigt. Optional kann vor der Problembeschreibung eine benutzerdefinierte Meldung ausgegeben werden. Hard Disk Sentinel liest diese benutzerdefinierte Nachricht aus einer Textdatei, bevor die Warnung angezeigt wird. Es wird auf Computern empfohlen, die nicht mit dem Netzwerk verbunden sind und denen die Remote-Sendemethoden nicht möglich sind. Eine benutzerdefinierte Nachricht kann beispielsweise "Bitte rufen Sie den Administrator über das Telefon XX-XXXXX-XXX an und teilen Sie ihm folgende Informationen mit:".

Zur Windows-Ereignisanzeige hinzufügen: Die dort in Windows-Protokolle > Anwendung hinzugefügte Warnung. Dies kann Administratoren/Tools beim Abrufen der Windows-Ereignisanzeige helfen, Benachrichtigungen über Warnungen und Probleme zu erhalten (nur registrierte Version).

Externe Anwendung oder Batch-Datei ausführen: Bei einer Warnung wurde eine extern konfigurierte Anwendung (oder BAT-Datei) gestartet. Es ist möglich, auszuwählen (oder die Befehlszeile manuell anzugeben) und auszuwählen, ob die externe Anwendung "unsichtbar" ausgeführt werden soll, ohne das Fenster anzuzeigen (nur registrierte Version).

In der externen Anwendung (oder BAT-Datei) stehen die folgenden Umgebungsvariablen zur Verfügung, die von Hard Disk Sentinel voreingestellt wurden:
& nbsp; & nbsp; HDS_TimeStamp: Datum und Uhrzeit der tatsächlichen Warnung im festen Format yyyymmdd hhmmss
& nbsp; & nbsp; HDS_TimeStampClean: Datum und Uhrzeit der Warnung im benutzerfreundlichen Format (aktuelle regionale Windows-Einstellung)
& nbsp; & nbsp; HDS_Host: aktueller Hostname (Computer)
& nbsp; & nbsp; HDS_Alert: die Warnung (z. B. bei Überhitzung)
& nbsp; & nbsp; HDS_Disk: betroffene Festplatte(n)
& nbsp; & nbsp; HDS_Threshold: konfigurierter Schwellenwert (enthält Celsius/Fahrenheit oder %-Symbole)
& nbsp; & nbsp; HDS_ThresholdValue: konfigurierter Schwellenwert (nur die Zahl)
& nbsp; & nbsp; HDS_Health: allgemeine Integritätsinformationen aller Laufwerke
& nbsp; & nbsp; HDS_Partition: allgemeine Partitionsinformationen aller Laufwerke
& nbsp; & nbsp; HDS_LowestDiskHealth: niedrigster Integritätswert aller Laufwerke in %

Hinweis: Die tägliche Status-E-Mail kann nur E-Mail sein, unabhängig vom auf dieser Seite ausgewählten Nachrichtentyp.


Konfiguration: E-Mail-Konfiguration

Auf dieser Seite kann der Benutzer die Einstellungen konfigurieren, die zum Zustellen einer E-Mail-Nachricht notwendig sind. Die erforderlichen Einstellungen sind:

  • Absendername: Später als Absender angezeigt (z. B. Name des Benutzers des Computers)

  • Absender-E-Mail: E-Mail-Adresse des Absenders (z. B. E-Mail-Adresse des Benutzers des PCs)

  • SMTP-Server: Name oder IP-Adresse des zu verwendenden SMTP-Servers

  • Empfänger-E-Mail: E-Mail-Adresse des Empfängers, der die Problem-/Status-E-Mails liest (z. B. der Administrator). Es können zwei oder mehr durch Komma (,) getrennte Adressen eingegeben werden.

  • Port: Wenn der SMTP-Server den Standardport (25) nicht verwendet, kann dies hier angegeben werden.

  • Benutzername, Passwort: Wenn beim Senden einer E-Amil eine Authentifizierung erforderlich ist (dies ist bei vielen Internetdienstanbieter nötig), können diese Informationen hier konfiguriert werden. Ist keine Authentifizierung notwendig, lassen Sie diese Felder leer. Es ist möglich, die Verwendung von SSL und TLS (STARTTLS) zu aktivieren, falls für die Verbindung notwendig. Für die Konfiguration des Versendens von E-Mails über ein "Google Mail"-Konto wird Port 465 oder 587 mit der Option "SSL verwenden" angefordert.

Im Feld E-Mail-Konto können Sie ein zuvor konfiguriertes Outlook- oder Outlook Express-E-Mail-Konto (falls vorhanden) auswählen. Ist ein Konto ausgewählt, werden der Absendername, die E-Mail-Adresse, der SMTP-Server und die Felder Benutzername (falls nötig) in Bezug auf die Einstellungen des E-Mail-Kontos automatisch ausgefüllt. Auf diese Weise wird nur die E-Mail-Adresse des Empfängers benötigt - und das Passwort, wenn eine Authentifizierung benötigt wird (aus Sicherheitsgründen wird das Passwortfeld nicht automatisch ausgefüllt).

Hinweis: Möglicherweise werden nicht alle definierten E-Mail-Konten angezeigt.

Anmerkung: Nachdem Sie alle Optionen festgelegt haben, wird empfohlen, die Schaltfläche Mail-Test zu verwenden, um die Konfiguration zu prüfen oder mögliche Probleme bei der E-Mail-Zustellung aufzudecken.


Konfiguration: Registrierung

Nach dem Kauf einer registrierten Version wird der Registrierungsschlüssel automatisch an den Benutzer übermittelt. Auf dieser Programmseite kann der Registrierungsschlüssel eingegeben werden, um Hard Disk Sentinel zu registrieren und zu aktivieren. Dadurch werden alle Funktionen der Anwendung freigeschaltet. Hinweis: Eine Standardlizenz ist nur für die Standardversion von Hard Disk Sentinel verfügbar. Die PRO-Version kann nicht aktiviert werden. Der PRO-Registrierungsschlüssel kann auch nur mit der PRO-Version verwendet werden (die alle Funktionen der Standard-Version und vieles mehr enthält).

Der Benutzer sollte einen Benutzernamen auswählen und eingeben. Dies kann alles sein, wie etwa der tatsächliche Name, sein Spitzname, ein Firmenname usw. Dieser Name wird im Info-Dialog als registrierter Benutzer angezeigt. Der Name kann später jederzeit frei verändert werden, indem man den Registrierungsschlüssel erneut eingibt und auf eine Beliebige der Registrierungsschaltflächen klickt. Da die Anwendung bereits aktiviert ist, ist keine Netzwerkkommunikation oder Dateiübertragung notwendig.

Hard Disk Sentinel überprüft den Registrierungsschlüssel selbst und anschließend den Code auf dem Online-Registrierungsserver (dieser Vorgang wird als Aktivierung bezeichnet). Die Anwendung wird registriert und aktiviert, wenn der Code sowohl von der Anwendung selbst als auch vom Online-Server akzeptiert wird. Dies ist erforderlich, um die Verwendung von Hard Disk Sentinel durch Software-Piraten zu verhindern.

Ist der Computer mit dem Internet verbunden, wird empfohlen, die Online-Aktivierungsmethode zu verwenden. Klicken Sie dazu auf die Schaltfläche Online registrieren und aktivieren-, nachdem Sie den Benutzernamen und den (gültigen) Registrierungsschlüssel eingegeben haben. Die Aktivierung dauert nicht länger als einige Sekunden, auch wenn eine geringere Bandbreite verfügbar ist.

Ist die Online-Aktivierungsmethode nicht möglich, sollte die Option Registrierung und Aktivierung per E-Mail ausgewählt werden (nachdem der Benutzername und der (gültige) Registrierungsschlüssel eingegeben wurden). Auf diese Weise erstellt Hard Disk Sentinel eine Datei und der Benutzer muss diese Datei (von einem anderen Computer aus) per E-Mail mit dem 15-stelligen Registrierungsschlüssel an die Adresse info@hdsentinel.com senden. Wir schicken die aktivierte Schlüsseldatei zurück, die über "Aktivierte Schlüsseldatei laden" ausgewählt werden kann (oder kopiert sie in den Installationsordner von Hard Disk Sentinel und startet ihn neu), um die Software zu freizuschalten und alle registrierten Funktionen zu aktivieren.

Mit der Schaltfläche "Aktivierte Schlüsseldatei laden" kann eine zuvor empfangene aktivierte Schlüsseldatei (die zur vorherigen Installation gehört) nicht geladen werden, da dies nicht funktioniert. Die aktivierte Schlüsseldatei ist nur ein Teil der Lizenz, sodass die Software allein nicht aktiviert wird. Wenn Sie die aktuelle Lizenz (und Einstellungen, Statistiken, Protokolle, Details) für eine geplante Neuinstallation sichern möchten, verwenden Sie bitte Konfiguration -> Aktualisieren -> Konfiguration sichern, um alles in einer einzigen Datei zu speichern (die nach vollständiger Neuinstallation erneut geladen werden kann).

Hinweis: Wenn Ihr Registrierungsschlüssel nicht von unserem Unternehmen bereitgestellt wird (weil ungültig) und die Online-Aktivierung zu einem Fehler führt, versuchen Sie bitte nicht die E-Mail-Aktivierungsmethode. Registrierungsanfragen mit falschem Schlüssel (oder überhaupt ohne einen solchen) werden automatisch gelöscht.

Anmerkung: Muss der Benutzer das Betriebssystem neu installieren, kann Hard Disk Sentinel so oft neu installiert und aktiviert werden, wie der Benutzer möchte, wenn die zuerst installierte Festplatte in allen Fällen dieselbe ist. Muss diese (erste) Festplatte ausgetauscht werden, wird die Anzahl der legal zulässigen Reaktivierungen um eins verringert. Für diese (neue) Festplatte kann der Benutzer dann so oft neu installieren und aktivieren, wie er möchte. Hard Disk Sentinel kann an 5 (fünf) verschiedene primäre Festplatten angeschlossen werden (sollten Sie Ihre erste Festplatte durch eine sechste ersetzen müssen, kontaktieren Sie uns bitte, um Ihre Lizenz zu verlängern). Die zweite, dritte oder weitere Festplatte oder andere Komponenten haben keinen Einfluss auf den Registrierungsstatus der Anwendung. Der Benutzer kann jede zweite oder weitere Festplatte frei hinzufügen, entfernen, ersetzen.

Wenn zwei oder mehr Betriebssysteme auf demselben Computer installiert sind, kann Hard Disk Sentinel unter all diesen Systemen installiert, registriert und aktiviert werden.

Hinweis: Bei Verwenden der CORPORATE-Version wird diese Konfigurationsseite unbrauchbar. Es ist nicht möglich, den Benutzernamen zu ändern oder auf die Schaltfläche "Registrierung und Aktivierung per E-Mail" zu klicken, da die Anwendung nach Abschluss der Installation bereits registriert und aktiviert ist.

Droht die installierte Lizenz abzulaufen, wird in diesem Fenster das Ablaufdatum angezeigt. Bitte kontaktieren Sie den Entwickler, um Ihre abgelaufene Lizenz zu verlängern.


Konfiguration: Aktualisierung

Hard Disk Sentinel kann sich über den Online-Server selbst aktualisieren, wenn eine aktuellere Version zum Download verfügbar ist. Der Benutzer kann das automatische (wöchentliche) Update verwenden. Über die Schaltfläche Jetzt auf neue Version prüfen können Sie nachsehen, ob eine neuere Version zur Verfügung steht und diese automatisch herunterladen. Das Datum wird angezeigt, an dem die Anwendung zuletzt nach einer neuen Version gesucht hat.

Während der Aktualisierung (nach Überprüfung auf eine neue Version) wird die Anwendung geschlossen. Das Trayicon, das Statusfenster und alle anderen geöffneten Fenster werden geschlossen, während das Update-Modul die neueste Version herunterlädt:

Der Updater überprüft auf neuere Version

Hinweis: Bei der Registrierung und Aktivierung der PROFESSIONAL-Version wird dieses Modul ausgeführt, um das Archivierungsmodul herunterzuladen. Später wird dieses Modul ebenfalls aktualisiert, da die Anwendung bereits registriert ist.

Anmerkung: Nach dem erfolgreichen Update wird die neue Version gestartet. Die Liste der zuvor behandelten Warnungen wird gelöscht, sodass konfigurierte Warnungen in manchen Fällen erneut gesendet werden.

Hinweis: Das Update-Modul lädt nur die neuesten, finalen (Nicht-Beta-) Versionen herunter. Die Evaluierungsversionen (Beta) sollten manuell heruntergeladen und installiert werden.

Anmerkung: Registrierte Nutzer können frei auf neuere Versionen aktualisieren, da die Anwendung nach dem Aktualisierungsvorgang registriert bleibt (sofern ein gültiger Registrierungsschlüssel zur Freischaltung verwendet wird).

Es ist möglich, die aktuelle Konfiguration zu sichern und wiederherzustellen. Das Backup speichert die aktuelle Konfiguration einschließlich aller Optionen und der Projektkonfiguration, die vorherigen Statistiken, Protokolle und Registrierungsdetails (registrierter Benutzer und Aktivierungsdatei). Auf diese Weise muss der Benutzer nach einer vollständigen Neuinstallation nur die vorherige Konfiguration wiederherstellen. Die Software wird automatisch registriert und alle vorherigen Einstellungen und Statistiken funktionieren wie zuvor. Es wird empfohlen, die Konfiguration und Statistiken regelmäßig auf Wechselmedien zu sichern, die im Falle einer vollständigen Neuinstallation verwendet werden können.

Hinweis: Wird die Hardwarekonfiguration geändert, muss die Software möglicherweise erneut aktiviert werden.

Anmerkung: Die Option Konfiguration sichern ist nur in der registrierten Version verfügbar.


Konfiguration: Erweiterte Optionen

Diese Optionen sollten nur von fortgeschrittenen, erfahrenen Nutzern geändert werden, da diese Optionen zu einem falschen oder ungeeigneten Systembetrieb führen können.

Erkennungsfrequenz: Die Zeit zwischen zwei aufeinanderfolgenden Erkennungen von Festplatteninformationen (Erkennen von S.M.A.R.T.-Informationen zur Anzeige von Temperatur, Zustand usw.). Standardmäßig identifiziert Hard Disk Sentinel solche Informationen alle 5 Minuten. Zu viele Festplatten oder langsame Geräte können die Leistung der Anwendung beeinträchtigen und die Antwortzeiten verlängern. In diesem Fall wird empfohlen, den Schieberegler nach rechts zu ziehen, es ist jedoch möglich, die Häufigkeit zu erhöhen. Hinweis: Sehr häufige Erkennungen (einmal alle 1 oder 5 Sekunden) können die Leistung oder Reaktionsfähigkeit der Software (die ständig auf Festplatten zugreifen und auf deren Antwort warten müsste) beeinträchtigen.

Generell überprüft Hard Disk Sentinel, ob sich das Laufwerk im Ruhezustand befindet, wenn die Erkennungsperiode ansteht. In diesem Fall wird das Laufwerk nicht nur zum Aktualisieren seines Status aktiviert. Einige Laufwerke (und Festplattencontroller, Treiber) liefern vielleicht einen falschen Stromversorgungsstatus. Dies bedeutet, dass die Software (auch wenn sie ihr Bestes gibt, den Zustand der Stromversorgung zu ermittelt) den Eindruck haben könnte, das Laufwerk sei aktiv (im Ruhezustand), und die Erkennung durchführt, was das Laufwerk aufweckt. Hierzu gibt es eine Option Automatische Erkennung basierend auf Laufwerksnutzung, die hilfreich sein kann: Ist diese Option aktiviert, überprüft Hard Disk Sentinel auch, ob seit der letzten Erkennung echte Festplattenaktivität auf dem Laufwerk stattgefunden hat, und führt den Festplattenzugriff nur in diesem Fall durch (andernfalls wird das Laufwerk als inaktiv/schlafend betrachtet).

Zustand Ermittlungsmethode: Der Nutzer kann die Methode zur Ermittlung der Zustands- und der Leistungswerte für die Festplatten auswählen. Es wird empfohlen, die Option "Datenfeld analysieren" oder die strengere Analyseoption zu verwenden, um die Datensicherheit zu verbessern. Die strenge Methode wird auf Servern, Notebooks oder Computern mit hoher Festplattenauslastung oder äußerst wichtigen Informationen empfohlen.

Warnung aktivieren, wenn Festplatte nicht reagiert: Wenn die Festplatte nicht auf die Erkennung von Hard Disk Sentinel reagiert, wird ein Protokolleintrag generiert (der bei Aktivierung zu einer Warnung führen kann). Auf der Seite mit den Laufwerksinformationen wird ein gelbes und dann ein rotes Etikett mit zusammen dem Problem angezeigt. Die Verwendung dieser Option wird nicht in allen Fällen empfohlen, nur wenn dies wirklich erforderlich ist (z. B. unter Windows 98/ME).

Automatisches Scandisk beim Start von Windows deaktivieren: Mit dieser Option können Sie die automatische Datenträgerprüfung deaktivieren, die möglicherweise mit Windows startet. Dies kann verhindern, dass ein schadhafter Kopf falsch auf die stabilen Plattenbereiche zugreift und diese beschädigt.

Verzögerung vor Start von Scandisk (Sek.): Ist die automatische Festplattenprüfung aktiviert, kann eingestellt werden, wie viele Sekunden das System warten soll, bevor dieser Prozess beginnt. Während dieser Zeit kann der Benutzer die Festplattenprüfung durch Drücken einer beliebigen Taste abbrechen.

Rechneruhr mit Atomuhr synchronisieren: Die Uhr des Computers wird mit einem Remote-Zeitserver mittels NTP (Network Time Protocol) synchronisiert, um das korrekte Datum und die richtige Uhrzeit anzuzeigen. Dies ist nützlich, wenn Sie das Datum und die exakte Uhrzeit von Warnungen ermitteln möchten. Diese Option kann auf älteren Systemen (Windows XP und frühere Versionen) hilfreich sein, insbesondere wenn die PROFESSIONAL-Version installiert und konfiguriert ist, um geplante Sicherungsprojekte zu starten. Hinweis: Wird die nicht registrierte Version verwendet, wird diese Option nach der ersten Synchronisierung der Uhr automatisch deaktiviert.

XML-Datei erzeugen und aktualisieren: Wenn diese Option aktiviert ist, werden die Festplattendetails automatisch in eine spezielle XML-Datei exportiert, die von anderer Software verarbeitet werden kann. Standardmäßig wird die Datei HDSentinel.xml verwendet, dies kann jedoch geändert werden, wenn die Schaltfläche Auswählen gedrückt wird. Die letzte am Vortag gespeicherte XML-Datei wird als Sicherungskopie mit der Erweiterung .BAK gespeichert. Weitere Informationen zum Beispielskript finden Sie unter: How to: integrate Hard Disk Sentinel by automatic XML report export. Hinweis: Diese Funktion kann nur in der registrierten Version verwendet werden.

Status über WMI bereitstellen: Wenn aktiviert, können Anwendungen/Skripte von Drittanbietern auf Status und Details des Laufwerks (von Hard Disk Sentinel erkannt) zugreifen. Auf diese Weise können Entwickler, Administratoren und Systemintegratoren benutzerdefinierte Tools erstellen, um erkannte Details zu protokollieren, zu melden und auszugeben. Weitere Informationen zum Beispielskript finden Sie unter: How to: query disk information by WMI from Hard Disk Sentinel. Hinweis: Diese Funktion kann nur in der registrierten Version verwendet werden.

Ergebnisse der Laufwerkstests automatisch in Ordner speichern Ermöglicht, die Ergebnisse nach Abschluss aller Tests (einschließlich des Kurzen/Erweiterten/Transport-Tests und aller Laufwerkoberflächentests über den Menüpunkt Laufwerk -> Oberflächentest) automatisch zu sichern. Nach Abschluss der Tests werden die Ergebnisse und Details automatisch im angegebenen Ordner gespeichert, einschließlich:
- einer Schnellprotokolldatei (selftestlog.txt), die Datum/Uhrzeit des Tests, den Typ, die Dauer und die Ergebnisse für alle Hardware-Selbsttests enthält. (Menü Laufwerk-> Kurzer Selbsttest, Erweiterter Selbsttest)
- Vollständiger Laufwerksbericht über die betroffene Festplatte nach Abschluss des Kurzen/Erweiterten Tests
- Vollständige Details (Abbilder der Festplattenoberflächenkarte, Exporte der Übertragungsgeschwindigkeit, Fehlerprotokolle), wenn einer der Oberflächentests (Menü Laufwerk -> Oberflächentest) abgeschlossen ist.

Überwachung von Laufwerk- und Datenspeicher-Problemen im Windows Ereignisprotokoll: Durch diese Funktion erkennt Hard Disk Sentinel während der Ausführung, ob ein Problem mit dem Speichersubsystem vorliegt, das vom Festplatten-Controllertreiber oder von Windows selbst gemeldet wird (unabhängig vom Selbstüberwachungsstatus des Laufwerks). Dies schließt Probleme ein, die direkt mit dem Festplattenlaufwerk zusammenhängen (z. B. fehlerhafte Sektoren) - aber auch mit etwas anderem (Kabel, Verbindungen). Dies kann zum Bus-Reset, Wiederholungsversuchen, Kommunikationsproblemen oder anderen Problemen führen. Solcherlei Probleme wurden im Gesundheitszustand und in der Textausgabe gemeldet, zum Beispiel:
Kürzlich wurden folgende Einträge dem System-Ereignisprotokoll hinzugefügt:
56 Warnungen, zuletzt: Die I/O-Operation an der logischen Blockadresse 8fa0 für Datenträger 9 (PDO Name: \Device\0000009d) wurde wiederholt. (Datenträger; ID: 153)
Die folgende Funktion kann verwendet werden, um die Situation zu verbessern: Laufwerk -> Oberflächentest -> Laufwerksreparatur

Ablageordner zum Speichern von Statistiken und Einstellungen ändern: Mit dieser Option können Sie Hard Disk Sentinel so konfigurieren, dass alle Informationen (Statistiken, Einstellungen, Protokolle, Details, Lizenzen) in einem anderen Ordner (oder sogar auf einem anderen Laufwerk) gespeichert werden, anstatt dessen lokalen Ordner zu verwenden. Es ist möglich, auch Remote- oder Netzlaufwerke zu konfigurieren. Seien Sie jedoch vorsichtig: Wenn beim Start nicht auf den entsprechenden Ordner (Laufwerk) zugegriffen werden kann, ist Hard Disk Sentinel vielleicht nicht in der Lage, die Lizenz und die vorherigen Einstellungen/Konfigurationen zu laden, sodass er womöglich nicht wie erwartet funktioniert.


Konfiguration: Laufwerkssteuerung

Hard Disk Sentinel überprüft kontinuierlich den verwendeten und freien Speicherplatz der logischen Laufwerke (Partitionen). Mithilfe dieser Informationen kann die Menge des genutzten Speicherplatzes auf den Laufwerkssymbolen dargestellt werden. Darüber hinaus erscheint auf diesen Symbolen ein Zeichen, das dem aktuellen Zustand der Festplatte entspricht.

Standard-Festplattensymbole ändern: Mit dieser Option können Sie die Verwendung der erweiterten Festplattensymbole global aktivieren/deaktivieren. Ist die Option deaktiviert, werden die ursprünglichen Windows-Laufwerkssymbole verwendet. Wenn aktiviert, werden die erweiterten Symbole angewandt: Die Menge des genutzten Speicherplatzes und dessen Integrität sind auf den Symbolen zu sehen. Diese Symbole werden in allen Anwendungen einschließlich des Windows-Explorers gezeigt.

Speicherplatz auf Netzlaufwerken überwachen: Es ist auch möglich, die Informationen zum freien Speicherplatz auf Remote-Festplatten zu überprüfen und diese Informationen im Bereich des logischen Laufwerks des Hauptfensters automatisch zu aktualisieren.

Standard-Systemsymbol für Netzlaufwerke ändern: Nach der Erkennung gibt das Symbol der (Remote-) Netzlaufwerke die Menge des verwendeten Speicherplatzes wieder.

Speicherplatz auf Netzlaufwerken überwachen: Es ist auch möglich, die Informationen zum freien Speicherplatz auf Remote-Festplatten zu überprüfen und diese Informationen im Bereich des Hauptfensters des logischen Laufwerks automatisch zu aktualisieren.

Standard-Systemsymbol für Wechseldatenträger ändern: Nach der Erkennung gibt das Symbol der Wechseldatenträger den verwendeten Speicherplatz wieder.

Hinweis: Auf Netzlaufwerken und den meisten Wechseldatenträgern ist es nicht möglich, S.M.A.R.T.-Informationen zu erkennen. Somit repräsentiert das Symbol nur Informationen zu genutztem/freiem Speicherplatz, jedoch nicht zum Gesundheitszustand.

Anmerkung: Das Überprüfen des Speicherplatzes auf Netz- und Wechseldatenträgern kann langsam sein (insbesondere wenn auf ein Netzlaufwerk nicht zugegriffen werden kann oder wenn in einen Kartenleser keine Karte eingesteckt ist). Es wird empfohlen, diese Optionen nur dann zu verwenden, wenn sie die Leistung des Systems und der Anwendung nicht beeinträchtigen.

Es kann festgelegt werden, welche Laufwerke von der Speicherplatzprüfung ausgeschlossen werden sollen und welche das Standard-Festplattensymbol beibehalten sollen. Bitte geben Sie die Laufwerksbuchstaben (ohne Doppelpunkt (:) oder Leerzeichen) in das entsprechende Feld ein.

Hinweis: Hard Disk Sentinel kann die Symbole nur erkennen und ändern, während er ausgeführt wird. Wenn die Anwendung geschlossen wird, werden die vorherigen Laufwerkssymbole angezeigt (die ursprünglichen Systemsymbole oder geänderte Symbole, wenn sie von einer Anwendung eines Drittanbieters geändert wurden).

Noch ein Hinweis: Einige Betriebssysteme (z. B. Windows XP SP1) könnten vielleicht nicht die korrekten Symbole anzeigen. Bitte aktualisieren Sie auf das neueste Service Pack, wenn dieses Problem auftritt.

Mit der Option Laufwerk-Symbolsatz wird der Stil der Festplattensymbole (XP- oder Vista/7-Stil) angegeben, die im Windows Explorer und in anderen Anwendungen benutzt werden sollen, die solche Symbole anzeigen. Diese Symbole geben den Status des Festplattenzustands und den verwendeten Speicherplatz wieder.
Ab Version 4.10 können externe Symbolbildpakete (.HDZ-Dateien) geladen und genutzt, sowie weitere Informationen zum Symbolpaket (Informationen des Symbolpakets des Herausgebers anzeigen), ein Beispielbild mit den möglichen Symbolen angesehen werden.

Erkennung von USB- und SCSI-Laufwerken deaktivieren: Diese Option ist nur für Kompatibilitätsprobleme verfügbar, um die Erkennung erweiterter Informationen zu speziellen Geräten zu deaktivieren. Dies kann auch Festplatten/SSDs umfassen, die an RAID-Controllern angeschlossen und für RAID-Arrays konfiguriert sind, oder auch nur für Geräte, die von irgendwelchen Festplattencontrollern verwendet werden. In den meisten Fällen ist diese Option NICHT erforderlich, schon weil sie womöglich die Erkennung des Festplattenstatus verhindert. Sie ist möglicherweise nur bei einigen (insbesondere älteren) Kartenlesern nötig, da diese eventuell sehr langsam auf die Anwendung reagieren. Nutzen Sie in diesem Fall die Option Bericht -> Testbericht an Entwickler senden.


Konfiguration: Hotkeys

Es ist möglich, über Hotkeys auf einige Funktionen von Hard Disk Sentinel zuzugreifen. Dies sind systemweite Hotkeys, die auch dann funktionieren, wenn eine andere Anwendung ausgewählt und aktiviert ist (mit Ausnahme einiger Anwendungen, z. B. Spiele, kann die Verwendung von Hotkeys verhindert werden).

Die nützlichsten Funktionen für den Zugriff über Hotkeys sind das Ein- oder Ausblenden des Statusfensters, das Anzeigen des Hauptfensters oder des Konfigurationsfensters.

Die Hotkeys sind nur in der registrierten Version verfügbar.

Hinweis: Einige Tastenkombinationen funktionieren unter Umständen nicht unter allen Betriebssystemen. Beispielsweise kann Vista die Tastenkombinationen STRG+ALT+Fx blockieren.


Operationen

Hard Disk Sentinel PROFESSIONAL kann automatische (Sicherungs-) Operationen erstellen, planen und bei einem Fehler ausführen. Diese Funktion wird in den folgenden Kapiteln beschrieben:

  • Projekte

  • Zeitplan

  • Panik-Backup


Konfiguration: Operationen

Diese Funktionen sind nur in der PROFESSIONAL-Version verfügbar.

Mit der PRO-Version von Hard Disk Sentinel können verschiedene Aufgaben (Projekte) definiert und deren regelmäßige Ausführung geplant werden. Die definierten Projekte sind bei diversen Ereignissen ausführbar, z. B. bei einem niedrigen Wert für den Festplattenzustand. Möglich ist auch, zwei oder mehr verschiedene Projekte gleichzeitig oder nacheinander auszuführen (ein Projekt ausführen, nachdem das andere Projekt abgeschlossen ist). Bei den Projekten handelt es sich normalerweise um Datenarchivierungsvorgänge, es können jedoch auch andere Arten von Projekten festgelegt werden.

Zunächst ist ein kurzer, schlüssiger Name für das Sicherungsprojekt erforderlich (dieser kann später nicht mehr geändert werden). Durch Klick auf die Schaltfläche Neu kann der Benutzer diesen Namen eingeben und die Projektdetails erscheinen - die Felder sind jetzt leer.

Mit der Schaltfläche Entfernen kann das aktuell angezeigte Projekt aus der Liste der Projekte gelöscht werden, wenn es nicht mehr benötigt wird. Hinweis: Wenn das Projekt ein oder mehreren Daten oder Ereignissen zugeordnet war, muss der Benutzer den Entfernungsvorgang bestätigen. Bitte seien Sie vorsichtig beim Entfernen eines Projektes, mit dem andere Projekte in einer Sequenz verknüpft waren.

Der Benutzer kann einen beschreibenden Text über die tatsächliche Funktion des Projekts in das Feld Kommentar eingeben. Wenn das Projekt vor der Ausführung eine Bestätigungsfrage benötigt, werden dem Benutzer der Projektname und dieser Kommentar angezeigt. Dieser kann entscheiden, ob das Projekt ausgeführt werden oder abgebrochen werden soll.

Der Typ des Projekts kann sein:

  • Externe Anwendung oder Batch-Datei starten: Das Projekt startet die angegebene externe Anwendung, den internen Befehl (z. B. COPY) oder die Batch-Datei (BAT, CMD). Dies kann zum Beispiel dazu genutzt werden, um einige Ordner mit einer beliebigen Komprimierungssoftware zu packen und/oder Dateien mithilfe eines Befehlszeilen-CD/DVD-Brennprogramms auf ein optisches Laufwerk zu brennen. Es kann auch zum Start einer anderen Anwendung verwendet werden, beispielsweise um die Datenbank eines Antiviren-Programms zu aktualisieren. Dafür sollten alle Befehlszeilenparameter angegeben werden. Sie können die ausführbare Datei über die Schaltfläche Durchsuchen auswählen. Name und der Pfad des Programms müssen zwischen Anführungszeichen (") angegeben werden, wenn der Anwendungsname oder sein Pfad ein oder mehrere Leerzeichen enthält. Zusätzliche Parameter können nach dem letzten Anführungszeichen hinter dem Anwendungsnamen angegeben werden. Beispiel: "C:\Programme\MyProgOrdner\MyProg.exe" parameter1 parameter2

    Wenn der Benutzer auswählt, Unsichtbar, ohne Fenster anzuzeigen, starten, wird die Anwendung im unbeaufsichtigten Modus nicht sichtbar ausgeführt.

    Ist die Option Warnmeldung bei Fehler aktiviert, wird eine Warnung (gemäß den Meldungseinstellungen) generiert, wenn die externe Anwendung oder BAT-Datei beim Beenden einen anderen EXIT-Code als 0 zurückgibt. Hinweis: Bei Verwendung der BAT-Datei kann der EXIT-Code mit EXIT xx angegeben werden. Wenn die BAT-Datei Anweisungen wie if .. then enthält, können damit die richtigen EXIT-Codes an verschiedenen Stellen innerhalb des Codes angegeben werden. Der EXIT-Code 0 bedeutet eine korrekte (problemlose) Beendigung. Jeder andere Code gibt (wenn diese Option aktiviert ist) eine Warnung mit dem zurückgegebenen EXIT-Code aus. In diesem Fall werden keine anderen Projekte in Abhängigkeit von diesem problematischen Projekt gestartet.

  • Dateien und Ordner übertragen: In diesem Fall wird das interne Archivierungsmodul zum Sichern von Dateien verwendet. Mit diesem Modul ist es möglich, diverse Archivierungsoptionen zu konfigurieren und verschiedene spezifische Sicherungsaufgaben zu erstellen. Durch Klick auf die Schaltfläche Konfigurieren kann der Nutzer die Optionen des Sicherungsprojekts angeben. Hinweis: Diese Funktion ist nur in der registrierten Version verfügbar.

  • CD/DVD mit NERO brennen: Hard Disk Sentinel verwendet das Programm NERO(TM) der Ahead Software AG, um den Inhalt eines bestimmten Ordners auf einer optischen Festplatte zu archivieren.

    CD/DVD mit NERO brennen

    Dazu müssen Sie den Speicherort der Datei NEROCMD.EXE (die Befehlszeilenversion von NERO) mithilfe der Schaltfläche Anwendung wählen angeben. Ist dies nicht angegeben, aber ein Projekt konfiguriert, fordert Hard Disk Sentinel Sie auf, den Speicherort der fehlenden Anwendung zu konfigurieren.

    Die auszuführende Befehlszeile kann mit allen Parametern überprüft werden. Durch Drücken von STRG+C ist es möglich, den Inhalt dieses Fensters in die Zwischenablage zu kopieren.

    Einen Pfad zum Quellordner anzugeben ist unbedingt notwendig. Dieser kann Variablen enthalten (z.B.%USER%,%LAST% usw.). Die Details der Variablen werden in den Ordnereinstellungen beschrieben. Bei Verwendung von %LAST% wird der neueste Ordner (erstellt mit Datum und Uhrzeit iim Namen) aus dem angegebenen Ordner (in unserem Fall L:\BACKUP) als Quellordner verwendet. Dies sollte angewandt werden, wenn ein anderes Projekt zuvor Daten in L:\BACKUP gespeichert hat und Aktuelles Datum als Ordnernamen verwenden und behalte die letzten XX vollständigen Archive" für dieses Projekt aktiviert ist.

    Ebenso muss das Laufwerk des Brenners (falls zwei oder mehr optische Laufwerke im PC installiert sind) und die Schreibgeschwindigkeit ausgewählt werden. Letztere wird automatisch an die Eigenschaften des Brenners und des eingelegten Mediums angepasst. Außerdem sollte der Typ des Mediums (CD oder DVD) ausgewählt werden. Der Pufferunterlaufschutz (BURN) und das Verifizieren nach dem Schreiben können aktiviert oder deaktiviert werden.

    Auch die Angabe weiterer Befehlszeilenparameter ist möglich. Sie werden an NEROCMD.EXE gesendet. Ein solcher Parameter kann --disable_eject sein, womit das Auswerfen der Disk deaktiviert wird. Die vollständige Liste der Parameter kann mit dem Befehl NEROCMD /? ausgegeben werden.

    Man kann den Brennvorgang unbeaufsichtigt (ohne ein Fenster anzuzeigen) starten, und auch die Aktivierung der Fehlerbehandlung wie die Option für Projekte mit dem Typ Externe Anwendung oder Batch-Datei starten ist möglich. Die vollständige Liste der EXIT-Codes von NEROCMD finden Sie im NEROCMD-Benutzerhandbuch.

    Hinweis: Diese Funktion ist nur in der registrierten Version verfügbar.

  • Dateien mit RAR/7-Zip komprimieren: Hard Disk Sentinel kann die Anwendung WINRAR(TM) von RarSoft oder die kostenlose Anwendung 7-Zip als Packer verwenden. Die Liste der verfügbaren Optionen ist für beide Packer gleich. Hinweis: Ältere Versionen von 7-Zip unterstützen das Erstellen von Archiven mit mehreren Volumes nicht.

    Dateiarchive (packen)

    Sie müssen den Speicherort der Datei RAR.EXE oder 7Z.EXE (die Befehlszeilen-Packprogramme) mithilfe der Schaltfläche Anwendung wählen angeben. Wird dieser nicht angegeben, aber ein Projekt ist konfiguriert, fordert Hard Disk Sentinel Sie auf, den Speicherort der fehlenden Anwendung zu konfigurieren.

    Die auszuführende Befehlszeile kann inklusive aller Parameter überprüft werden. Durch Drücken von STRG+C ist es möglich, den Inhalt dieses Fensters in die Zwischenablage zu kopieren.

    Um das Archiv zu komprimieren, muss der Quellordner angegeben werden. Es können Variablen enthalten sein (z.B.%USER%,%LAST%, die Details der Variablen sind in den Ordnereinstellungen beschrieben).

    Zudem ist eine Zieldatei anzugeben, um das komprimierte Archiv zu speichern. Es besteht die Möglichkeit, Archive mit mehreren Volumes zu erstellen und die Volume-Größe in KByte (1024 Byte) zu konfigurieren.

    Alle anderen Befehlszeilenparameter, die beim Starten der RAR- oder 7Z-Anwendung verwendet werden sollen, können eingegeben werden. Solche Parameter können sein: -mXXX, um die Komprimierungsmethode anzugeben, -pXXX, um ein Kennwort festzulegen, oder -sfx, um ein selbstentpackendes Archiv zu erstellen. Die vollständige Liste der Parameter kann mit dem Befehl WINRAR /? oder 7Z (ohne Parameter) angezeigt werden.

    Der Komprimierungsprozess kann unbeaufsichtigt (ohne ein Fenster anzuzeigen) gestartet werden, und die Aktivierung der Fehlerbehandlung wie bei der Option für Projekte mit dem Typ Externe Anwendung oder Batch-Datei starten ist möglich. Die vollständige Liste der möglichen EXIT-Codes der Anwendung finden Sie im WINRAR- oder 7-Zip-Benutzerhandbuch.

    Hinweis: Diese Funktion ist nur in der registrierten Version verfügbar.

  • Registry-Einträge exportieren: Die angegebenen Registry-Schlüssel werden in eine Datei exportiert (der Dateiname kann auch Variablen enthalten).

    Registry-Einträge exportieren

    Hinweis: Diese Funktion ist nur in der registrierten Version verfügbar.

  • Rechner einschalten: Schalten Sie einen Remote-Rechner im lokalen Netzwerk ein (starten Sie ihn), indem Sie ein Wake-Paket an den Zielrechner senden. Es ist erforderlich, die MAC-Adresse des Zielrechners anzugeben (diese kann beispielsweise aus einem Bericht von Hard Disk Sentinel auf dem Zielrechner ermittelt werden). Im Optionalfall kann die Software warten, bis der PC bereit ist (auf PING antwortet), aber nicht länger als eine festgelegte maximale Zeit wartet. Es wird empfohlen, die Firewall, den Computer (Wake-on-LAN sollte aktiviert sein) und die Netzwerkkonfiguration zu überprüfen.

    Remote-Rechner im Netzwerk einschalten

    Hinweis: Diese Funktion ist nur in der registrierten Version verfügbar.

  • Rechner ausschalten: Der lokale oder Remote-Computer kann gestoppt (heruntergefahren) oder neu gestartet werden. Zudem kann der lokale Rechner auch in den Standby oder Ruhezustand versetzt werden.

    Remote-Computer im Netzwerk ausschalten

    Hinweis: Diese Funktion ist nur in der registrierten Version verfügbar.

  • Dateien per E-Mail verschicken: Mit dieser Funktion können Dateien (oder vollständige Ordner mit allen Dateien und Unterordnern) per E-Mail übertragen werden. Nach Auswahl des richtigen Typs (Dateien oder Ordner) sollten die Dateien/Ordner angegeben und durch ein Semikolon (;) getrennt werden. Zum Senden von Mails werden Absender-, Mailserver- und Authentifizierungsoptionen auf der Seite E-Mail-Konfiguration verwendet.

    Senden von Dateien per E-Mail

    Es ist möglich, alle Dateien in separaten E-Mails zu senden (Senden einer Datei pro E-Mail). Diese Option ist ideal, um einzelne Dateien (Archive) zu senden, die nicht zu groß sind, um in E-Mails übertragen zu werden. Bei vielen kleineren Dateien ist es möglich, Dateien zu sammeln, bis ein Mindestlimit erreicht ist, und die Dateien zusammen in einer E-Mail zu versenden. Auf diese Weise enthalten alle E-Mails beispielsweise 2.000 KB an Daten, mit Ausnahme der letzten, die die verbleibenden Dateien enthält. Bevor Sie diese Option verwenden, wird empfohlen, die Datenmenge und den verfügbaren E-Mail-Speicherplatz auf dem Mailserver (oder den vom Netzwerkdienstanbieter bereitgestellten) zu überprüfen..

    Hinweis: Diese Funktion ist nur in der registrierten Version verfügbar.

  • FTP-Transfer der Dateien: Mit dieser Option können Dateien oder komplette Ordner auf den FTP-Server hochgeladen werden. Nach Auswahl des richtigen Typs (Dateien oder Ordner) sollten die Dateien/Ordner angegeben und durch ein Semikolon (;) getrennt werden.

    Dateien auf FTP-Server hochladen

    Zum Übertragen der Dateien sind der (Remote-) FTP-Servername oder dessen IP-Adresse, der Benutzername und das Passwort für die Anmeldung erforderlich. Optional können auch der Übertragungs-Port (Standard = 21, Standard-FTP-Port), die Option für den passiven Modus und der Remote-Ordner angegeben werden. Die Schaltfläche Konfigurieren öffnet ein Fenster mit weiteren Optionen zur Steuerung der Übertragung, einschließlich der unterstützten Archivierungsoptionen sowie des FTP-Time-outs und der maximalen Anzahl von Wiederholungsversuchen.

    Hinweis: Die Option "Aktuelles Datum als Ordnernamen verwenden und behalte die letzten XX vollständigen Archive" kann für die FTP-Übertragung verwendet werden. Fortsetzen (REST) wird nicht unterstützt.

    Hinweis: Diese Funktion ist nur in der registrierten Version verfügbar.

  • Festplatten testen: Die Festplatten können mithilfe von Hardware-Selbsttest-Funktionen untersucht und getestet werden (unterstützt von IDE- und S-ATA-Festplatten). Die zu testenden Festplatten werden aufgelistet und können ausgewählt werden, oder man kann alle installierten Festplatten gleichzeitig testen.

    Wird die Maus über eine Festplatte bewegt, werden die unterstützten Tests in einem Hinweis angezeigt. Bitte wählen Sie den Testtyp aus den unterstützten Tests aus.

    Zudem kann nach Abschluss des Tests ein Bericht gesendet werden (immer oder nur dann, wenn ein Fehler aufgetreten ist). Der Bericht enthält die Details des Tests, einschließlich aller neu gefundenen Probleme (z. B. neue fehlerhafte Sektoren).

    Hinweis: Diese Funktion ist nur in der registrierten Version verfügbar.

Hinweis: Die folgenden Versionen haben möglicherweise mehrere unterschiedliche Projekttypen.

Mit der Schaltfläche Jetzt starten können Sie das Projekt sofort ausführen. Verwenden Sie immer die Schaltfläche Speichern, bevor Sie auf diese Schaltfläche klicken, um zuvor geänderte Optionen für das Projekt zu speichern.

Mit der Schaltfläche Verknüpfung für Projekt auf dem Desktop erstellen erzeugt Hard Disk Sentinel für das aktuell ausgewählte Projekt eine Verknüpfung auf dem Desktop. Die Verknüpfung kann verwendet werden, um das zugehörige Projekt zu starten (auch wenn Hard Disk Sentinel nicht aktiv ist). Hinweis: Wenn das Projekt -Variablen enthält, werden die Variablen zum Zeitpunkt der Erstellung der Verknüpfung ausgewertet. Es wird daher empfohlen, keine Variablen in Projekten zu verwenden, die manuell ausgeführt werden sollen, nutzen Sie stattdessen nur konstante Variablen (z.B.%COMPUTER%). Hinweis: Diese Funktion ist nur in der registrierten Version verfügbar.

Die Schaltfläche Speichern sollte zum Speichern der geänderten Konfiguration verwendet werden. Dadurch werden die aktuelle Liste der Projekte, die Liste der definierten Zeitpläne und die Liste der definierten Ereignisse gespeichert. Es wird empfohlen, diese Schaltfläche häufig zu verwenden, da einige Optionen nur verfügbar sind, wenn die Sicherungskonfiguration gespeichert wurde. Mit der Schaltfläche Standardprojekte wiederherstellen können Sie die zuvor gespeicherte Sicherungskonfiguration neu laden. Dies könnte hilfreich sein, ein versehentliches Löschen oder Ändern rückgängig zu machen.

Nachdem die Sicherungsprojekte definiert wurden, sollten sie an verschiedenen Tagen auf der Seite Zeitplan oder mit unterschiedlichen Ereignissen zu verschiedenen Zeiten verbunden sein. Ein solches Ereignis kann das Panik-Backup sein. Es wird ausgeführt, falls bei einem Problem mit einer Festplatte auftritt und die Option zum Starten des Panik-Backups für dieses Problem auf der Seite Warnungen aktiviert ist.


Konfiguration: Operationen, Zeitplan

Diese Funktionen sind nur in der PROFESSIONAL-Version verfügbar.

Zeitplan von Projekten

Für jeden Wochentag kann eine andere Projektliste definiert werden. Im Auswahlmenü neben Starten am kann der Benutzer den Wochentag auswählen, um die definierten Projekte zu untersuchen und die Konfiguration hinzuzufügen/zu überprüfen.

Mit der Option Am nächsten Wochentag aussetzen können alle Projekte am auf der Auswahl folgenden Wochentag deaktiviert werden. Ist beispielsweise Dienstag der aktuell ausgewählte und angezeigte Tag und diese Option aktiviert, werden die für Dienstag geplanten Projekte am nächsten Dienstag nicht ausgeführt. Auf diese Weise ist es möglich, die Projekte für einen geplanten Service vorübergehend zu deaktivieren. Nach Ablauf des Tages (z. B. nach dem nächsten Dienstag) wird die Anwendung automatisch im normalen Modus wiederhergestellt und alle Projekte werden wie zuvor ausgeführt. Auf diese Weise muss sich der Administrator nicht um das manuelle Deaktivieren und anschließende erneute Aktivieren der Projekte nach Abschluss des Dienstes kümmern.

Das rote X unter Löschen kann verwendet werden, um das entsprechende Projekt aus der Liste zu entfernen. Natürlich wird das Projekt selbst nicht gelöscht, es kann jederzeit wieder ausgewählt werden, um es einer Projektliste hinzuzufügen. Dann wird (von links nach rechts) die Projektnummer angezeigt. Dies ist nur dann wichtig, wenn der Benutzer eine Projektkette erstellen möchte (Projekte sequenziell nacheinander ausführen).

Unter Projekt wird der Name des Projekts angezeigt. Der Benutzer kann das auszuführende Projekt aus der Liste der zuvor erstellten Projekte auswählen.

In der Spalte Start kann festgelegt werden, wann das Projekt ausgeführt werden soll. Die möglichen Optionen sind:

  • Feste Zeit: Das Projekt wird zu der in der Spalte Zeit angegebenen Zeitpunkt (Stunde: Minute) ausgeführt. Konnte das Projekt zum konfigurierten Zeitpunkt nicht ausgeführt werden (z B. ist das System aufgrund eines Stromversorgungsproblems nicht bereit), wird das Projekt wenn möglich zu einem späteren (nächstbesten verfügbaren) Zeitpunkt ausgeführt. Dies kann durch die Option Geht auch später gesteuert werden. Dies wird für die Durchführung fester, länger geplanter Projekte empfohlen (z. B. vollständige Sicherung während der Nacht).

  • Nach Start: Startet das Projekt, nachdem Hard Disk Sentinel gestartet wurde und eine vordefinierte Verzögerung verstrichen ist. Die Verzögerung kann in der Spalte Zeit (Stunde: Minute) konfiguriert werden. Das Projekt wird nach jedem Neustart von Hard Disk Sentinel ausgeführt. Sollte das System regelmäßig neu gestartet werden müssen, kann es mehrmals pro Tag ausgeführt werden. Empfohlen für schnelle Sicherungen (z. B. Speichern neuer oder geänderter Dokumente, Bilder).

  • 1/Tag nach Start: Startet das Projekt, nachdem Hard Disk Sentinel ausgeführt wurde und eine vordefinierte Verzögerung ist verstrichen. Die Verzögerung kann in der Spalte Zeit (Stunde: Minute) konfiguriert werden. Das Projekt wird erst nach dem ersten Start von Hard Disk Sentinel an allen Tagen ausgeführt, sodass es maximal einmal pro Tag ausgeführt wird. Empfohlen für Aufgaben, die maximal einmal pro Tag ausgeführt werden sollen, z. B. das Aktualisieren einer Antiviren-Datenbank.

  • Periodisch: Wiederholt das Projekt nach einem konfigurierten Zeitraum. Dieser kann in der Spalte Zeit (Stunde: Minute) konfiguriert werden. Empfohlen zum Speichern häufig geänderter Daten, häufig ankommender Dateien und Bilder.

  • Nach X : Startet das Projekt, wenn ein anderes Projekt mit der Nummer X abgeschlossen wurde. Nur verfügbar, wenn die Projektliste mit der Projektnummer X gespeichert wurde. Hinweis: Wenn ein Projekt in der Ablauffolge vom Benutzer abgebrochen wird oder der Benutzer sich weigert, ein Projekt zu starten, wogegen er dies zulassen sollt, werden alle weiteren Projekte abhängig vom Abgebrochenen nicht gestartet. Es ist möglich, ein oder mehrere Projekte mit einem zuvor abgeschlossenen Projekt zu verbinden (wenn für die Projekte dieselbe Option "Nach X" ausgewählt ist). Auf diese Weise werden diese Projekte gleichzeitig ausgeführt, unmittelbar nachdem das andere Projekt (mit der Nummer X) abgeschlossen wurde. Empfohlen für: Komprimieren archivierter Dateien, Brennen der Dateien auf optische Medien.

Ist die Option Vor Start fragen ausgewählt, wird das Projekt nicht automatisch ausgeführt. Stattdessen wird ein Bestätigungsfenster mit dem Namen und dem Kommentar des Projekts angezeigt, und der Benutzer muss den Start des Projekts zulassen. Damit kann der Benutzer die Ausführung des Projekts (und aller davon abhängigen Projekte) insofern verzögern, dass er wartet, bevor er die Taste drückt. Wenn er die Ausführung abbricht, werden das Projekt und alle abhängigen Projekte nicht gestartet. Hinweis: Diese Option kann nur in der registrierten Version deaktiviert werden. Die nicht registrierte Version benötigt immer eine Bestätigung zur Projektausführung.

Wenn Sie die Option Aktiviert abwählen, wird das Projekt deaktiviert und nicht gestartet. So kann ein Projekt für längere Zeit deaktiviert werden - ohne es aus der Projektliste zu entfernen. Hinweis: Wenn ein oder mehrere Projekte vom deaktivierten Projekt abhängen, werden solche Projekte auch nicht ausgeführt. Hard Disk Sentinel zeigt in dieser Situation eine Warnung an und der Benutzer kann die Konfiguration überprüfen.

Klicken Sie am Ende der Liste auf Neues Projekt zur Liste hinzufügen, um dem Tagesplan ein neues Projekt einzupflegen.


Konfiguration: Operationen, Panik-Backup

These functions are available only in the PROFESSIONAL version.

Panik-Backup: Projekt bei Problem starten

Es ist möglich, die Projektausführung mit verschiedenen Ereignissen wie auf der Seite Zeitplan zu verbinden. Wenn beispielsweise der Integritätswert einer Festplatte zu niedrig oder die Temperatur zu hoch ist, kann ein Projekt ausgeführt werden. Der Benutzer muss die verschiedenen Problemtypen aktivieren, wenn ein Projekt auf der Seite Meldungen gestartet werden soll.

Ebenso kann man eine allgemeine Projektliste angeben. Alle Projekte in dieser Liste werden ausgeführt, wenn auf einer Festplatte ein Problem auftritt (und "Panik-Back-up" für das entsprechende Problem auf der Seite Meldungen aktiviert ist). Darüber hinaus kann der Benutzer für jede installierte Festplatte eine andere Projektliste erstellen. Auf diese Weise kann festgelegt werden, dass die Daten regelmäßig von der ersten Festplatte auf die zweite archiviert werden sollen und falls die erste Festplatte einen niedrigen Integritätswert aufweist. Und wenn es ein Problem mit der zweiten Festplatte gibt, sollten die Daten auf eine externe Festplatte oder auf einen Remote-Server kopiert werden.

Im Feld neben Laufwerk können Sie die entsprechende Festplatte oder die allgemeine Projektliste auswählen (indem Sie die Option "Alle Festplatten" auswählen).

Das rote X unter Löschen kann verwendet werden, um das entsprechende Projekt aus der Liste zu entfernen. Natürlich wird das Projekt selbst nicht gelöscht, es kann jederzeit wieder ausgewählt werden, um es einer Projektliste hinzuzufügen. Dann wird (rechts vom X) die Projektnummer angezeigt. Diese ist nur dann wichtig, wenn der Benutzer eine Projektkette erstellen möchte (Projekte sequenziell eins nach dem anderen ausführen will).

Unter Projekt wird der Name des Projekts angezeigt. Der Benutzer kann das auszuführende Projekt aus der Liste der zuvor erstellten Projekte wählen.

In der Spalte Start kann festgelegt werden, wann das Projekt ausgeführt werden soll. Die möglichen Optionen sind:

  • Automatisch: Startet das Projekt sofort, wenn das Problem erkannt wird.

  • Nach dem X: Starten Sie das Projekt, wenn ein anderes Projekt mit der Nummer X abgeschlossen ist. Nur verfügbar, wenn die Projektliste mit der Projektnummer X gespeichert ist. Hinweis: Wird ein Projekt in der Kette vom Benutzer abgebrochen oder der Benutzer sich weigert, der Aufforderung zum Start eines Projekts zustimmen, was den Start aller weiteren vom abgebrochenen abhängigen Projekte verhindert. Es ist möglich, ein oder mehrere Projekte mit einem zuvor abgeschlossenen Projekt zu verbinden (wenn für die Projekte dieselbe Option "Nach X" ausgewählt ist). Auf diese Weise werden diese Projekte gleichzeitig ausgeführt, unmittelbar nachdem das andere Projekt (mit der Nummer X) abgeschlossen ist.

Wurde die Option Vor Start fragen ausgewählt, wird das Projekt nicht automatisch ausgeführt. Stattdessen wird ein Bestätigungsfenster mit dem Namen und dem Kommentar des Projekts angezeigt, und der Benutzer muss dem Start des Projekts zustimmen. Auf diese Weise kann der Benutzer die Ausführung des Projekts (und aller davon abhängigen Projekte) verzögern, indem er keine Tasten drückt, wenn das Projekt später gestartet werden soll. Bricht er den Start ab, werden das Projekt und alle abhängigen Projekte nicht gestartet. Hinweis: Diese Option kann nur in der registrierten Version deaktiviert werden. In der nicht registrierten Version muss die Projektausführung immer bestätigt werden.

Durch Deaktivieren der Option Aktiviert wird das Projekt nicht gestartet. Auf diese Weise kann ein Projekt für längere Zeit stillgelegt werden - ohne es aus der Projektliste zu entfernen. Hinweis: Sollten ein oder mehrere Projekte vom stillgelegten Projekt abhängen, werden diese Projekte ebenfalls nicht ausgeführt. Hard Disk Sentinel zeigt in dieser Situation eine Warnung an und der Benutzer kann die Konfiguration überprüfen.

Klicken Sie am Ende der Liste auf Neues Projekt zur Liste hinzufügen, um dem Tagesplan ein neues Projekt hinzuzufügen.


Dateien übertragen

Die registrierte Version von Hard Disk Sentinel PROFESSIONAL verfügt über ein internes Archivierungsmodul. Es enthält zahlreiche zu konfigurierende Funktionen und mit diesem Modul können diverse geeignete Sicherungsoperationen für die aktuelle Situation erstellt werden. Die Konfiguration und die Funktion werden in den folgenden Kapiteln beschrieben:

  • Operationen

  • Ordnereinstellungen

  • Globale Einstellungen

  • Projektoptionen

  • Dateien und Ordner übertragen (Verarbeitung)


Konfiguration: Projektoperationen, Dateien übertragen

Diese Funktionen sind nur in der registrierten PROFESSIONAL-Version verfügbar.

Um die Datei- und Ordnerübertragung zu konfigurieren, müssen Sie vor allem die Quell- und Zielordner angeben.

Durch einen Klick auf die Schaltfläche Neu wird das Fenster Ordnerauswahl angezeigt, in dem diese Ordner konfiguriert werden können. Die Schaltfläche Bearbeiten öffnet dieses Fenster und die zuvor angegebenen Werte können geändert werden (ein Doppelklick auf einen Eintrag in der Liste öffnet dieses Fenster ebenfalls. Wenn Sie die Schaltfläche Löschen verwenden, wird die der aktuell ausgewählte Eintrag aus der Liste entfernt.

Auf der Seite Globale Einstellungen können allgemein gültige Optionen für alle "Dateien und Ordner übertragen"-Projekte konfiguriert werden. Auf der Seite Projektoptionen gibt es eine Vielzahl an Optionen zur Feinabstimmung des aktuell ausgewählten Projekts.


Konfiguration: Operationen, Dateien übertragen, Ordnereinstellungen

Diese Funktionen sind nur in der registrierten PROFESSIONAL-Version verfügbar.

Um die Datei- und Ordnerübertragung zu konfigurieren, müssen Sie vor allem die Quell- und Zielordner angeben.

Quellordner und Zielordner können ausgewählt oder manuell eingegeben werden. Zudem kann man mehr als einen Zielordner verwenden (auch auf verschiedenen Laufwerken oder verschiedenen Rechnern). Die Dateien aus dem Quellordner werden in alle diese Zielordner kopiert. Bei der Definition des Zielordners können beliebige (eine oder mehrere) Variablen angegeben werden. Beispielsweise können verschiedene Ordner basierend auf dem Benutzernamen, dem Computernamen oder der IP-Adresse erstellt werden. Hard Disk Sentinel erzeugt den Ordner bei Bedarf vor der Archivierung automatisch.

Die Variable %LAST=folder% wird durch den Namen des zuletzt aktualisierten Unterordners aus dem angegebenen "Ordner" ersetzt. Dies ist nützlich, wenn der Benutzer mehrere unterschiedliche Sicherungsstatus speichern möchte, die neuesten Dateien jedoch weiter verarbeitet werden müssen (z. B. das Brennen der neuesten Dateien auf ein optisches Laufwerk). Diese Funktion und ihre Konfiguration werden auf der Seite der Projektoptionen beschrieben.

Man kann auch eine kürzere Form dieser Option verwenden: Dazu gibt man nur %LAST% an. In diesem Fall wird der Ordner vor %LAST% nach dem neuesten archivierten Ordner durchsucht. Beispiel: C:\BACKUP\%LAST=C:\BACKUP% und C:\BACKUP\%LAST% führen zu demselben Ergebnis (das neueste Archiv von C:\BACKUP). Wenn das Brennen einer CD/DVD erforderlich ist und eines dieser Beispiele als Quellordner bereitgestellt wird, wird der neueste Ordner auf das optische Laufwerk kopiert.

Hinweis: %LAST=folder% und %LAST% können nur dann verwendet werden, wenn Die Option Aktuelles Datum als Ordnernamen verwenden und behalte die letzten XX vollständigen Archive aktiviert ist.

Anmerkung: Die Ordnernamen können auf lokale oder entfernte (Netzwerk-) Laufwerke verweisen. Auch können UNC-Pfade anzugeben (z. B. \\Server\Freigabe\Ordner). Stellen Sie sicher, dass die entsprechenden Netzwerkressourcen für die Anwendung verfügbar sind.


Konfiguration: Operationen, Dateien übertragen, Globale Einstellungen

Diese Funktionen sind nur in der registrierten PROFESSIONAL-Version verfügbar.

Hier kann man konfigurieren, welche Dateien (die den angegebenen Dateimasken entsprechen) ignoriert werden sollen. Diese Dateien werden nicht archiviert.

Hinweis: Diese Option wirkt sich auf die Ausführung aller Sicherungsprojekte aus.


Konfiguration: Operationen, Dateiübertragung, Projektoptionen

Diese Funktionen sind nur in der registrierten PROFESSIONAL-Version verfügbar.

Mit diesen Optionen kann der Benutzer das Sicherungsprojekt anpassen.

Berechnen der zu kopierenden Datenmenge: Hard Disk Sentinel kann die Gesamtmenge der zu archivierenden Daten berechnen, bevor der Archivierungsprozess gestartet wird. Dies kann viel Zeit in Anspruch nehmen, wenn eine Menge Dateien und Ordner gesichert werden müssen. Daher kann diese Funktion deaktiviert werden. Wenn das Projekt als "Panik-Backup"-Projekt konzipiert ist, sollte diese Funktion in der Konfiguration der Projektoptionen deaktiviert werden, um die Archivierung so schnell wie möglich zu starten. Ist diese Option aktiviert, werden der Fortschritt und die geschätzte verbleibende Zeit während des Sicherungsvorgangs angezeigt.

Nicht starten, wenn die Datenmenge kleiner ist als XX kByte.: Starte die Archivierung nicht, wenn der Quellordner nicht die angegebene Datenmenge enthält. Mit dieser Option ist es möglich, vorhandene Sicherungen beizubehalten und die Sicherung eines leeren Ordners oder eines Ordners mit nur partiellem Inhalt zu vermeiden.

Bei zu wenigen Daten alarmieren: Erzeugt eine Warnung, wenn die Datenmenge unter dem angegebenen Schwellenwert liegt. Dies können E-Mail-, Netzwerknachrichten- oder Warnfenster sein, die gemäß Nachrichten-Einstellungen auf dem Bildschirm angezeigt werden. Es ist auch möglich, einen akustischen Alarm zu erzeugen (siehe unten).

Kopierte Daten verifizieren: Während des Sicherungsvorgangs erstellt Hard Disk Sentinel automatisch eine CRC-Prüfsumme für alle Dateien und speichert diese Werte in den archivierten Dateien (Mit diesen Informationen kann das Wiederherstellungsmodul (das in Zukunft verfügbar sein wird) die Integrität aller archivierten Dateien überprüfen und die Dateien automatisch wiederherstellen.). Ist diese Option aktiviert, wird die Integrität der archivierten Dateien nach der Archivierung überprüft. Wenn die Anzahl der archivierten Dateien groß ist, kann dieser Vorgang lange dauern (sogar länger als der Sicherungsvorgang).

Nur neue und aktualisierte Dateien kopieren: Archiviert nur seit dem letzten Sicherungsvorgang neue oder aktualisierte Dateien.

Archiv-Bit bei kopierten Dateien löschen: Hard Disk Sentinel löscht das Archiv-Bit für alle Dateien nach der Sicherung. Dadurch wird sichergestellt, dass die Dateien archiviert werden. Es wird empfohlen, diese Option gemeinsam mit der Vorherigen zu verwenden.

Quelldateien nach erfolgreichem Kopieren löschen: Entfernt alle Quelldateien, wenn der Archivierungsvorgang abgeschlossen ist. Verwenden Sie diese Funktion nur in besonderen Fällen (z. B. Sicherung von einem Speichergerät mit geringer Kapazität und bei leerem Gerät). Hinweis: Die (leeren) Ordner werden nicht gelöscht.

Unterordner speichern: Es ist möglich, die Archivierung aller Dateien in allen Unterordnern unter den Quellordnern zu aktivieren.

Quellordnernamen auch mit Inhalt speichern: Ist diese Option aktiviert, wird der Name des Quellordners (der oberste Ordner des Quellpfads) ebenfalls im Zielordner erstellt und alle Dateien und Unterordner des Quellordners werden in diesem Ordner gespeichert. Wenn diese Option deaktiviert ist, wird der Inhalt des Quellordners direkt im Zielordner gespeichert.

Fenster mit Speicherfortschritt nicht anzeigen: Normalerweise wird das Fenster Speicherfortschritt während des Archivierungsvorgangs angezeigt. Wenn die Option deaktiviert ist, wird das Fenster nicht angezeigt. Nur ein blinkendes Taskleistensymbol zeigt an, dass ein Sicherungsvorgang ausgeführt wird.

Aktuelles Datum als Ordnernamen verwenden und behalte die letzten XX vollständigen Archive: Ist diese Option aktiviert, wird der Inhalt von Quellordnern mehrmals in den Zielordnern gespeichert. Auf diese Weise können viele verschiedene vollständige Sicherungsarchive erstellt werden. Wenn das Sicherungsprojekt beispielsweise für die tägliche Ausführung konfiguriert ist und diese Option für 7 vollständige Archive aktiviert ist, werden alle Dateien rückwirkend eine Woche lang gespeichert (alle Dateien werden siebenmal gespeichert, eine Sicherungskopie pro Tag). Der Ordner mit dem aktuellen Datum und der aktuellen Uhrzeit wird automatisch im Zielordner erstellt und die Quelldateien werden darin archiviert. Wenn der Zielordner bereits die angegebene Anzahl vollständiger Archive enthält, wird das älteste Archiv automatisch gelöscht. Mit dieser Option ist es möglich, im Falle eines Problems oder Datenverlusts aus einem stabilen Archiv eines beliebigen vorherigen Tages alles wiederherzustellen. Es hat jedoch einen Nachteil: Es benötigt viel mehr Speicherplatz als eine einfache Sicherung.

Es ist möglich, nach Ausführung eines Sicherungsprojekts einen Bericht zu erstellen. Der Bericht kann in jedemFall erstellt werden (bei einem Fehler/Problem oder wenn das Projekt fehlerfrei abgeschlossen wurde) oder nur dann, wenn ein Problem aufgetreten ist. Es ist auch möglich, die Berichterstellung für dieses Projekt vollständig zu deaktivieren. Der Bericht kann eine E-Mail, eine Netzwerknachricht oder ein Warnfenster sein, das auf dem Bildschirm gemäß den Nachrichten-Einstellungen angezeigt wird. Optional kann ein akustischer Alarm aktiviert werden, wenn ein Problem auftritt.

Durch Aktivieren der Option Sound-Warnung bei Problem wird eine Warnmeldung gemäß den Toneinstellungen auf der Seite Warnungen generiert.

Es ist möglich, die Ausführungspriorität zu konfigurieren. Durch Setzen der "maximalen" Priorität wird das Projekt so schnell wie möglich ausgeführt. Dies kann die Leistung anderer Anwendungen beeinträchtigen, jedoch können auf diese Weise die Dateien unter Umständen eher archiviert werden. Es wird empfohlen, "Maximum" für "Panik-Backup"-Vorgänge zu verwenden, für andere Projekte jedoch inaktiv oder normal.


Dateien und Ordner übertragen

Wenn das Projekt im Fenster Projektkonfiguration so konfiguriert ist, dass "Dateien und Ordner übertragen" werden, wird das interne Archivierungsmodul zur Archivierung verwendet. Während des Vorgangs werden ein Fortschrittsfenster mit dem aktuellen Schritt (z. B. Dateien übertragen, Archiv überprüfen usw.) und der aktuelle Status sowie die verbleibende Zeit angezeigt, wenn die Option Zu kopierende Datenmenge berechnen aktiviert wurde.

Projekt läuft (Archivierung von Dateien)

Die Ausführung kann mit der Schaltfläche Abbrechen abgebrochen werden. In diesem Fall erstellt Hard Disk Sentinel einen Bericht (wenn die Option Berichterstellung aktiviert war) darüber, dass der Benutzer das aktuell ausgeführte Projekt abgebrochen hat. Alle anderen vom abgebrochenen Projekt abhängigen Projekte werden nicht gestartet. Hinweis: In einigen Fällen wird der Prozess möglicherweise noch einige Sekunden lang ausgeführt, bevor er gestoppt wird.

Mit der Schaltfläche X (Schließen) können Sie dieses Fortschrittsfenster schließen (ausblenden). Dadurch wird der laufende Prozess nicht gestoppt. Das Symbol für die blinkende Festplatte in der Taskleiste zeigt an, dass der Vorgang noch ausgeführt wird:

Sicherungsstatus in der Taskleiste anzeigen

Hard Disk Sentinel zeigt den aktuellen Vorgang, den Arbeitsschritt und Fortschritt an, wenn der Mauszeiger über dieses Taskleistensymbol bewegt wird. Das vollständige Fortschrittsfenster kann durch einen Klick mit der linken Maustaste angezeigt werden (wodurch auch das Taskleistensymbol ausgeblendet wird).

Hinweis: Nach Abschluss der Projektausführung werden die Status- oder Probleminformationen in der Datei project_log.txt im Ordner von Hard Disk Sentinel gespeichert. Es wird empfohlen, diese Datei im Falle eines Problems zu untersuchen.


Konfiguration: Integration

Auf dieser Seite können Sie konfigurieren, wie die Anwendung in das System integriert werden soll. Nur fortgeschrittene Benutzer sollten diese Optionen und Funktionen verwenden.

Schutz

Die Anwendung kann durch ein Passwort geschützt werden. Ohne Kenntnis dieses Kennworts kann der Benutzer die aktuellen Einstellungen nicht überprüfen und ändern. Optional kann auch das Hauptinformationsfenster geschützt werden, sodass Festplattendetails ohne das Kennwort nicht angezeigt werden können.

Ist der Schutz aktiviert, kann der Administrator nach Eingabe des richtigen Kennworts auf das entsprechende Fenster zugreifen. Die Anwendung merkt sich das Kennwort nach dem Schließen des Informationens- oder des Konfigurationsfensters. Der Benutzer muss es nicht erneut eingeben - es sei denn, die automatische Abmeldeoption ist aktiviert. In diesem Fall fragt Hard Disk Sentinel nach Ablauf des angegebenen Zeitlimits erneut nach dem Kennwort.

Der Systemadministrator kann die Schaltfläche Jetzt abmelden jederzeit verwenden, um sich nach Überprüfung und Änderung der Einstellungen abzumelden. Dies schützt die Benutzeroberfläche erneut mit einem Passwort.

Hinweis: Diese Funktion ist nur in der registrierten Version verfügbar.

Dienst

Hard Disk Sentinel kann in zwei verschiedenen Modi arbeiten. Er kann als Anwendung oder als Dienst ausgeführt werden. Standardmäßig wird es im Anwendungsmodus ausgeführt: Die Software wird gestartet, nachdem sich der Benutzer (mit den entsprechenden Administratorrechten) angemeldet hat. Vor Version 2.02 war dies der einzige Modus.

Wenn Sie Hard Disk Sentinel als NT-Dienst ausführen, startet die Software mit dem Betriebssystem und wird auch dann ausgeführt, wenn kein Benutzer angemeldet ist oder wenn ein Benutzer nur eingeschränkte Rechte hat. Auf diese Weise arbeitet Hard Disk Sentinel unabhängig vom aktuellen Benutzer: Er kann den Festplattenstatus steuern und überprüfen sowie Sicherungsvorgänge starten - genau wie im anderen Modus.

Nur der Systemadministrator kann Dienste installieren, deinstallieren und verwalten. Daher sollte der Administrator die Anwendung konfigurieren (z. B. Schwellenwerte und Alarmoptionen festlegen) und danach in den Dienstmodus wechseln. Es wird empfohlen, die vorherige (Schutz-) Funktion zu verwenden, um nicht-autorisierte Änderungen in der Konfiguration zu verhindern.

Hinweise zum Dienstmodus:

  • Diese Funktion ist nur unter NT-basierten Betriebssystemen verfügbar (Windows 2000, XP, 2003, Vista, Win7, Win8, Win10 und Windows Server 2003/2008/2012/2016 usw.).

  • Die Software führt im Dienstmodus und im Anwendungsmodus die gleichen Funktionen aus: Sie gibt Warnungen aus, führt Sicherungsvorgänge aus und so weiter.

  • Der Name des Dienstes lautet: HardDiskSentinelService und wird im Sicherheitskontext des "Lokalen Systems" ausgeführt. Der Administrator kann dies bei Bedarf über das Fenster "Systemsteuerung", "Verwaltung" und "Dienste" ändern (z. B. um den Zugriff auf Remote-Laufwerke und -Ressourcen zu ermöglichen). Die konfigurierten Sicherungsprojekte und externen Anwendungen erben die angegebenen Rechte.

  • Der Dienst kann über die richtige Verknüpfung über die Programmgruppe von Hard Disk Sentinel gestartet und gestoppt werden. Nach dem Beenden des Dienstes können Sie ihn vollständig entfernen und in den Anwendungsmodus zurückkehren. Der Benutzer muss dazu über Administratorrechte verfügen und das richtige Kennwort eingeben (wenn die Schutzfunktion aktiviert war).

  • Es ist möglich, die Software in einem "unsichtbaren" Modus (ohne Anzeige von Fenstern, Taskleistensymbolen, Meldungen) zu verwenden, wenn die Option "Datenaustausch zwischen Dienst und Desktop zulassen" deaktiviert ist (im Fenster "Diensteigenschaften" des Betriebssystems). In diesem Fall kann der Benutzer nicht auf die Hauptinformationen und die Konfigurationsfenster zugreifen, es sei denn, er beendet den Dienst mithilfe der Verknüpfung "Dienst beenden". Windows Vista/7/8/10 zeigt keine Benutzeroberfläche für interaktive Dienste an, daher wird der Dienst von Hard Disk Sentinel unter Vista/7/8/10 in einem solchen "unsichtbaren" Modus ausgeführt.

  • In der Professional-Version ist die Verknüpfung Hard Disk Sentinel Tray in der Programmgruppe verfügbar. Dies zeigt die Taskleistensymbole an und ermöglicht den Zugriff auf Laufwerkstatusinformationen unter Windows Vista/7/8/10 und neueren Betriebssystemen, selbst wenn Hard Disk Sentinel im Modus "Dienst" ausgeführt wird. Auf diese Weise könnten Benutzer mit eingeschränkten Rechten Informationen zu Laufwerkstatus und Temperatur-/ Integritätsanzeigen in der Taskleiste erhalten.

  • Der Dienst wird automatisch mit dem System gestoppt und gestartet. Der Benutzer muss ihn nicht manuell stoppen, bevor er den Computer herunterfährt.

  • Der Administrator sollte den Zugriff auf den Ordner von Hard Disk Sentinel für Benutzer mit eingeschränkten Rechten deaktivieren. Auf diese Weise können Benutzer Einstellungen und Informationen außerhalb der Anwendung nicht überprüfen und ändern.

  • Manche Systeme, Anwendungen oder Desktop-Themen können dazu führen, dass einige Teile der Benutzeroberfläche (das Statusfenster, Informationen auf dem Desktop) nicht oder nur teilweise angezeigt werden.

  • Sie können den Dienst über das Fenster Systemsteuerung, Verwaltung, Dienste starten und stoppen. Klicken Sie mit der rechten Maustaste auf HardDiskSentinelService, und ein Popup-Menü mit den Befehlen Start und Stopp wird angezeigt. Dies ist auch von einem Remotecomputer aus möglich, wenn der Benutzer über die entsprechenden Rechte verfügt.

  • Wird der Dienst angehalten, können Sie den ihn mithilfe der Befehle HDSentinel.exe /INSTALL oder HDSentinel.exe /UNINSTALL im Installationsordner von Hard Disk Sentinel installieren oder deinstallieren.

Fernbedienung

Web-Status aktivieren: Ist diese Option aktiviert, kann der Festplattenstatus mithilfe eines Webbrowsers vom lokalen Computer oder von einem Remotecomputer/Mobiltelefon/PDA aus überprüft werden. Optional kann ein Passwort verwendet werden, um unbefugten Zugriff zu verhindern. Auf diese Weise sollten ein beliebiger Benutzername und ein Kennwort im Bereich Schutz verwendet werden, um die Verbindung herzustellen.

Es ist möglich, einen beliebigen HTTP-Port entsprechend der aktuellen Netzwerkkonfiguration anzugeben.

Hinweis: Diese Funktion ist nur in der registrierten Version verfügbar.

Ist diese Option aktiviert, können die folgenden Abfragen im Webbrowser verwendet werden:

  • http://server:port/status: Das gesamte Statusfenster mit allen Inhalten (genau wie konfiguriert), das regelmäßig nach Ablauf der angegebenen Zeit aktualisiert wird. Das Fenster hat keine Ränder und Randabstände und kann in einen IFRAME eingefügt werden.

  • http://server:port/statuswin.bmp: Statusfenster (nur das Bild)

  • http://server:port/report: detaillierter HTML-Bericht, der die konfigurierten Berichtsabschnitte enthält

  • http://server:port/xml : vollständiger XML-Bericht

Hinweis: Das Statusfenster muss nicht auf dem Computer (Server) angezeigt werden, um diese Funktion nutzen zu können.

Beispiel: Wenn die Option auf dem lokalen Rechner aktiviert ist und die Standardeinstellungen verwendet werden, geben Sie http://localhost:61220/status in einem Browser ein, um Festplatteninformationen zu überprüfen.

Anmerkung: Alle Anfragen werden mit IP-Adresse und Datum in der Datei "NetLog.txt" protokolliert. Andere als die oben genannten Abfragen geben den Fehler 403 Vorbidden im Browser zurück. Mit dieser Funktion ist es NICHT möglich, auf das Dateisystem oder andere Informationen zuzugreifen.

Hinweis: Wenn der Computer (Server) über eine dynamische IP-Adresse verfügt, muss der Dienst eines DynDNS-Anbieters (der die dynamische IP-Adresse in einen festen Hostnamen übersetzt) verwendet werden, um aus der Ferne auf den Rechner zuzugreifen. Dieser Service ist beispielsweise unter http://www.no-ip.com und http://www.dyndns.com frei verfügbar.

    Festplattenstatus wird in einem Remote-Browser (PDA) angezeigt
    In einem Remote-Browser (PDA) angezeigter Festplattenstatus

Statusfenster von Hard Disk Sentinel von zwei oder mehr Computern können problemlos zu einer einzigen Webseite kombiniert werden (die automatisch aktualisiert wird, um den momentanen Status wiederzugeben). Auf diese Weise ist es möglich, den Status verschiedener Konfigurationen aus der Ferne zu überprüfen, indem diese Seite (HTML-Datei, die sich auf einem Dateiserver im Netzwerk oder auf dem PC/Telefon/PDA selbst befinden kann) in einem Browser geöffnet wird. Beispiele:

    <html>
<head>
<title>Hard Disk Sentinel Status</title>
</head>
<body>
<center>
<iframe src="http://192.168.2.101:61220/status" width=220
height=61 frameborder=0></iframe><br>PC #1<br><br>
<iframe src="http://192.168.2.102:61220/status" width=220
height=61 frameborder=0></iframe><br>PC #2<br><br>
<iframe src="http://192.168.2.103:61220/status" width=220
height=61 frameborder=0></iframe><br>PC #3<br><br>
</body>
</html>
    Displays 3 status windows in IFRAMEs (updated automatically, separately).
    <html>
<head>
<title>Hard Disk Sentinel Status</title>
<META HTTP-EQUIV="Refresh" CONTENT="300">
<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
<META HTTP-EQUIV="CACHE-CONTROL" CONTENT="NO-CACHE">
</head>
<body>
<center>
<a href="http://192.168.2.101:61220/report"><img
src="http://192.168.2.101:61220/statuswin.bmp" border=0></a><br>PC #1<br><br>
<img src="http://192.168.2.102:61220/statuswin.bmp"><br>PC #2<br><br>
<img src="http://192.168.2.103:61220/statuswin.bmp"><br>PC #3<br><br>
</body>
</html>
    Zeigt 3 Statusfenster an und aktualisiert alle 300 Sekunden. Wenn Sie auf das erste Fenster klicken, wird der vollständige Bericht für diesen pc angezeigt.
    Hard Festplattenstatus wird in einem Remote-Browser (PDA) angezeigt.
    Das oben Angezeigte wurde in einer HTML-Datei auf dem PDA gespeichert und im Browser geöffnet.

Remote-Verbindungen vom Server akzeptieren: Mit Hard Disk Sentinel Enterprise können Sie Festplattenprobleme aus der Ferne analysieren, den Festplattenstatus überprüfen und Festplatten auf Computern testen, auf denen der Client von Hard Disk Sentinel ausgeführt wird. Ist diese Option aktiviert, kann der Server Befehle senden und Informationen über diesen Computer erkennen.

DynDNS-, No-IP- oder benutzerdefinierten Dyamic-DNS-Dienst aktivieren: Mithilfe dieser Dienste kann einer sich ändernden (dynamischen) IP-Adresse eines Computers ein fester Hostname zugewiesen werden. Mit diesem konstanten Hostnamen kann auf den Computer aus der Ferne zugegriffen werden, sodass eine Fernwartung (Webstatus, Remote-Verbindungen) möglich ist.

Um dies zu konfigurieren, ist eine Registrierung bei einem der oben genannten Dienste erforderlich. Anschließend sollten der Benutzername, das Kennwort und der registrierte Hostname in Hard Disk Sentinel konfiguriert werden. Wenn die Anwendung später feststellt, dass die IP-Adresse des Computers geändert wurde, aktualisiert sie diese innerhalb einer Minute automatisch für den zugeordneten Host. Auf diese Weise wäre der Fernzugriff möglich, nachdem sich der Computer erneut mit dem Netzwerk verbunden hat.

Über die Schaltfläche "Konfigurieren" sollten Sie den Benutzernamen, das Kennwort und den Hostnamen für den jeweiligen dynamischen DNS-Anbieter angeben. Nach einem IP-Update kann die letzte Serverantwort überprüft werden, indem der Mauszeiger über die entsprechende Option für dynamisches DNS bewegt wird. Diese Serverantwort ist nützlich, um ein Problem zu diagnostizieren (z. B. einen falschen Benutzernamen).


Konfiguration: Testbericht senden

Auf dieser Seite können Sie einen Testbericht mit detaillierten Erkennungsinformationen erstellen und an den Entwickler senden. Ein solcher Bericht enthält manchmal mehr Informationen (im Vergleich zu einem vollständigen, aber formatierten HTML- oder Textbericht) über die erkannten Festplatten, deren Typ und Details. Diese Informationen können dazu beitragen, mögliche Probleme zu untersuchen oder die Anwendung zu verbessern. Senden Sie diese Berichte daher an die Adresse reports@hdsentinel.hu.

Der Bericht kann sofort nach Erstellung gesendet werden. Auf diese Weise lädt Hard Disk Sentinel ihn automatisch auf www.hdsentinel.com hoch. Wenn keine aktive Internetverbindung besteht, kann der Bericht über die Schaltfläche Speichern in einer Datei gespeichert und vom Benutzer später (von einem anderen Rechner aus) gesendet werden.


Festplattentests

Auf den folgenden Seiten werden die verschiedenen in Hard Disk Sentinel verfügbaren Festplattentests beschrieben. Es wird empfohlen, diese Seiten sorgfältig durchzulesen (insbesondere die allgemeinen Informationen) bevor Sie einen dieser Tests verwenden.

  • Allgemeine Informationen, Antworten zu Festplattentests

  • Hardware-Selbsttests: Kurzer, Erweiterter, Transport-Selbsttest

  • Test des wahlfreien Zugriffs (Random Seek)

  • Oberflächentest


Tests - Allgemeine Informationen

Wie es ist möglich, dass der Zustand der Festplatte niedrig ist, die Textausgabe zeigt die schlechten Sektoren, aber die Tests melden keine Probleme?

Findet die Festplatte einen fehlerhaften Sektor, versucht sie, den Inhalt des Sektors im Ersatzbereich zu speichern (neu zuzuweisen). Wenn dies abgeschlossen ist, wird der ursprüngliche Sektorspeicherort markiert und die Festplatte verwendet ihn nicht mehr: Alle weiteren Lese- und Schreibvorgänge werden an den Ersatzsektor umgeleitet. Auf diese Weise können die Tests (was nicht nur Tests dieser Software bedeutet) nur auf diese modifizierte Oberfläche zugreifen. In einer optimalen Situation ist die Oberfläche wirklich perfekt - die Probleme sind behoben, schlechte Bereiche werden nicht mehr verwendet. Probleme können nur verursacht werden, wenn der schlechte Bereich relativ groß ist (daher ist die Gesundheit gering) und immer mehr Probleme (zum Beispiel schwache und schlechte Sektoren) entstehen. Um diese Probleme zu beheben, wird empfohlen, die in Hard Disk Sentinel integrierten Tests zu verwenden, da sie die Probleme in einer kontrollierten Umgebung überprüfen und beheben können. Weitere Informationen zu Problemen finden Sie im Abschnitt Textausgabe.

Alle Tests sollen Festplattenprobleme aufdecken. Der Zustand wird basierend auf den mit der Festplatte festgestellten Problemen berechnet. Der Test kann zu einer Abnahme des Zustands führen. Die Gesundheit könnte sich nur dann erhöhen, wenn die Probleme "versteckt" (aber nicht behoben!) würden. Dies ist nicht möglich - außer wenn das Laufwerk vor dem Test schwache Sektoren hatte und deren Anzahl abnehmen kann (sogar zurück auf null). Die Anzahl anderer Probleme, die von der Festplatte erkannt (und behoben) wurden, kann nicht verringert werden und wäre nicht gut, aber unter Verwendung der Spalte "Offset" in der S.M.A.R.T.-Seite können diese Probleme ignoriert werden, wenn der Laufwerksstatus stabil ist. Weitere Informationen finden Sie in den Abschnitten Textausgabe und Temperaturkalibrierung.

Warum findet der Test mehr oder weniger fehlerhafte Sektoren als in der Textausgabe angezeigt wird?

Die in der Textausgabe angezeigten fehlerhaften Sektoren, die nicht mehr verwendet werden, wurden von der Festplatte bereits neu zugewiesen. Die durch den Test aufgedeckten fehlerhaften Sektoren befinden sich immer noch auf der aktiven Oberfläche, sodass diese möglicherweise zu Datenverlust führen könnten. Unser Ziel ist es, die Festplatte zu zwingen, diese Sektoren neu zuzuweisen, um ihre zukünftige Verwendung zu verhindern. Normalerweise funktioniert die Festplatte besser (selbst ihr Integritätswert kann aufgrund der Neuzuweisung abnehmen).

Kann die Gesundheit verbessert werden? Kann sie zu 100 % wiederhergestellt werden?

Wenn die Festplatte schwache Sektoren hatte, kann ihr Status während der Tests verbessert werden. Dies kann zu einem erhöhten Gesundheitswert führen - sogar auf 100 %, wenn keine anderen Probleme beim Laufwerk festgestellt wurden. In allen anderen Fällen kann sich der Zustand verschlechtern, wenn der Status des Laufwerks nicht stabil ist und erneut Probleme auftreten.

Wenn das Laufwerk stabil ist: Der Zustand ändert sich auch nach vielen Durchläufen der Schreibtests nicht, die vorherigen Probleme können auf der S.M.A.R.T.-Seite mithilfe der Spalte Offset gelöst werden. Auf diese Weise kann die Gesundheit zu 100 % wiederhergestellt werden.

Ein Garantieaustausch ist nur bei 0 % Gesundheit möglich. Wenn der Gesundheitszustand höher (aber immer noch niedrig) wurde, wird empfohlen, Tests (auch mehrmals) zu starten, um weitere, derzeit nicht erkannte Probleme aufzudecken.

Warum ist es gut, die Festplattentests von Hard Disk Sentinel zu verwenden? Warum reicht es nicht aus, Dateien einfach zu kopieren (um eine Neuzuweisung zu erzwingen)?

Während der Tests in der Anwendung werden die Festplatten im Vergleich zu gewöhnlichen Dateioperationen besser kontrolliert und überwacht. Das Dateisystem ist nicht gemountet, um zu verhindern, dass das Betriebssystem und andere Software auf die Festplatte zugreifen. Der Status des Dateisystems (z. B. Fragmentierung) hat keinen Einfluss auf den Test. Die Leistung der Blöcke, die Anzahl der Wiederholungen sowie der Zustand und die Temperatur der Festplatte sind Faktoren, die während der Tests kontinuierlich überwacht werden. Es ist sogar möglich, den Sektorinhalt jederzeit einzusehen. Genau wie ein chirurgischer Eingriff nur im Krankenhaus möglich ist - verfügt das Testen und Reparieren von Festplatten über eine eigene kontrollierte Umgebung.

Teststypen

Im Allgemeinen stehen zwei verschiedene Tests zur Verfügung: Hardware-Selbsttest und Softwaretests < /a> (beide sind in Hard Disk Sentinel verfügbar). Die letztgenannte Kategorie enthält auch den Test des wahlfreien Zugriffs (Random Seek), einer speziellen Art Test, da er nicht die Oberfläche, sondern nur die Suchfunktionen des Laufwerks überprüft.

Die Hardware-Tests können besser sein als Softwaremethoden, da sie das Plattensystem und die Komponenten (z. B. Kopf, Servo, elektrische Komponenten usw.) auf eine spezielle Weise untersuchen in der Lage sind, als es mit Softwaremethoden möglich wäre. Die gespeicherten Informationen sind davon nicht betroffen, sodass sie (auf IDE- und S-ATA-Festplatten, die sie unterstützen) jederzeit ohne besondere Vorbereitung oder ein vorheriges Backup angewandt werden können. Die Verwendung von Hardwaretests wird regelmäßig empfohlen, insbesondere auf perfekten (oder nahezu perfekten) Festplatten, um versteckte Probleme aufzudecken.

In einigen Fällen sind diese Hardwaretests (Laufwerk -> Kurzer Selbsttest, Laufwerk -> Erweiterter Selbsttest) nicht verfügbar, werden nicht unterstützt oder führen selbst bei einer relativ geringen Anzahl von Problemen schnell zu einem Fehler. Es werden keine weiteren Informationen über das Ergebnis zurückgegeben. Beispielsweise ist es nicht möglich, die beschädigten Sektoren aufzulisten. In diesem Fall ist eine geeignete Softwaretestmethode erforderlich.

Wenn wir über Software-Tests sprechen, ist es wichtig zu wissen, dass der Schreib-Vorgang, der sich auf die Festplattenoberfläche auswirkt, von großerer Bedeutung ist: Dies zwingt die Festplatte, die Integrität des Datensektors zu überprüfen und ihn bei Bedarf neu zuzuweisen sowie einen schwachen Sektor zu reparieren. Aus diesem Grund können alle Typen von Lesetests (z. B. Scandisk, aber auch eine Formatierung) nicht zur Reparatur von Festplattenproblemen beitragen (und in vielen Fällen können sie solche Probleme nicht einmal erkennen). Scandisk überprüft und behebt nur logische Fehler (Dateisystemfehler), die nicht wirklich mit dem Status, den Fehlern der physischen Festplatte in Verbindung stehen (nur aus diesem Grund verschwinden sie normalerweise nach vollständiger Neupartitionierung und Neuformatierung der Festplatte).

Die Schreibtests sind normalerweise destruktiv, da sie die gespeicherten Daten überschreiben müssen. Seien Sie in jedem Fall sehr vorsichtig, bevor Sie einen solchen Festplattentest starten. Es ist wichtig, alle Daten zu sichern!

Die Verwendung von Softwaretests wird im Vergleich zu Hardwaretests weniger häufig empfohlen. Softwaretests sind nützlich, wenn

  • eine neue leere Festplatte im System installiert wurde
  • ein Hardware-Selbsttest mit Fehler abgeschlossen wurde
  • die Festplatte verdächtig ist (z. B. macht sie seltsame Geräusche) und/oder ihr Zustand ändert sich
  • es erforderlich ist, die gespeicherten Daten auf der Festplatte oder dem SSD/Flash-Gerät aufzufrischen (ohne Daten zu löschen), was regelmäßig zu verwenden empfohlen wird, um zu verhindern, dass die Zellen die gespeicherten Informationen "vergessen". Die Häufigkeit richtet sich nach der tatsächlichen Nutzung des Geräts.

In solchen Fällen wird empfohlen, zuerst den Lesetest zu verwenden, der die gespeicherten Informationen nicht beeinflusst. Der Lesetest kann keine Fehler beheben, kann jedoch zeigen, welche Bereiche des Laufwerks nicht perfekt, beschädigt und/oder nur langsam zugänglich sind, und er zeigt die Temperatur- und Leistungsmerkmale des Laufwerks an. Die eigentliche Überprüfung und Behebung von Fehlern ist später durch einen geeigneten Schreibtest möglich. Bei anhaltenden Problemen wird empfohlen, die Daten zu sichern und den Test zur erneuten Initialisierung der Festplattenoberfläche zu verwenden (auch bei Stufe 3 oder höher). Andere Anwendungen bezeichnen eine einfachere Version dieses Tests (fälschlicherweise) als Low-Level-Format.

WICHTIG: Der Entwickler bietet keine Garantie für die auf Datenträgern gespeicherten Daten! Es wird unbedingt empfohlen, ALLE DATEN zu sichern und die Beschreibung der Tests sorgfältig zu lesen, bevor einer der Tests gestartet wird.


Hardware-Selbsttests

Die in IDE/Serial ATA/SCSI/SAS-Festplatten integrierten Hardware-Selbsttests sind die perfekte Lösung, um den Festplattenstatus schnell oder sehr detailliert zu testen. Normalerweise werden die kurzen und erweiterten Selbsttests von den Festplatten unterstützt, aber einige Modelle stellen auch andere (Transport-) Selbsttests bereit. Die Liste aller unterstützten Selbsttests und die geschätzte Zeit solcher Tests werden auf der Seite mit Informationen der Festplatte angezeigt.

Die Selbsttests sind zerstörungsfrei und wirken sich nicht auf die auf der Festplatte gespeicherten Daten aus. Während des Tests kann die Festplatte weiterhin verwendet werden, ist jedoch möglicherweise langsamer Umgekehrt kann die Festplattennutzung die Testdauer verlängern. Dies könnte für eine Systemfestplatte wichtig sein, auf der das Betriebssystem oder eine andere Software viele Lese-/Schreibvorgänge verursachen kann.

Der Kurze Selbsttest überprüft die Hauptkomponenten der Festplatte (Lese-/Schreibköpfe, Servo, Elektronik, interner Speicher usw.). Dieser Test dauert nur einige Minuten.

Der Erweiterte Selbsttest führt die oben genannten Schritte aus und verfügt über einen vollständigen Oberflächen-Scan, der die problematischen Bereiche (falls vorhanden) aufdeckt und die Neuzuweisung der fehlerhaften Sektoren erzwingt. Es wird empfohlen, diesen Test regelmäßig zu verwenden, um den Zustand der Festplatte zu überprüfen - insbesondere auf einer Festplatte mit weniger als 100 % Zustand.

Der Transport-Selbsttest (falls unterstützt) führt herstellerspezifische Testschritte durch. Dadurch werden normalerweise die mechanischen Teile der Festplatte überprüft, um sicherzustellen, dass keine Handhabungsschäden aufgetreten sind.

Das Datum und die Ergebnisse (erfolgreicher Abschluss oder fehlerhaftes Festplattenelement) der letzten Selbsttests werden auf der Seite Informationen angezeigt. Auf dieser Seite können alle unterstützten Festplattentests manuell gestartet werden. Sie können auch automatische (geplante) Festplattentests auf der Seite Operationen konfigurieren (nur Professional-Version).


Test des wahlfreien Zugriffs (Random Seek)

Durch diesen Test ist es möglich, den Geräuschpegel, die Suchzeit von Spur zu Spur und die Temperatur-Levels der Festplatte zu überprüfen, insbesondere bei übermäßiger Festplattennutzung.

Der Test ist besonders nützlich, nachdem der Geräuschpegel geändert wurde, um zu überprüfen, wie sich die geänderte Einstellung auf das Rauschen und die Suchzeit auswirkt. Diese Überprüfung kann durch einen kurzen (schnellen) Test erfolgen.

Der Test kann verwendet werden, um die Stabilität und den Temperaturanstieg der Festplatte während eines längeren Zeitraums hoher Beanspruchung zu überprüfen. Es ist möglich, dass die Temperatur während des Tests um 10-15 Grad Celsius (im Vergleich zur Leerlauftemperatur) ansteigt. Wenn die Festplatte vor Beginn des Tests zu heiß war, wird empfohlen, den Test nur unter Kontrolle zu verwenden und ihn bei Erreichen eines kritischen Temperaturniveaus abzubrechen.

Empfohlene Verwendung des Tests: nach der Installation einer neuen Festplatte. Ein längerer Test (8 Stunden oder länger) kann als Stresstest verwendet werden, um die Stabilität der Festplatte zu prüfen.

Der Test kann auch dann angewandt werden, wenn der Hardware-Selbsttest mit einem Fehler beendet oder von der Festplatte nicht unterstützt wird. Der Test ist sicher, wirkt sich nicht auf die gespeicherten Daten aus, sondern positioniert nur den Lese-/Schreibkopf der Festplatte.

Hinweis: Die nicht registrierte Version erlaubt nur den kürzesten Test (2 Minuten) und nur einmal auf einer Festplatte.


Oberflächentest

Mit diesem Test kann die Oberfläche der Festplatte mittels verschiedener Methoden untersucht werden. Einige dieser Methoden sind für die gespeicherten Daten sicher, andere jedoch destruktiv: Die gespeicherten Informationen werden während des Testvorgangs dauerhaft gelöscht.

Zunächst müssen Sie die Festplatte und den am besten zu startenden Testtyp auswählen. Die detaillierte Beschreibung des Tests wird bei der Auswahl angezeigt, und die Software zeigt an, wie sich der Test auf gespeicherte Daten auswirkt. Es wird dringend empfohlen, diese Informationen vor Beginn des Tests sorgfältig zu lesen.

Mit der Schaltfläche "Mehrere Laufwerke" können Sie mehrere Festplatten auswählen, die gleichzeitig mit derselben Testmethode, denselben Optionen und Einstellungen getestet werden sollen. Die Anzahl der zu testenden Festplatten ist nicht begrenzt (nur die Gesamtsystemleistung/Ressourcen können sie einschränken).

Folgende Tests sind möglich:

- Lesetest - Liest die Festplattenoberfläche, um zu überprüfen, ob alle Sektoren zugänglich und lesbar sind.

Der Test ist sicher und wirkt sich nicht auf gespeicherte Daten aus.

Festplattenprobleme könnten in manchen Fällen verborgen bleiben und aufgedeckte Festplattenprobleme werden NICHT behoben (wie bei ScanDisk).

- Schreibtest - Überschreibt die Festplattenoberfläche mit einem konfigurierbaren Muster. Erzwingt die Analyse schwacher Sektoren, überprüft versteckte Probleme und behebt sie durch Neuzuweisung fehlerhafter Sektoren (dies nennt sich Laufwerksregenerierung).

Ermöglicht eine bessere Verwendung der Festplatte, da nach dem Test der Ersatzbereich anstelle problematischer Sektoren verwendet wird.

Hinweis: Auf der Konfigurationsseite kann das vom Schreibtest zu schreibende Muster konfiguriert werden. Standardmäßig schreibt Hard Disk Sentinel Nullen (00 Bytes), es kann jedoch festgelegt werden, dass alle Sektoren die Sektornummern (möglicherweise nützlich für die spätere Datenwiederherstellung) oder sogar zufällige Daten enthalten sollen. Ebenso ist es möglich, eine beliebige Byte/Byte-Sequenz als Überschreibmuster anzugeben. Wenn Sie beispielsweise ABC in das Feld für die Byte/Byte-Sequenz eingeben, werden in allen Sektoren ABC-Zeichenfolgen wiederholt. In dieser Option ist es möglich, eine Hex-Sequenz einzugeben, zum Beispiel 0x99 0x88 0x77, um solche Bytes zu schreiben. Es ist auch möglich, FILE=vorhandener Dateiname anzugeben. Anschließend wird der Inhalt der Datei als Überschreibmuster verwendet.

- Schreibtest + Lesetest (nur Pro-Version) Überschreibt die Festplattenoberfläche mit einem konfigurierbaren Muster und liest dann Sektorinhalte zurück, um zu überprüfen, ob sie zugänglich und konsistent sind. Erzwingt die Analyse schwacher Sektoren und überprüft versteckte Probleme und behebt sie durch Neuzuweisung fehlerhafter Sektoren (Laufwerksregenerierung genannt).

Ermöglicht eine bessere Verwendung der Festplatte, da nach dem Test stattdessen der Ersatzbereich aller problematischen Sektoren verwendet wird.

- Lesetest + Schreibtest + Lesetest (Datenbereich auffrischen) (nur Pro-Version) Liest gespeicherte Daten aus jedem Block, schreibt den Inhalt zurück und liest schließlich die Informationen und vergleicht sie mit dem ursprünglichen Inhalt. Bei dem umfangreichen Test wird vor dem Zurückschreiben des Inhalts ein zusätzlicher Schreibzyklus verwendet, um die Effizienz der Fehlerkorrektur (Laufwerksregeneration) zu verbessern.

Der Vorgang ist normalerweise für die gespeicherten Informationen sicher, es kann jedoch zu Datenverlust kommen, falls das System nicht stabil ist und/oder bei Stromausfall, Übertaktung, Speicher-, Stromversorgungs-, Kabelproblemen und anderen Faktoren.

Mit dem Test kann der Datenbereich des Speichergeräts aufgefrischt werden, ohne dass ein vollständiges Löschen erforderlich ist, es wird dennoch empfohlen, wichtige Daten vor diesem Test zu sichern.

- Festplattenoberfläche neu initialisieren (nur Pro-Version) Überschreibt die Festplattenoberfläche mit einem speziellen Initialisierungsmuster, um den Standardstatus (leer) der Sektoren wiederherzustellen, und liest Sektorinhalte zurück, um zu überprüfen, ob sie zugänglich und konsistent sind. Erzwingt die Analyse schwacher Sektoren, überprüft versteckte Probleme und behebt sie durch Neuzuweisung fehlerhafter Sektoren (Laufwerksregenerierung genannt).

Ermöglicht eine bessere Verwendung der Festplatte, da nach dem Test stattdessen der Ersatzbereich sehr problematischer Sektoren verwendet wird.
Sehr intensiver und zeitaufwendiger Test, insbesondere wenn der Pegel (die Anzahl der Überschreibungszyklen) auf einen höheren Wert eingestellt ist.

Die einfache Version dieses Tests wird normalerweise (nicht korrekt) von anderen Tools als Low-Level-Format bezeichnet. Es kann effektiv verwendet werden, um gespeicherte Informationen dauerhaft zu zerstören (Navso P-5239-26 Standard-Datenvernichtung).

- Festplattenreparatur (nur Pro-Version) - Liest die Festplattenoberfläche, um zu überprüfen, ob alle Sektoren lesbar sind, und zwingt das Laufwerk, problematische (ausstehende, schwache) Sektoren zu reparieren: Setzt den Status wieder auf gut oder realloziert (Wieder einsetzen aus dem Ersatzbereich), falls erforderlich, um die Weiterverwendung des ursprünglichen Sektors zu verhindern.
Der Test ist für gespeicherte Daten sicher und die beschädigten Dateien sind lesbar. Dateifragmente auf defekten Sektoren können jedoch beschädigt sein. Dateien auf den betroffenen, reparierten Sektoren werden nach Abschluss des Tests aufgelistet.
Der Test eignet sich am besten zum Reparieren von Laufwerken mit schwachen Sektoren, ohne dass eine vollständige Sicherung erforderlich ist (ohne erneute Anwendung des Oberflächentests ) und funktioniert sowohl auf System- als auch auf Sekundärlaufwerken. Weitere Informationen finden Sie unter: Hard disk case: weak sectors

Jeder Test besitzt unterschiedliche Konfigurationsoptionen:

Im Allgemeinen ist es möglich, die Reihenfolge der zu testenden Blöcke zu konfigurieren und optional die Anzahl der Wiederholungen anzugeben (sodass die Software denselben Test zwei- oder mehrmals auf der Festplatte ausführt) und alle logischen Volumes (Partitionen) während des Tests freizugeben (unmount). Letzteres wird dringend empfohlen, um zu verhindern, dass andere Software und das Betriebssystem während des Tests auf die Festplatte zugreifen. Das Systemlaufwerk (welches das Betriebssystem, den Stammordner des Benutzers oder die Auslagerungsdatei von Windows enthält), kann auf diese Weise nicht gesperrt werden. Weil das System in diesem Moment läuft, kann auf einem Systemlaufwerk nur ein Lesetest (der keine Auswirkungen auf gespeicherte Daten hat) verwendet werden.

Hinweis: Einige Tests (z. B. Tests zur Neuinitialisierung der Datenträgeroberfläche und zum Aktualisieren des Datenbereichs) und Testoptionen sind nur in der Professional-Version der Software verfügbar.

Anmerkung: Um zu verhindern, dass nicht-autorisierte Personen die Tests (insbesondere die Schreibtests) verwenden, fragt die Software vor dem Öffnen des Testfensters nach dem konfigurierten Kennwort.

Test-Details

Die Software unterteilt den Datenbereich in 10.000 Blöcke. Dies ist die Oberflächenkarte der Festplatte. Wenn Sie mit der Maus auf einen Block klicken, wird der Inhalt des Sektors unter dem ausgewählten Block angezeigt. Auf diese Weise ist es möglich, die gespeicherten Daten und/oder die geschriebenen Daten nach Durchführung eines Schreibtests zu überprüfen. Sie können den Sektorinhalt überprüfen (und die Ergebnisse eines zuvor gespeicherten Tests zurückladen), ohne einen Test zu starten, indem Sie auf die Schaltfläche Anzeigen klicken. Dies ist für die auf der Festplatte gespeicherten Daten sicher.

Während der Tests überprüft Hard Disk Sentinel die Integrität der einzelnen Sektoren unter den angezeigten Blöcken. Ein Block, auf den zugegriffen und der fehlerfrei verarbeitet werden kann, wird durch die Farbe grün gekennzeichnet. Eine dunklere grüne Farbe bedeutet, dass die Sektoren langsamer und schwerer zu verarbeiten sind (je nach Testtyp lesen oder schreiben), aber immer noch gut. Einige (insbesondere zufällige) dunklere Grüne Blöcke sind völlig akzeptabel, es sei denn, sie bilden einen durchgehenden, größeren Bereich (vor allem mit gelb/roten Blöcken in der Nähe). Die Software filtert den Effekt langsamerer Übertragungszeiten am Ende der Festplatten heraus. Sind Sektoren schwerer zugänglich und können erst nach einem oder mehreren Wiederholungsversuchen verarbeitet werden, werden die Blöcke beschädigt, aber repariert. Die Software zeigt die entsprechenden Blöcke mit gelb an. Die Farbe Rot bedeutet, dass der Sektorblock nicht verarbeitet werden kann (gelesen oder geschrieben - entsprechend dem ausgewählten Test). Ein weiterer Schreibtest kann erforderlich sein, um das Laufwerk zu zwingen, die problematischen Sektoren im Block neu zuzuweisen.

Bei beschädigten oder fehlerhaften Blöcken wird empfohlen, die gesamte Datenoberfläche mit einem oder mehreren Schreibtests zu untersuchen. Während der Schreibtests zwingt die Software die Festplatte, den Status der Sektoren auf der Oberfläche zu überprüfen und sie dem Ersatzbereich neu zuzuweisen. Auf diese Weise wird der ursprüngliche (fehlerhafte) Sektor nicht verwendet und alle weiteren Lese- und Schreibvorgänge werden in den freien Bereich umgeleitet. Dies nennt man Regeneration. Die resultierende Festplatte funktioniert besser, es ist sogar möglich, dass bei folgenden Tests nur gute (grüne) Blöcke angezeigt werden, da die fehlerhaften Sektoren nicht mehr verwendet werden. Der Nebeneffekt der Regeneration besteht darin, dass der Zustand des Laufwerks abnimmt, da immer mehr Probleme auftreten. Daher verbessert die Regeneration normalerweise nicht die Gesundheit (außer, wenn schwache Sektoren gefunden wurden und ihr Status stabilisiert wurde).

Werden im Laufe der Tests fehlerhafte Blöcke gefunden, reagiert die Software und/oder das Betriebssystem möglicherweise während der Neuzuweisung nicht. Dies kann einige Minuten oder sogar Stunden dauern - abhängig von der Größe der betroffenen Oberfläche. Es wird nicht empfohlen, den Vorgang abzubrechen und ein Zurücksetzen oder Ausschalten des Computers ist zu vermeiden. Möglicherweise trennt der Festplattencontroller oder sein Treiber das nicht reagierende Laufwerk, sodass es aus dem System verschwindet. Dies ist eher bei USB-Verbindung möglich. In diesem Fall wird empfohlen, die Festplatte direkt an das Motherboard oder einen anderen Controller anzuschließen und den Test erneut zu starten.

Empfohlene Verwendung der Tests: Starten Sie einen umfangreichen Schreibtest (z. B. mit "Festplattenoberfläche neu initialisieren"), um zu überprüfen, ob die Festplattenoberfläche verwendbar ist, und erzwingen Sie zu diesem Zeitpunkt die Überprüfung und Neuzuweisung von Sektoren. Wie der Test des wahlfreien Zugriffs (Random Seek) misst die Software dabei die Temperaturniveaus, sodass die höchstmögliche Temperatur während dieser extremen Belastung überprüft werden kann. Die Tests können auf anderen Arten von Speichergeräten (nicht nur auf Festplatten) gestartet werden, z. B. können SSD-Geräte, Flash-Speicherkarten, USB-Sticks ebenfalls getestet werden - und der Test "Lesen + Schreiben + Lesen" kann effektiv verwendet werden, um Datenverlust durch den Effekt des "Vergessens" der Speicherzellen zu verhindern.

Die Tests können auch dann nützlich sein, wenn die Hardwaretests mit einem Fehler beendet werden, der nicht unterstützt wird oder zu dem keine Informationen verfügbar sind.

Hinweis: Die unregistrierte Version erlaubt das Starten von Tests nicht. Mit nicht registrierten Versionen können nur Sektorinhalte angezeigt werden.

Anmerkung: Während der Tests könnte Software und das im Hintergrund ausgeführte Betriebssystem die Leistung (also die resultierende Farbe) der einzelnen Blöcke beeinträchtigen. Um diesen Effekt zu minimieren, verhindert die Anwendung, dass ein Bildschirmschoner gestartet wird, dass der Computer in einen Standby- oder niedrigeren Energieverwaltungsmodus wechselt und eine höhere Priorität verwendet. Es wird jedoch empfohlen, alle anderen Hintergrundoperationen während des Tests zu schließen und den Test zu wiederholen, wenn die Leistungsminderung einen größeren Bereich betrifft (nicht nur 1-1 Blöcke). Die Software kann den Test wiederholen, um diesen vorübergehenden Leistungsabfall zu minimieren.

Anhalten, Fortsetzen, Neu Starten

Laufwerkstests auf Festplatten mit hoher Kapazität können lange dauern, manchmal 12 bis 24 Stunden oder sogar länger. Sollten Sie die Festplattentest jemals anhalten müssen, klicken Sie einfach innerhalb der Lauferksoberflächenkarte auf einen der weißen Blöcke (oder auf einen der bereits verarbeiteten grünen Blöcke), um das Fenster "Laufwerksinhalts-Inspektor" mit dem Rohinhalt des Sektors zu öffnen. Der Test hält an, während dieses Fenster angezeigt wird. Wenn Sie es schließen, wird der Test automatisch fortgesetzt.

Muss der Test abgebrochen werden, können Sie ihn später ab einem bestimmten Punkt neu starten: Wählen Sie den Menüpunkt Laufwerk -> Oberflächentest und den entsprechenden Testtyp. Wählen Sie jedoch vor dem Starten des Tests in diesem Fenster die Registerkarte Konfiguration. Es gibt eine Option namens Das Testen auf bestimmte Datenblöcke beschränken, bei der es möglich ist, den ersten und den letzten zu testenden Block zu konfigurieren. Um beispielsweise die letzten 25 % zu testen, geben Sie bei Erster Block = 7500 und bei Letzter Block = 9999 an.

Hard Disk Sentinel stellt einen zuvor gestarteten Test nicht automatisch wieder her und setzt ihn fort. Wenn der Test gestoppt wurde, konnte die Software nicht überprüfen (keine Kontrolle darüber haben), was genau mit dem Laufwerk passiert, nachdem der Test gestoppt wurde. In diesem Fall konnte sie keinen erfolgreichen Testbetrieb garantieren. Es ist möglich, vollständige Neustarts, Windows-/Systemaktualisierungen, sogar Änderungen an der Geräteverbindung (Hardware) usw. durchzuführen, was sich auf den gesamten Betrieb der Festplatte auswirken kann, sowie auf das Testergebnis.

Dies gilt insbesondere dann, wenn etwas Unerwünschtes/Unvorhergesehenes passiert (z. B. Stromausfall, Fehler bei der Stromversorgung oder Überspannung, wenn die Stromversorgung wieder hergestellt wird). Dies könnte sogar Schäden an einem Teil des Laufwerks (generell an jeder Hardware) verursachen. Selbst wenn Sie zuvor beispielsweise 92 % des Laufwerks getestet haben und dann fortfahren, können wir nicht wirklich sicher sein, dass alles zu 100 % perfekt ist.

In solchen Situationen kann der Benutzer überlegen, ob er den gesamten Test neu starten oder von einem bestimmten Punkt aus neu starten sollte, beispielsweise vom letzten bekannten getesteten Block.

Beispiele

Das Ende des nutzbaren Datenbereichs ist schlecht. Die schlechten Blöcke bilden durchgehende Bereiche, die ein ernstes Oberflächenproblem vermuten lassen. Beachten Sie den gelben beschädigten Block in der Nähe der unteren linken Ecke: Er ist der Nachbar eines fehlerhaften Blocks und wird bei späterer Verwendung wahrscheinlich schlecht. Auch nicht beschädigte Blöcke sind sehr langsam zugänglich. Es wird empfohlen, die Position des ersten problematischen Blocks mit dem Mauszeiger zu überprüfen und Partitionen zu erstellen, die den folgenden Bereich nicht verwenden.

Die Festplatte zeigte viele Probleme. Sie blieb während des Lese- und Schreibvorgangs stehen und war relativ schlecht (30 %). Es gab verschiedene schlechte, beschädigte und langsam zugängliche Blöcke.

Dieselbe Festplatte nach vielen Tests mittels "Laufwerkoberfläche neu initialisieren". Die schwachen Sektoren sind behoben und die fehlerhaften Sektoren werden neu zugewiesen (der Zustand ist auf 20 % gesunken), aber die Gesamtoberfläche wird verbessert und die Festplatte kann noch einige Zeit verwendet werden (wird jedoch wegen der Probleme nicht zum Speichern wichtiger Daten empfohlen).

Eine typische Festplatte mit niedrigem Gesundheitszustand (22 %). Viele Schreibtests (insbesondere der Test zur Reinitialisierung der Festplattenoberfläche) können den Status verbessern. Es wird jedoch nicht empfohlen, die erste Hälfte dieses Laufwerks zu verwenden (indem Partitionen nur in der zweiten Hälfte erstellt werden).


Anhang - Informationen

Anhang

Allgemeine Informationen zur S.M.A.R.T.-Technologie und Funktionen von Hard Disk Sentinel werden in den folgenden Kapiteln beschrieben:

  • Herstellerspezifische vs rohe S.M.A.R.T.-Werte

  • Zustandsberechnung

  • Leistungsberechnung

  • Betriebszeit/a>

  • Temperaturkalibrierung

  • Bekannte S.M.A.R.T.-Attribute


Herstellerspezifische vs rohe S.M.A.R.T.-Werte

Wie auf der Seite S.M.A.R.T. der Festplatten beschrieben, können Sie feststellen, dass die Auswertung von Attributen mithilfe der herstellerspezifischen Methode möglich ist (Überprüfung des Wertes und der schlechtesten Felder) oder unter Verwendung einer anderen, vom Hersteller unabhängigen Methode (Überprüfung des Datenfelds). Wie funktionieren diese beiden recht verschiedenen Methoden und was ist der Unterschied?

Herstellerspezifische Werte

Der aktuelle Status der Festplatte wird ständig von vielen Sensoren überprüft. Die gemessenen Rohwerte werden gespeichert (im Feld "Daten" des entsprechenden S.M.A.R.T.-Attributs), und von einem Algorithmus ausgewertet (kodiert intern in der Firmware der Festplatte).

Nach dieser Auswertung wird das herstellerspezifische Ergebnis für das Attribut im Feld Wert gespeichert. Es zeigt an wie "gut" das Attribut ist (verglichen mit der Zahl im Feld Schwellenwert. Ist die Festplatte neu (wurde noch nie verwendet), hat dieser Wert einen theoretischen Maximalwert und nimmt dann ab - bis er den Schwellenwert erreicht.

Somit ist ein Attribut perfekt, wenn folgende Ungleichung WAHR ist:

A - f(r) >= C

Wobei:

  • A - theoretischer Maximalwert, der "bestmögliche" Wert für das Attribut.

  • f - eine Funktion zum Berechnen des Verringerung basierend auf den Rohwerten (r) (Normalerweise ist es eine lineare Funktion, weshalb r mit einer B-Konstante multipliziert wird.)

  • C - der herstellerspezifische Schwellenwert (Unterhalb diesem Wert wird das Attribut als problematisch angesehen.)

Die Verwendung dieser Methode hat einige Nachteile. Die A-, B-, C-Werte (oder die f-Funktion) sind nicht genau definiert (diese können von Modell zu Modell variieren, selbst auf zwei Festplatten desselben Herstellers). Ein weiterer Nachteil ist, dass die Attribute unabhängig voneinander ausgewertet werden und die Beziehung zwischen ihnen ignoriert wird.

Im wirklichen Leben ist es möglich, nicht realistische Werte zu finden, die auf einen falschen Status der Festplatte hinweisen können. Einige Festplattenhersteller definieren vielleicht 60 bis 70 Jahre oder sogar mehr für eine Gesamtlebensdauer der Festplatte, wenn das entsprechende Attribut untersucht wird. Auch ist es möglich, dass viele Tausende fehlerhafter Sektoren benötigt werden, bis sich die Festplatte als problematisch herausstellt, wenn die obige Methode verwendet wird. Natürlich können viele Probleme lange vor Erreichen dieses Schwellenwerts auftreten. Das Untersuchen und Neuzuweisen von Daten aus Sektoren in einem fehlerhaften (beschädigten) Datenbereich kann beispielsweise viel Zeit (sogar Stunden) in Anspruch nehmen - und womöglich nicht ohne Probleme abgeschlossen werden. Während dieses Vorgangs reagiert das System normalerweise nicht. Daher kann eine problematische Festplatte, die immer wieder Probleme verursacht, die Stabilität des Gesamtsystems erheblich verringern.

Die meisten Anwendungen zur Festplattenanalyse verwenden die oben beschriebene Methode, um den Status des Festplattenzustands zu bestimmen. In vielen Fällen ist der angezeigte Festplattenstatus aufgrund der moderaten Schwellenwerte viel besser als der Tatsächliche. Einige Hersteller ändern vielleicht auch die Werte, um den Gesundheitszustand ihres Laufwerks besser anzuzeigen als andere. Dies kann einige Anwendungen oder die Benutzer irreführen.

Es ist wichtig, dass nach Erreichen des Schwellenwerts eines S.M.A.R.T.-Attributs, die Festplatte 24 Stunden lang ausgeführt werden sollte (um eine mögliche Sicherung auszuführen). In den meisten Fällen reicht dies nicht aus, und während dieser Zeit können nur Teildaten gespeichert werden. Das Speichern von Daten einer problematischen, fast toten Festplatte kann sehr schmerzhaft, langwierig und aufwendig sein. Besser ist es, das Problem lange vor einer katastrophalen Situation zu identifizieren und sich darauf vorzubereiten.

Rohwerte analysieren

Hard Disk Sentinel wurde entwickelt, um diese Situation zu überwinden. Die Standardauswertungsmethoden überprüfen die Rohwerte des S.M.A.R.T.-Attributs. Hiermit ist es möglich, den Festplattenzustand unabhängig von den Herstellern und Modellen zu bestimmen. Hinweis: In der Bedingungsberechnung kann eine herstellerspezifische Bewertungsmethode ausgewählt werden. Die ständige Verwendung dieser Methode wird jedoch nicht empfohlen (aufgrund der oben beschriebenen Probleme), da dies zu falschen Ergebnissen führen kann.

Bei der Auswertung von Rohwerten gibt es keinen vordefinierten (herstellerspezifischen) Schwellenwert für die Attribute. Zunehmende Probleme verringern jedoch den Festplattenzustand (ständig und drastisch) und dies sagt den möglichen Ausfall und Datenverlust voraus.

Die ausführliche Erläuterung der Berechnungsmethoden finden Sie hier.


Zustandsberechnung

In den Erweiterten Optionen können viele verschiedene Ermittlungsmethoden für den Zustand ausgewählt werden. Hier finden Sie die Unterschiede zwischen diesen Bewertungsmethoden:

Analyse-Datenfeld

Ist diese Option ausgewählt, werden die rohen, gemessenen Zahlen (angezeigt in der Spalte Daten für die entsprechenden S.M.A.R.T.-Attribute) verwendet, um die Integrität der Festplatte zu bestimmen. Bei der Entwicklung der Ermittlungsmethoden waren folgende Aspekte wichtig:

  • Es sollte den tatsächlichen Status widerspiegeln und nicht von der Zeit oder früheren Werten abhängen. Bestimmen Sie das Ergebnis ohne langwierige Analyse- oder Testmethoden.

  • Es sollte nicht mit der Zeit zunehmen - nicht den Gesundheitszustand nach einiger Zeit besser anzeigen (außer, wenn einige ausstehende Sektoren erfolgreich getestet wurden und sie verwendet werden können, weil sie keine Probleme vorweisen).

  • Es sollte kleine Veränderungen und Verschlechterungen widerspiegeln. Eine ständig steigende Anzahl von Problemen sollte das Ergebnis ständig verringern.

  • Es sollte die Beziehung zwischen Attributen zählen. Mehrere unterschiedliche Probleme sollten eher als nur ein einziges problematisches Attribut das Ergebnis drastisch verringern.

  • Das Ergebnis sollte für zwei (oder mehr) Festplatten mit denselben Problemen gleich sein, auch wenn die Festplatten von verschiedenen Modellen und Herstellern stammen.

  • Das Ergebnis sollte in einigen Situationen kontrolliert werden. Beispielsweise sollten nach dem Ersetzen eines problematischen Netzteils die zuvor aufgetretenen Probleme ignoriert werden. Auch ein falscher Sensor sollte ignoriert oder sein Wert geändert werden (siehe dazu Temperaturkalibrierung).

Die Festplatte befindet sich anfangs in einem 100 %-Zustand. Alle kritischen gesundheitsbezogenen S.M.A.R.T.-Parameter (falls verfügbar, hängt vom Hersteller ab) verringern diesen Wert. Diese Attribute haben ein vordefiniertes Gewicht und einen maximalen Grenzwert (Letzterer definiert die maximale Verschlechterung des Integritätswerts für das Attribut). Der prozentuale Gesamtgesundheitswert wird durch Multiplikation der verbleibenden prozentualen Werte (100 - Verschlechterung in %) berechnet.

Derzeit verfügt Hard Disk Sentinel über zwei unterschiedliche Methoden. Bei Verwendung der Standardmethode sind die Gewichte und Grenzwerte (siehe unten) geringer. Wenn die Option strenger, empfohlen für Server verwendet wird, sind die Werte viel schärfer, die Probleme können den Zustand drastisch beeinträchtigen.

Die folgenden Tabellen enthalten die gesundheitsbezogenen (kritischen) S.M.A.R.T.-Attribute, die den Gesundheitswert mit ihren Gewichten und Höchstgrenzen beeinflussen:

Gewichte und Grenzwerte für die Standard-Berechnungsmethode:

S.M.A.R.T.-Attribut | Gewicht | Grenzwerte %
Reallocated sectors count | 1 | 70
Seek error rate | 0.5 | 20
Spin retry count | 3 | 60
Reallocation event count | 0.6 | 30
Current pending sectors count | 0.6 | 48
Off line uncorrectable sectors count | 1 | 70

Gewichte und Grenzwerte für die striktere Berechnungsmethode:

S.M.A.R.T.-Attribut | Gewicht | Grenzwerte %
Reallocated sectors count | 6 | 60
Seek error rate | 2 | 20
Spin retry count | 6 | 40
Reallocation event count | 4 | 30
Current pending sectors count | 4 | 30
Off line uncorrectable sectors count | 6 | 60

Ermittelt werden die Zahlen durch Prüfung der eingetroffenen Berichte und des S.M.A.R.T.-Status der (unbrauchbaren) Festplatten, die zur Datenwiederherstellung empfangen wurden.

Anmerkung: Die Spalte Daten enthält hexadezimale Werte. Diese sollten vor der Berechnung in Dezimalzahlen umgewandelt werden. Die unteren 16 Bits (höchstens 4 Stellen) werden bei der Berechnungsmethode verwendet.

Beispiel: Wird die Berechnungsmethode Standard verwendet und das Attribut "Reallocated sectors count" enthält in der Spalte "Daten" 0002, ist der Integritätswert = 100 x (100 - 2x1)% = 98%

Enthält das Attribut "Current pending sectors count" zudem den Wert 0005 in der Spalte "Daten" auf derselben Festplatte, beträgt der Zustand = 98 x (100 - 5x0,6)% = 95%. Die strengere Berechnungsmethode ergibt 100 x (100 - 2x6)% x (100 - 5x4)% = 70% als resultierenden Gesundheitswert.

Das Limit % definiert, um wie viel % das Attribut den Gesamtgesundheitswert verringern kann. Wenn beispielsweise das Attribut "Off line uncorrectable sectors" 0200 in der Spalte "Daten" enthält (bei Konvertierung in einen Dezimalwert 512), sollte der Gesundheit um 512 x 1 = 512% fallen, die Grenze für dieses Attribut ist jedoch nur 70%. In anderen Worten, wenn der Wert für "Off line uncorrectable sectors" derart hoch ist, kann der Integritätswert der Festplatte nicht größer als 30% sein. Andere Probleme können den Gesundheitswert weiter verringern.

Herstellerspezifische Werte analysieren

Ist diese Option ausgewählt, werden die gesundheitsbezogenen S.M.A.R.T. Attribute erhöht. Alle diese Attribute haben einen kleinen Bedingungswert, berechnet zwischen 0 und 100% basierend auf dem tatsächlichen Wert, Schwellenwert und theoretischer Maximalwert (letzterer von Hard Disk Sentinel bestimmt basierend auf Hersteller und Modell). Das Multiplizieren dieser Werte ergibt den Gesamtwert des Festplattenzustands.

Beispiel: Der Schwellenwert für "Reallocated sectors count" ist 36, der Wert ist 84 und der Anfangswert für dieses Attribut war 100. Der Bedingungswert für dieses Attribut ist: (1 - (100-84)/(100-36)) x 100 = 75%. Wenn (auf derselben Festplatte) der Schwellenwert für die "Seek error rate" 30 beträgt, der Wert 60 und der Anfangswert 90 beträgt, lautet die Bedingung dieses Attributs 50% und der Gesamtzustand der Festplatte 37,5 %.

Anmerkung: 1.40 und frühere Versionen von Hard Disk Sentinel verwendeten nur die strengere, für Server empfohlene Berechnungsmethode. Ein Upgrade von Version 1.40 oder älter kann zu einer anderen Anzeige des Integritätswerts führen. Auf der Seite Erweiterte Optionen kann die Berechnungsmethode jederzeit geändert werden.

Anmerkung: Die ausgewählte Berechnungsmethode wird in den Berichten gespeichert, um Verwirrung zu vermeiden.

Anmerkung: Normalerweise folgen die verschiedenen Gesundheitswerte der Formel:

Herstellerspezifisch >= Standard >= Strenger

Durch die Verwendung der "strengeren" Methode verringert sich der Integritätswert bei kleinen Problemen drastisch. Daher wird die Anwendung dieser Methode nur dann empfohlen, wenn kein (auch nur das Kleinste) Problem zulässig ist.

SSD-Zustand

Speicherzellen in "Solid State"-Geräten (üblicherweise Flash-Speicher) können nur eine begrenzte Anzahl von Überschreibungsdurchläufen tolerieren, sodass während des normalen Gebrauchs "Verschleiß" auftritt.

Die Funktion "Verschleißausgleich" der SSD versucht, diesen Effekt zu verbergen/minimieren kann es aber normalerweise nicht beseitigen. In der Regel behält das SSD-Gerät den Gesamtzustand der Speicherzellen bei und liefert diese Informationen durch verschiedene Attribute.

Wurden keine Probleme gefunden, liest Hard Disk Sentinel solche Attribute zur Bestimmung des vollständigen Zustands des "Solid State"-Geräts aus und zeigt in der Textausgabe folgendes an: Der Zustand wird durch SSD-spezifische S.M.A.R.T.-Attribute ermittelt:

Solche Attribute können #177 Wear Leveling Count, #231 SSD Life Left, #233 Media Wearout Indicator, Percentage Used, Remaining Drive Life oder ähnliches sein. Auf der S.M.A.R.T.-Seite ist es möglich, den aktuellen Wert zu überprüfen und auch mit der Zeit zu ändern.

Solche Werte (und damit der Zustand) werden von der SSD berechnet, unabhängig von irgendeiner Software, basierend auf der tatsächlichen Nutzung (Menge der geschriebenen Daten, Einschaltzeit und so weiter). Versuchen Sie, die auf Ihre SSD geschriebene Datenmenge zu minimieren, um den Gesundheitszustand hoch zu halten.


Leistungsberechnung

Der Leistungswert der Festplatte kann auf verschiedene Art und Weise berechnet werden (wie der Zustandswert (Integrität)). Die Option für die Berechnungsmethode im Feld Erweiterte Optionen definiert die Methode, mit der auch der Leistungswert berechnet wird.

Datenfeld analysieren

Hard Disk Sentinel kombiniert verschiedene Werte, um diesen Wert zu bestimmen. Die Rohwerte der leistungsbezogenen S.M.A.R.T.-Attribute (Z. B. die Suchzeit) wirken sich um maximal 25 % auf die Gesamtleistung aus. Die Anzahl der im letzten Monat festgestellten Datenübertragungsfehler (Ultra-ATA-CRC-Fehler) kann den Leistungswert ebenfalls um 25 % verringern. Diese Übertragungsfehler weisen nicht wirklich auf das Problem der Festplatte hin, können jedoch die Stabilität und Leistung des Systems beeinträchtigen.

Die restlichen 50 % des Leistungswerts werden berechnet, indem der aktuell verwendete DMA-Übertragungsmodus und der maximal verfügbare Übertragungsmodus untersucht werden. Wenn die Festplatte nur im PIO-Modus (programmierte I/O) funktioniert, ist dieser Teil des Bedingungswerts 0 anstelle von 50.

Beispiel: Wenn die Übertragungsrate nur Ultra-DMA-Modus 2 (33 MB/s) anstelle der maximal verfügbaren Übertragungsrate Ultra-DMA-Modus 5 (100 MB/s) ist, das leistungsbezogenen S.M.A.R.T.-Attribute aber korrekt sind und im letzten Monat keine Datenübertragungsfehler gefunden wurden. Der Gesamtleistungswert beträgt 25 + 25 + (2/5) x 50 = 70%. In diesem Beispiel wird das Problem wahrscheinlich durch die Verwendung eines alten IDE-Kabels mit nur 40 Drähten verursacht.

Herstellerspezifische Werte analysieren

Wurde diese Option ausgewählt, werden die leistungsbezogene S.M.A.R.T.-Attribute ausgewertet. All diese Attribute haben einen Wert, der zwischen 0 und 100 % basierend auf dem tatsächlichen Wert, dem Schwellenwert und dem theoretischen Maximalwert berechnet wird (Letzterer wird von Hard Disk Sentinel basierend auf Hersteller und Modell bestimmt). Das Multiplizieren dieser Werte ergibt den Gesamtleistungswert des Festplattenzustands.


Betriebszeit, verbleibende Lebensdauer

Die Einschaltzeit der Festplatte kann durch der Nr. 9 "Anzahl der Einschaltzeiten" der S.M.A.R.T.-Attribute der Festplatte untersucht werden. Dieser Wert wird von den meisten modernen IDE- und S-ATA-Festplatten unterstützt.

Der Rohwert dieses Attributs steigt ständig an, währen die Festplatte unter Strom steht (ausgeführt wird, jedoch nicht unbedingt eine Lese- oder Schreiboperation verrichtet). Die Zeiteinheit hängt vom Hersteller ab. Dies können Stunden (der Wert wird einmal pro Stunde erhöht), Minuten oder halbe Minuten sein. Es sind auch verschiedene weitere Einheiten möglich, und zwei Festplatten desselben Herstellers nutzen womöglich nicht die gleichen Zeiteinheiten.

Nach der Installation beginnt Hard Disk Sentinel mit der Prüfung dieses Attributs. Er überprüft die verstrichene Zeit zwischen zwei aufeinanderfolgenden Erhöhungen des Rohwerts dieses Attributs. Während dieses Tests wird ein Schaltzeitwert (mit grauer Farbe) angezeigt, der möglicherweise nicht genau ist. Dieser Test kann bis zu 20 Minuten dauern. Wenn der Benutzer die Anwendung während des Tests schließt, wird sie beim nächsten Start von Hard Disk Sentinel automatisch neu gestartet, bis die auf allen Festplatten verwendete Zeiteinheit ermittelt werden konnte. Nach erfolgreicher Messung wird der Wert gespeichert und später automatisch verwendet. Diese Messung hat keinen Einfluss auf die Leistung der Festplatte oder des Computers.

Nach der Messung (oder, wenn eine solche nicht erforderlich ist) wird der genaue, korrekte Schaltzeitwert (mit schwarzer Farbe) angezeigt und der Text "Schätzwert" ist nicht mehr zu sehen. Wenn der angezeigte Wert falsch zu sein scheint (zu niedrig oder zu hoch), kann die Schaltfläche "Test wiederholen" verwendet werden.

Nach Abschluss der Messung wird empfohlen, einen Testbericht zu versenden. Die erhaltenen Berichte helfen bei der Weiterentwicklung und es ist möglich, dass in einer späteren Version schon beim ersten Mal eine genaue Einschaltzeit angezeigt wird (ohne dass eine Messung erforderlich wäre).

Der neben Betriebszeit angezeigte Wert gibt die Gesamtzeit an, in der das Laufwerk lief (eingeschaltet war). Die Leerlaufzeit (wenn keine Lese- oder Schreiboperation durchgeführt wurde) erhöht diesen Wert ebenfalls, die Standby-Zeit erhöht diese Zeit jedoch nicht. Ein angezeigter Tag bedeutet 24 Stunden. Beispielsweise zeigt eine zwei Jahre alte Festplatte, die täglich 12 Stunden verwendet wird, dieselbe "Betriebszeit" wie eine einjährige Festplatte, die im 24/7-Modus verwendet wird (wie eine drei Jahre alte Festplatte, die 8 Stunden pro Tag arbeitet).

Hinweis: Bei einigen Modellen ist die Anzeige der Einschaltzeit eventuell nicht korrekt.

Geschätzte verbleibende Lebensdauer

Datenfeld analysieren

Wenn die Option "Datenfeld analysieren" als Methode zur Zustandsberechnung auf der Seite Erweiterte Optionen ausgewählt ist, wird die verbleibende Lebensdauer durch folgende Methode ermittelt:

  • Standardmäßig ist die erwartete Gesamtlebensdauer einer Festplatte in einwandfreiem Zustand mit 5 Jahren definiert (läuft jeden Tag und jede Nacht an allen Tagen). Dies entspricht 1825 Tagen im 24/7-Modus oder 43800 Stunden.

  • Die verstrichene Betriebszeit verringert diesen Wert.

  • Das Ergebnis wird entsprechend der Anzahl der Tage verringert, an denen die Temperatur zu hoch war. Wenn die maximale (Spitzen-) Temperatur hoch war, ist dies nicht unbedingt kritisch, war aber die durchschnittliche Temperatur zu hoch (dies bedeutet, dass die Temperatur für längere Zeit hoch war), wird das Ergebnis drastisch reduziert.

  • Das Ergebnis wird mit dem Quadrat des Integritätswerts der Festplatte multipliziert.

Hinweis: Hard Disk Sentinel zeigt 1.000 Tage als Maximalwert für die geschätzte verbleibende Lebensdauer an. Unter idealen Bedingungen wird dieser Wert natürlich auch nach Hunderten von Tagen nicht abnehmen.

Beispiel: Die Festplatte arbeitet seit 600 Tagen (600 x 24 Stunden) und ihre Temperatur war nicht zu hoch (es gab keinen Tag mit zu hoher Durchschnittstemperatur) und der Zustand beträgt 70%. Die verbleibende Gesamtlebensdauer beträgt 1225 x 0,7 x 0,7 = 600 Tage und 6 Stunden.

Wie Sie sehen, bestimmt der Zustandswert drastisch die geschätzte verbleibende Lebensdauer der Festplatte. Wenn dieser Integritätswert niedrig ist, bleibt die Anzeige der verbleibenden Lebensdauer viele Tage lang unverändert, selbst wenn sich der Wert für die Betriebszeit erhöht. Beträgt der Zustandswert für eine Festplatte beispielsweise 25 %, werden 16 Tage benötigt (vorausgesetzt, die Festplatte arbeitet 24 Stunden täglich), um die verbleibende Lebensdauer um einen einzigen Tag zu verkürzen (da 16 x 0,25 x 0,25 = 1).

Anmerkung: Die geschätzte verbleibende Lebensdauer hängt von vielen Faktoren (Temperatur, Zustand) ab. Es wird daher empfohlen, die Schritte der Temperaturkalibrierung durchzuführen und die richtige Methode zur Zustandsberechnung auszuwählen basierend auf der tatsächlichen Situation und unter Verwendung der korrekten Offset-Werte für S.M.A.R.T.-Attribute, falls erforderlich. Nur fortgeschrittene Benutzer sollten diese Optionen verwenden und ändern, da eine falsche Kombination von Einstellungen zu einer fehlerhaften Anzeige einiger Werte führen kann.

Herstellerspezifische Werte analysieren

Wird die Einstellung "Herstellerspezifische Werte analysieren" verwendet, wird die geschätzte Lebensdauer durch den Schwellenwert bestimmt, der das Datum der Überschreitung des kritischen S.M.A.R.T. Attributs, das seinen Schwellenwert vor jedem anderen kritischen S.M.A.R.T.-Attribut der Festplatte erreicht. Solche Datumswerte der Überschreitung des Schwellenwertes werden auf der S.M.A.R.T.-Attributdiagramm einer Festplatte dargestellt (wenn neben dem Diagramm die Option "Herstellerspezifische Werte anzeigen" ausgewählt ist).

Hinweis: Diese Methode ist nur dann zuverlässig, wenn Hard Disk Sentinel die Festplatten über einen sehr langen Zeitraum (dies kann Wochen oder sogar Monate dauern) ständig analysiert. In anderen Fällen ist die Vorhersage falscher Ergebnisse durch eine geringfügige Verschlechterung der Attribute möglich(der Schwellenwert würde beispielsweise das Datum im Januar 2100 überschreiten. Dies ist natürlich nicht real, aber solche Werte können in anderen Anwendungen zur Festplattenüberwachung auftreten). Um diese Situation zu vermeiden, zeigt Hard Disk Sentinel 1.000 Tage als Maximalwert für die geschätzte verbleibende Lebensdauer an. In einer idealen Situation wird dieser Wert natürlich auch nach Hunderten von Tagen nicht abnehmen.


Temperaturkalibrierung

Der in den meisten modernen Festplatten integrierte Temperatursensor kann zu falschen Ergebnissen führen. Die Differenz zwischen der gemessenen und der tatsächlichen Temperatur kann 7-9 Grad Celsius oder sogar mehr betragen.

Um dieses Problem zu beheben, ist es möglich (und empfohlen), die tatsächliche Temperatur der Festplatte mit einem externen Infrarot-Thermometer oder einer Frontplatte mit Temperatursensor zu messen und die Differenz zwischen der gemessenen Temperatur und der von Hard Disk Sentinel angezeigten Temperatur einzustellen (vom Laufwerk selbst gemeldet) als Temperaturversatz. Dies wird Kalibrierung genannt.

Nachdem die tatsächliche Temperatur gemessen wurde (mit dem Thermometer oder einem anderen externen Temperatursensor), kann der Versatz berechnet werden, indem der von der Software gemeldete Wert vom gemessenen Wert abgezogen wird. Dieser Versatz kann positiv (die Software meldet eine niedrigere Temperatur als die reale Temperatur) oder negativ (sie meldet eine höhere Temperatur als die reale Temperatur) sein.

Dieser Versatz kann auf der S.M.A.R.T.-Seite der Festplatte nach Auswahl des Attributs Nr. 194 (Disk temperature) und Verwendung der Tasten +/- (durch Klicken auf die Zahl zwischen den Symbolen kann der Versatzwert (Offset) direkt in der Einheiten Celsius eingegeben werden).

S.M.A.R.T.-Attribute, Details und Trends

Hard Disk Sentinel erhöht (oder verringert) automatisch alle von der Festplatte gemeldeten Temperaturen um den konfigurierten Offset-Wert. Auf diese Weise wird in allen Fällen die richtige (reale) Temperatur angezeigt und verwendet (z. B. beim Überprüfen der Festplattentemperatur anhand eines Schwellenwerts und beim Speichern von Berichten usw.).

Es wird empfohlen, die Temperaturkalibrierung nach Möglichkeit auf allen installierten Festplatten durchzuführen. Für den gleichen Festplattentyp sind möglicherweise unterschiedliche Temperatur-Offsets erforderlich.

Hinweis: Ist keine Kalibrierung möglich (das Computergehäuse kann nicht geöffnet werden), kann ein geschätzter Versatzwert ermittelt werden, indem die erste angezeigte Temperatur unmittelbar nach dem Starten des Computers überprüft und der Wert mit der Umgebungstemperatur (Raum, Büro) verglichen wird. Zu diesem Zeitpunkt sind die CPU, die Grafikkarte oder andere Komponenten nicht allzu warm und beeinflussen die Temperatur der Festplatte nicht. Dies gilt natürlich nur dann, wenn der Computer genügend Zeit hatte, um sich auf die Umgebungstemperatur abzukühlen (er wurde mindestens 8 Stunden lang nicht ausgeschaltet).

Wenn beispielsweise die Festplattentemperatur mit 17 Grad Celsius angezeigt wird (unmittelbar nach dem Starten des Computers) und die Raumtemperatur 22 Grad Celsius beträgt, kann +5 als Versatzwert konfiguriert werden (da die Festplatte nicht kühler als ihre Temperatur sein kann). Dieser Versatz ist besser als nichts, aber natürlich wird ein externes Thermometer benötigt, um den korrekten Temperaturversatzwert zu bestimmen.

Hinweis: Das Temperatur-Offset sollte unabhängig von der ausgewählten Temperatureinheit (Celsius oder Fahrenheit) in Celsius angegeben werden.

Anmerkung: Die nicht registrierte Version setzt automatisch alle Offset-Werte auf 0 zurück, wenn der Benutzer Hard Disk Sentinel neu startet.


S.M.A.R.T.-Attribute

S.M.A.R.T.-Attributliste (ATA)

Dies ist die Liste aller bekannten Attribute, die von IDE- und Serial-ATA-Festplatten unterstützt werden. Hinweis: Einige Hersteller verwenden die Attribute durchaus auch für unterschiedliche Zwecke. Hier nicht aufgeführte Attribute sind "herstellerspezifische" Attribute (ihr Zweck ist nicht bekannt).

1 | Raw Read Error Rate | Beim Lesen der Rohdaten von einer Festplatte sind Fehler aufgetreten. Zeigt ein Problem mit der Festplattenoberfläche oder den Lese-/Schreibköpfen an. Kritisches Attribut
2 | Throughput Performance | Allgemeine Durchsatzleistung der Festplatte Problem mit Motor, Servo oder Lagern anzeigen.
3 | Spin Up Time | Zeit, die die Spindel benötigt, um auf volle Drehzahl hochzufahren. Problem mit Motor oder Lagern anzeigen. Kritisches Attribut
4 | Start/Stopp Count | Anzahl der Start/Stopp-Zyklen der Spindel Dieser Wert wirkt sich nicht direkt auf den Zustand des Antriebs aus.
5 | Reallocated Sector Count (Reallocated Sectors Count) | Anzahl der Sektoren, die in den freien Bereich verschoben wurden Zeigt ein Problem mit der Plattenoberfläche oder den Lese-/Schreibköpfen an. Kritisches Attribut
6 | Read Channel Margin | Rand eines Kanals beim Lesen von Daten Die genaue Funktion dieses Attributs ist nicht angegeben.
7 | Seek Error Rate | Rate der Positionierungsfehler der Lese-/Schreibköpfe Problem mit Servo, Kopf anzeigen. Hohe Temperaturen können dieses Problem ebenfalls verursachen. Kritisches Attribut
8 | Seek Time Performance | Durchschnittliche Suchzeit der Köpfe Problem mit Servo anzeigen. Kritisches Attribut
9 | Power-On Time Count | Gesamtzeit, in der das Laufwerk eingeschaltet ist Die Maßeinheit hängt vom Hersteller ab.
10 | Spin Retry Count | Wiederholungszahl der Schleuderstartversuche Deutet Problem mit Motor, Lagern oder Stromversorgung an. Kritisches Attribut
11 | Drive Calibration Retry Count | Anzahl der Versuche, ein Laufwerk zu kalibrieren Zeigt ein Problem mit Motor, Lagern oder Netzteil an.
12 | Drive Power Cycle Count | Anzahl der vollständigen Ein-/Ausschaltzyklen Dieser Wert wirkt sich nicht direkt auf den Zustand des Laufwerks aus.
13 | Soft Read Error Rate | Anzahl der Software-Lesefehler Die Anzahl der nicht korrigierbaren Lesefehler.
184 | End-to-End error | Anzahl der Paritätsfehler während der Übertragung zwischen dem RAM-Cache und dem Host.
187 | Reported Uncorrectable Errors | Fehler, die mit Hardwarefehlerkorrekturmethoden nicht behoben werden konnten.
188 | Command Time-out | Anzahl der aufgrund eines Festplatten-Time-outs abgebrochenen Vorgänge. Ein Wert größer als Null kann auf Probleme mit der Stromversorgung oder der Datenkabelverbindung hinweisen.
189 | High Fly Writes | Anzahl unsicherer Schreibvorgänge außerhalb des normalen Kopfflugbereichs.
190 | Airflow Temperature | Luftstromtemperatur Die Lufttemperatur im Festplattengehäuse.
191 | Mechanical Shock | Anzahl der durch mechanischen Stoß verursachten Probleme Beschleunigung (z. B. Herunterfallen) kann mechanischen Stoß verursachen.
192 | Power off Retract Cycle | Anzahl der Ausschaltzyklen Dieser Wert wirkt sich nicht direkt auf den Zustand des Laufwerks aus.
193 | Load/Unload Cycle Count | Anzahl der Lade-/Entladezyklen Anzahl der Zyklen, in denen sich der Kopf in die Landezonenposition bewegt hat.
194 | HDD Temperature | Festplattentemperatur Die Temperatur im Festplattengehäuse.
195 | Hardware ECC Recovered | Anzahl der korrigierbaren Fehler Anzahl der durch den internen Fehlerkorrekturmechanismus korrigierten Fehler.
196 | Reallocation Event Count | Anzahl der Sektor-Remap-Operationen Anzahl aller (erfolgreichen und fehlgeschlagenen) Remap-Operationen. Kritisches Attribut
197 | Current Pending Sector Count | Anzahl instabiler Sektoren Diese ausstehenden Sektoren können dem Ersatzbereich neu zugeordnet werden. Kritisches Attribut
198 | Off-Line Uncorrectable Sector Count | Anzahl nicht korrigierbarer Fehler beim Lesen/Schreiben Zeigt ein Problem mit der Plattenoberfläche oder den Lese-/Schreibköpfen an. Kritisches Attribut
199 | Ultra ATA CRC Error Count | Anzahl der Fehler während der Datenübertragung zwischen Festplatte und Host Zeigt ein Problem mit der Stromversorgung oder dem Datenkabel an.
200 | Write Error Rate | Beim Schreiben von Rohdaten von einer Festplatte sind Fehler aufgetreten. Deutet ein Problem mit der Festplattenoberfläche oder den Lese-/Schreibköpfen an.
201 | Soft Read Error Rate | Anzahl der Software-Lesefehler Die Anzahl der nicht korrigierbaren Lesefehler.
202 | Data Address Mark Errors | Anzahl der Fehler bei der Adressierung von Daten Anzahl der falschen oder ungültigen Adressmarken.
203 | Run Out Cancel | Anzahl der Datenkorrekturfehler Bei der Fehlerkorrektur wurde eine ungültige Fehlerkorrekturprüfsumme gefunden.
204 | Soft ECC Correction | Anzahl der korrigierten Datenfehler Fehler, die durch den internen Fehlerkorrekturmechanismus korrigiert wurden.
205 | Thermal Asperity Rate | Anzahl der thermischen Probleme Gesamtzahl der Probleme, die durch hohe Temperaturen verursacht werden.
206 | Flying Height | Kopfflughöhe Die Höhe der Plattenköpfe über der Plattenoberfläche.
207 | Spin High Current | Aktueller Wert während des Hochfahrens Die Drehzahl, die zum Hochfahren des Laufwerks benötigt wird.
208 | Spin Buzz | Anzahl der zum Hochfahren erforderlichen Zyklen Die Anzahl der Wiederholungen während des Hochfahrens aufgrund des geringen verfügbaren Stroms.
209 | Offline Seek Performance | Laufwerksleistung während Offline-Vorgängen Die Suchleistung des Laufwerks während interner Selbsttests.
211 | Vibration During Write | Während des Schreibvorgangs auftretende Vibrationen.
212 | Shock During Write | Während des Schreibvorgangs aufgetretene Erschütterung.
220 | Disk Shift | Der Abstand der Scheibe hat sich relativ zur Spindel verschoben. Ein falsches Durchdrehen der Scheibe kann durch mechanischen Schlag oder hohe Temperatur verursacht werden.
221 | G-Sense Error Rate | Anzahl mechanischer Fehler Anzahl Fehler aufgrund von Stößen oder Vibrationen.
222 | Loaded Hours | Anzahl der eingeschalteten Stunden Dieser Wert steigt ständig an (einmal pro Stunde).
223 | Load/Unload Retry Count | Anzahl der Lade-/Entladevorgänge Die Anzahl der Ein-/Austritte der Laufwerkköpfe in die Datenzone
224 | Load Friction | Mechanische Reibungsrate Die Reibungsrate zwischen mechanischen Teilen. Zeigt ein Problem mit dem mechanischen Subsystem des Laufwerks an.
226 | Load-in Time | Gesamtzeit, in der die Köpfe geladen werden Die Zeit, in der sich die Lese-/Schreibköpfe in der Datenzone befinden.
227 | Torque Amplification Count | Drehmomentanstiegsrate Drehmomentanstieg während des Hochlaufvorgangs der Festplatte.
228 | Power-off Retract Count | Anzahl der Ausschaltzyklen Die Häufigkeit, mit der der Kopf infolge eines Stromausfalls zurückgezogen wurde.
230 | GMR Head Amplitude | Amplitude der Kopfpositionierung Kopfbewegungsabstände zwischen Operationen.
231 | Hard Disk Temperature | Festplattentemperatur Die Temperatur im Festplattengehäuse.
240 | Head Flying Hours | Anzahl der Kopfpositionierungsstunden Zeitaufwand für die Positionierung der Laufwerkköpfe.
250 | Read Error Retry Rate | Anzahl der Wiederholungsversuche während Lesevorgängen Anzahl der Fehler, die beim Lesen eines Sektors von der Plattenoberfläche gefunden wurden.
254 | Free Fall Event Count | Anzahl der vom Beschleunigungssensor erkannten Ereignisse im freien Fall

S.M.A.R.T.-Attributliste (SCSI)

Dies ist die Liste aller bekannten Attribute, die von SCSI-Festplatten unterstützt werden. Hinweis: Einige Hersteller verwenden die Attribute möglicherweise auch für unterschiedliche Zwecke. Hier nicht aufgeführte Attribute sind "herstellerspezifische" Attribute (ihr Zweck ist nicht bekannt).

01 | Anzahl Pufferüber-/unterläufe
02_0000 | Schreibfehler, die ohne wesentliche Verzögerung korrigiert wurden
02_0001 | Schreibfehler, die mit möglichen Verzögerungen korrigiert wurden
02_0002 | Schreibfehler insgesamt
02_0003 | Schreibfehler insgesamt korrigiert
02_0004 | Durch Algorithmus korrigierte Schreibfehler insgesam
02_0005 | Insgesamt geschriebene Bytes
02_0006 | Insgesamt nicht korrigierte Schreibfehler
03_0000 | Lesefehler, die durch die ECC-Hardwaremethode korrigiert wurden
03_0001 | Lesefehler, die mit möglichen Verzögerungen korrigiert wurden
03_0002 | Lesefehler insgesamt
03_0003 | Korrigierte Lesefehler insgesamt
03_0004 | Gesamtzahl der durch Algorithmus korrigierten Lesefehler
03_0005 | Insgesamt gelesene Bytes
03_0006 | Insgesamt nicht korrigierte Lesefehler
04_0000 | Durch die ECC-Hardwaremethode korrigierten Leseumkehrfehler
04_0001 | Leseumkehrfehler, die mit möglichen Verzögerungen korrigiert wurden
04_0002 | Leseumkehrfehler insgesamt
04_0003 | Korrigierte Leseumkehrfehler insgesamt
04_0004 | Durch Algorithmus korrigierten Leseumkehrfehler insgesamt
04_0005 | Gelesene Bytes insgesamt
04_0006 | Nicht korrigierte Leseumkehrfehler insgesamt
05_0000 | Überprüfungsfehler, die ohne wesentliche Verzögerung korrigiert wurden
05_0001 | Überprüfungsfehler, die mit möglichen Verzögerungen korrigiert wurden
05_0002 | Überprüfungsfehler insgesamt
05_0003 | Korrigierte Überprüfungsfehler insgesamt
05_0004 | Durch Algorithmus korrigierte Überprüfungsfehler insgesamt
05_0005 | Verifizierte Bytes insgesamt
05_0006 | Nicht korrigierte Überprüfungsfehler insgesamt
06_0000 | Nicht mittlere Fehler
07 | Letztes Fehlerereignis
0B | Letzter verzögerter Fehler oder asynchrones Ereignis
0D_0000 | Temperatur
0D_0001 | Referenztemperatur
0E_0001 | Herstellungsdatum (Jahr/Woche)
0E_0002 | Berechnungsdatum
0E_0003 | Angegebene Zyklusanzahl über die Lebensdauer des Geräts
0E_0004 | Akkumulierte Start-Stopp-Zyklen
0F | Parameterdaten des Anwendungsclients
10 | Selbsttestergebnisprotokoll
18 | Protokollspezifisches Portprotokoll
37_0000 | An den Initiator gesendete Blöcke
37_0001 | Vom Initiator empfangene Blöcke
37_0002 | Aus dem Cache gelesene und an den Initiator gesendete Blöcke
37_0003 | I/O-Befehle mit einer Größe, die kleiner als die Segmentgröße ist
37_0004 | I/O-Befehle mit einer Größe, die größer als die Segmentgröße ist
3E_0000 | Einschaltzeit
3E_0008 | Verbleibende Minuten bis zum nächsten internen Test


Textausgabe

Hard Disk Sentinel analysiert die durch die von der Festplatte bereitgestellten S.M.A.R.T.-Attribute und durch Auswerten dieser Werte wird eine textuelle Bewertung erstellt und angezeigt. Diese kann die Anzahl der Probleme enthalten, die während der Lebensdauer der Festplatte aufgetreten sind, die Probleme beim Hochfahren, die Datenübertragungsfehler usw. Die Hintergrundfarbe dieses Bereichs (grün, gelb, rot) zeigt den Zustand der Festplatte an. Der Textbereich kann Tipps zur Behebung der Probleme enthalten. Es wird daher empfohlen, die Details zu lesen.

Was ist der nächste Schritt?

Wenn der Gesundheitszustand der Festplatte unter 100 % liegt, bedeutet dies nicht unbedingt eine Katastrophe. Der angezeigte Integritätswert wird anhand aller Probleme berechnet, die jemals in der Lebensdauer der Festplatte aufgetreten sind. Solche Probleme werden alle in der internen Datenbank (der S.M.A.R.T.-Tabelle) der Festplatte aufgezeichnet und Hard Disk Sentinel liest und zeigt sie an.

Zunächst muss überprüft werden, ob diese Probleme weiterhin bestehen, ob sie bereits behoben wurden oder ob sich die Situation bereits verbessert hat. Wenn beispielsweise fehlerhafte Sektoren angezeigt werden, werden sie von der Festplatte nicht mehr verwendet und können auf keinen Fall aufgerufen werden (der Ersatzbereich wird anstelle der problematischen Sektoren verwendet). Aus diesem Grund zeigen Oberflächenscanner (z. B. Scandisk) keine Probleme, da sie auch den Ersatzbereich testen (siehe unten).

Auch wenn ein Hochfahrproblem angezeigt wird (was durch eine schwache Stromversorgung verursacht werden kann oder durch Probleme mit der Hauptstromleitung) und diese sind bereits behoben (z. B. die Stromversorgung wird ersetzt oder eine unterbrechungsfreie Stromversorgung (USV) installiert). Solche Probleme sind nicht mehr signifikant.

Am wichtigsten ist es festzustellen, ob der Festplattenstatus stabil ist oder nicht: wie sich der Integritätswert unter hoher Last und während der Langzeitnutzung ändert. Wenn der Integritätswert nicht zu hoch, aber stabil ist (sich nicht ändert), können die zuvor gefundenen Probleme ignoriert werden, da die Festplatte die neu zugewiesenen Sektoren nicht mehr verwendet und keine neuen fehlerhaften/schwachen Sektoren gefunden wurden (sofern die Textausgabe dies enthält).

Die beste Methode ist der datensichere Hardware-Selbsttest der Festplatte, mit dem überprüft werden kann, ob die aktuelle Situation stabil ist. Verschiedene Tests können über den Menüpunkt Laufwerk gestartet werden. Beide untersuchen die Komponenten der Festplatte (Köpfe, Servo, Firmware, interner Speicher), zudem überprüft der Erweiterte Selbsttest die gesamte Oberfläche des Laufwerks. Wenn solche Tests problemlos abgeschlossen werden (auch, wenn der Laufwerkszustand unter 100 % liegt), kann die Situation als stabil angesehen werden.

Werden bei einem oder beiden Tests Probleme gemeldet, wird empfohlen, für umfangreiche Tests eine andere Methode zu verwenden. Ein gutes Beispiel ist das Überschreiben der gesamten Festplattenoberfläche (nicht nur das Durchführen eines Lesetests). Dies kann durch die Oberflächentests erfolgen, die im Menüpunkt Laufwerk von Hard Disk Sentinel zur Verfügung stehen. Der beste Weg ist, die Methode Laufwerkoberfläche neu initialisieren zu verwenden, es stehen jedoch verschiedene weitere Tests zur Verfügung, um die Plattenoberfläche zu überprüfen. Schreibtests sind besser, da sie Probleme effektiv erkennen und reparieren können.

Wenn der Integritätswert und die angezeigte Textausgabe konstant sind, sich nach den Tests und über einen längeren Zeitraum nicht ändern, können die aktuellen Probleme als behoben angesehen werden. Auf diese Weise zeigt die Software sie nicht mehr an, zählt nur neue Probleme in der zukünftigen Verwendung - und bis kein Problem gefunden wird, wird der Integritätswert auf 100 % zurückgesetzt.
Um die vorhandenen Probleme zu beheben, öffnen Sie bitte die "S.M.A.R.T." -Seite der Festplatte und suchen Sie die Attribute, die Probleme anzeigen (diese sind mit Ausrufezeichen (!) gekennzeichnet). Klicken Sie auf die Spalte "Offset" und geben Sie einen negativen Wert ein, den Sie auch in der Spalte der "Daten"-Zeile sehen (und in der Textausgabe des Laufwerks). Wenn beispielsweise 5 neu zugewiesene Sektoren angezeigt werden, geben Sie "-5" in der Offset-Spalte des entsprechenden Attributs ein. Weitere Informationen zur Verwendung von Offsets finden Sie auf der Seite Temperaturkalibrierung.

Auf jeden Fall wird empfohlen, solche Festplatten kontinuierlich zu überwachen, insbesondere wenn zwei oder mehr verschiedene Probleme und/oder schwache Sektoren in der Textausgabe angezeigt werden. Eine solche Überwachung ermöglicht das Erkennen (auch kleiner) neuer Probleme und bietet in solchen Fällen die Möglichkeit, eine Sicherung durchzuführen. Die PRO-Version der Software kann dies automatisch erledigen.

Wenn der Gesundheitszustand niedrig ist, aber über 0% liegt, ist es nicht möglich, unter Garantiebedingungen einen Ersatz anzufordern. Zu diesem Zeitpunkt (unter Berücksichtigung des tatsächlichen Zustands oder der Testergebnisse) kann die Festplatte aus Sicht des Herstellers "zu wenige" Probleme haben - daher lehnen sie normalerweise den Garantieaustausch ab.
Grundsätzlich ist ein Garantieaustausch nur dann möglich, wenn die Anzahl der Probleme höher ist und den vom Hersteller festgelegten Schwellenwert erreicht. Zu diesem Zeitpunkt sinkt die Gesundheit auf 0 %.

Es ist wichtig zu wissen, dass ernsthafte Tests (und insbesondere die Hardwaretests) mehr Probleme aufdecken können und somit den Gesundheitswert weiter verringern können.

Vielleicht ist es möglich, die vom Hersteller bereitgestellte Testanwendung zu verwenden, um den Festplattenstatus zu überprüfen. Es ist wichtig zu wissen, dass einige dieser Probleme nicht wirklich behoben werden, sondern diese nur verbergen, sodass sie bei einer späteren Verwendung erneut auftreten können. Aus diesem Grund wird dringend empfohlen, nach Abschluss der Tests mit der Software des Herstellers die Festplatte kontinuierlich zu überwachen - insbesondere, wenn sich der Integritätswert in eine beliebige Richtung ändert.

Schlechte Sektoren?

Was ist ein "schlechter Sektor"? Wie sie entstanden und wie sie repariert werden können? Benutzer sind verwirrt, da beim Überprüfen der Festplattenoberfläche mittels Software (z. B. mithilfe von Windows Scandisk) keine Probleme oder fehlerhaften Sektoren gemeldet werden.

S.M.A.R.T. analysiert während des normalen Betriebs ständig die Plattenoberfläche. Wird ein problematischer Bereich gefunden(ein oder mehrere Sektoren, in denen die Daten schwer zu lesen oder zu schreiben sind), versucht er, die Daten zu lesen und in den Ersatzbereich zu kopieren (neu zuzuweisen). Der ursprüngliche Speicherort wird dann (intern) als fehlerhaft markiert, und alle weiteren Lese-/Schreibvorgänge, die auf den ursprünglichen Speicherort verweisen, werden dann in den freien Bereich umgeleitet.

Wenn der Vorgang abgeschlossen ist, ist der ursprüngliche (fehlerhafte) Bereich für die Software nicht mehr zugänglich. Selbst eine Neuinstallation oder eine vollständige Neuformatierung zeigt keine Probleme, da der ursprüngliche fehlerhafte Bereich nicht mehr verwendet wird. Aus diesem Grund findet Software (z. B. Windows Scandisk) keine problematischen Sektoren. Nur die Hardwarefunktion Sicheres Löschen greift auf diesen Bereich zu (auch auf das Löschen dieser Sektoren).

Aus diesem Grund zeigt beispielsweise der DOS-Befehl "format" auf den meisten modernen Festplatten wegen S.M.A.R.T. niemals fehlerhafte Sektoren an (außer, wenn der Ersatzbereich voll ist; es ist aber wirklich schwierig, eine solche Festplatte zu finden).

Die Neuzuweisung der Sektoren kann mit oder ohne Fehler abgeschlossen werden (Festplatten funktionieren jetzt viel besser im Vergleich zu älteren Modellen). Die Neuzuweisung kann jedoch zu Systeminstabilität führen, wenn dieser Zustand zu lange anhält.

Der Benutzer sollte nichts von den oben beschriebenen Schritten bemerken - nur wenn die Anzahl der fehlerhaften Sektoren hoch genug ist (der Schwellenwert erreicht ist) und S.M.A.R.T. dann einen möglichen Fehler voraussagt.

Ein sehr kleiner Kratzer oder Fleck auf der Plattenoberfläche kann einige fehlerhafte Sektoren verursachen. Ist die Anzahl der fehlerhaften Sektoren gering, verursachen sie normalerweise keine großen Probleme. Wenn jedoch ihre Anzahl ständig zunimmt (und der angezeigte Gesundheitswert abnimmt), können diese zu Fehlern führen. Es wird empfohlen, die Festplatte ständig zu überwachen, wenn sie nicht zu 100% perfekt ist.

SSD-Gesundheit - Perfekte SSD mit geringer Gesundheit?

Die Textausgabe kann beinhalten, dass die SSD perfekt ist, aber der Zustand relativ schlecht ist. Dies kann passieren, wenn die SSD keine Fehler, keine Anzeichen für fehlerhafte Sektoren (fehlerhafte Speicherzellen) oder ähnliche Probleme aufweist.

Aufgrund des Verschleißes der Speicherzellen, der durch Schreibvorgänge auf die SSD verursacht wird, nimmt der Zustand der SSD jedoch kontinuierlich ab. Die Funktion Verschleißausgleich (Wear-Leveling) der SSD versucht, diesen Effekt zu minimieren - kann ihn jedoch nicht vollständig beseitigen.

Der aktuelle Zustand dieser SSD wird durch einige spezifische S.M.A.R.T.-Attribute bestimmt, zum Beispiel Nr. 209 "Remaining Drive Life" (oder ein oder mehrere andere Attribute), wie von Hard Disk Sentinel erwähnt. Wenn Sie dieses Attribut auf der S.M.A.R.T.-Seite wählen, können Sie überprüfen, wie es sich im Laufe der Zeit in der Grafik unter der Liste verändert hat.

Ist der Zustand der SSD niedrig, könnten die in Speicherzellen gespeicherten Daten beschädigt werden oder verloren gehen.

Festplatten sind von diesem (Verschleiß-) Effekt nicht betroffen, sodass es möglich ist, viele Festplatten mit 100 % Gesundheit zu finden (auch nach Jahren des Gebrauchs). Im Gegensatz dazu nimmt der Zustand der SSDs im Laufe der Zeit stetig ab.

Festplattentest

Es wird empfohlen, den Festplattenstatus regelmäßig zu analysieren und zu überprüfen (insbesondere dann, wenn die Festplatte nicht perfekt ist, der Zustand unter 100 % liegt). Hard Disk Sentinel bietet eine große Anzahl von Tests im Menüpunkt Laufwerk: einschließlich Hardware-Selbsttests, um die Funktionalität der Festplattenkomponenten und der gesamten Oberfläche zu analysieren. Diese Hardwaretests können über den Menüpunkt Laufwerk gestartet werden, der Informationsseite oder automatisch (geplant) auf der Seite Operationen (nur Professional-Version).

Auch der Menüpunkt Laufwerk Oberflächentest kann verwendet werden, um die Plattenoberfläche mit Lese- und Schreibtests zu überprüfen, Festplattenprobleme aufzudecken und zu beheben.